Results 1 to 5 of 5

Thread: Stalks retrofit - how do I enable onboard computer?

  1. #1
    Verified VCDS User
    Join Date
    Sep 2016
    Location
    US
    Posts
    42
    Post Thanks / Like

    Stalks retrofit - how do I enable onboard computer?

    I have an Audi B8 (2010 Audi Avant) with Premium trim, which does not have the onboard computer functionality. Through VCDS I was able to allow it to show in the MMI, so I can manually change the display to show AVG MPG vs Current MPG (for example).

    However, I want the onboard computer controls through the stalks like the Premium Plus trim offers. So I replaced my stalks this weekend with ones that have the onboard computer controls. Everything went fine and works normally, however the onboard computer controls on the new stalks do not yet work. I assume there is a VCDS setting that I need to update to enable those.

    Does anyone know how to activate those through VCDS?
    Last edited by 4lane; 11-28-2016 at 02:05 PM.

  2. #2
    Verified VCDS User Mrclopec's Avatar
    Join Date
    May 2015
    Location
    Nipomo, CA
    Posts
    193
    Post Thanks / Like
    A great start would be to post a complete auto scan of your vehicle to see exactly what you're working with.
    Last edited by Uwe; 11-28-2016 at 03:59 PM. Reason: Added link
    I retrofit not because I settled for a car that didn't have everything. I retrofit for the challenge!

  3. Likes Uwe, Eric liked this post
  4. #3
    Verified VCDS User
    Join Date
    Sep 2016
    Location
    US
    Posts
    42
    Post Thanks / Like
    I believe the changes are needed in

    17-Instruments, and possibly, 16-Steering Wheel

    But I'm not entirely clear on the exact changes that need to be made to enable DIS through the wiper stalks.

  5. #4
    Verified VCDS User
    Join Date
    Nov 2016
    Location
    USA
    Posts
    18
    Post Thanks / Like
    If you post a scan you'll be more likely to receive help.

  6. Likes Eric, Mrclopec liked this post
  7. #5
    Verified VCDS User
    Join Date
    Sep 2016
    Location
    US
    Posts
    42
    Post Thanks / Like
    I did get the stalks working properly making the following changes tonight.

    Module, Byte, Bit, Old, New
    16, 2, 1, 0, 1
    17, 1, 2, 0, 1
    17, 1, 3, 0, 1
    56, 9, 6, 0, 1

    I ran a scan after I made the stalk replacement and changes above (did not clear codes yet). Here are the scan results.

    Code:
    Removed.   Guess why?
    Last edited by Uwe; 11-28-2016 at 11:19 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •