Results 1 to 7 of 7

Thread: Error code 11 during Update

  1. #1
    Verified VCDS User 949BFN's Avatar
    Join Date
    May 2016
    Location
    South Africa
    Posts
    32
    Post Thanks / Like

    Error code 11 during Update

    Received my Hex-Net interface today. First impressions are that it is an awesome upgrade from the previous USB version.

    I have however encountered an issue during the firmware update process. The Windows configuration app displayed "Error Code 11" during the update process.

    (I have a screenshot, but I still have to figure out how to upload a picture to this forum and don't have the time to look into that at the moment.)

    The interface is connected to the laptop with the USB cable.

    The steps leading up to this were:
    1. Ran HexNetConfig.jar
    2. Checked for updates. Updates were found and downloaded
    3. Received a message that data will be written to the interface and pop up screens should be OK'ed
    4. After about a minute or 2 , there was no movement of the progress bars. That is when I noticed the update utility reported the following:
    Update found!
    Changelog DS: 10000045
    Features:
    * New Label Files
    * New ASAM data
    Applying update...
    Downloading DS update
    Error code -11
    5. The interface is still connected to the laptop and I did not touch the Configuration App yet - to scared it will destroy the interface.
    The green LED on the interface is flashing, whilst the red LED is constantly red.

    Any suggestions as to what I should do next please? Will I destroy the interface if I unplug it from the laptop?


    Other info: Laptop is a Macbook Air running Windows 10 VM in Parallels (very latest version with all updates installed).
    2017 Audi SQ5 (ACC, HUD, B&O Sound, Virtual Cockpit, Navigation, City Assistance, Matrix LED, Towbar. Mods: Active Lane Assist)

    2019 VW Amarok 3.0 Extreme

    HEX-NET Interface

  2. #2
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    24,639
    Post Thanks / Like
    Blog Entries
    1
    If it were me, I would un-plug and re-try.

    Are you running the Java updater in Windows in a VM?

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  3. #3
    Verified VCDS User 949BFN's Avatar
    Join Date
    May 2016
    Location
    South Africa
    Posts
    32
    Post Thanks / Like
    Hi Uwe. Yes, I was. I was worried that I've messed up the interface because the firmware update failed. I have since tried the update on a different laptop (Sony, running Windows 10), but the update still fails, although somewhat differently. On the Sony, it gets to a stage where the app reports "Applying update". The "Setting Up" progress bar is at 99/100% (appears to be at maximum), with the "Applying update" progress bar at approximately 60%. The "Go Back" button is greyed out at this point.
    That is however the furthest it got. Nothing happens after this. The Green LED keeps flashing with the other LED solid Red.
    Running Beta 16.5; Interace: CB: 0.4316; FW: 0.244; CFB: 0.10; BL: 0.27; DS: 100000042 (as reported by the HexNet Config Java App).
    2017 Audi SQ5 (ACC, HUD, B&O Sound, Virtual Cockpit, Navigation, City Assistance, Matrix LED, Towbar. Mods: Active Lane Assist)

    2019 VW Amarok 3.0 Extreme

    HEX-NET Interface

  4. #4
    Ross-Tech Employee
    Join Date
    Jan 2014
    Location
    USA
    Posts
    831
    Post Thanks / Like
    Do you hear the HEX-NET re-enumerate or see a pop-up about a device being connected at this point? The utility needs to copy files to the interface, and it seems to be unable to find it in this case. If you are in a virtual machine, you might need to select an option to give control of the HEX-NET to the virtual machine.

  5. #5
    Verified VCDS User 949BFN's Avatar
    Join Date
    May 2016
    Location
    South Africa
    Posts
    32
    Post Thanks / Like
    Thanks Shaun. The references to the VM by you guys, made me remember that I've had issues updating iPods on the the VM as well. I tried the update a second time on a "normal" Windows laptop and the second attempt succeeded.
    I suppose the lesson learned is that one should stay away from VM's when doing firmware updates which requires the USB the device to restart as part of the update process.
    2017 Audi SQ5 (ACC, HUD, B&O Sound, Virtual Cockpit, Navigation, City Assistance, Matrix LED, Towbar. Mods: Active Lane Assist)

    2019 VW Amarok 3.0 Extreme

    HEX-NET Interface

  6. Likes Andy, jyoung8607, Uwe, Dana liked this post
  7. #6
    Administrator Andy's Avatar
    Join Date
    Jan 2014
    Location
    Sector 7G
    Posts
    2,510
    Post Thanks / Like
    Once you are connected in Infrastructure Mode, you can always have VCDS-Mobile do the updates as well. That way you are letting the HEX-NET connect directly (well, sort of) to the update server without it mattering whether you are using a browser in a native OS or in a virtual machine.

  8. Likes Uwe, Dana liked this post
  9. #7
    Verified VCDS User 949BFN's Avatar
    Join Date
    May 2016
    Location
    South Africa
    Posts
    32
    Post Thanks / Like
    Quote Originally Posted by Andy View Post
    Once you are connected in Infrastructure Mode, you can always have VCDS-Mobile do the updates as well. That way you are letting the HEX-NET connect directly (well, sort of) to the update server without it mattering whether you are using a browser in a native OS or in a virtual machine.
    I'll remember that.

    Must say, so far I'm very impressed with the HEX-NET. Holding thumbs that the label files for my vehicle's modules will be added soon.
    2017 Audi SQ5 (ACC, HUD, B&O Sound, Virtual Cockpit, Navigation, City Assistance, Matrix LED, Towbar. Mods: Active Lane Assist)

    2019 VW Amarok 3.0 Extreme

    HEX-NET Interface

  10. Likes jyoung8607, Dana liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •