Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: B8 A4 Avant LED Tail Light Retrofit

  1. #1
    New User
    Join Date
    Apr 2016
    Location
    USA
    Posts
    4
    Post Thanks / Like

    B8 A4 Avant LED Tail Light Retrofit

    Hello all, new user here looking for some assistance with coding for European LED tail lamps retrofitted to a US 2012 A4 Avant. I followed a DIY method using this thread from Audizine for guidance: http://www.audizine.com/forum/showth...aillight-howto

    The lights are fully functioning, but I'm now getting error codes for the blinkers and fog lights. Hoping someone on here may have tackled this project before and could provide some guidance or coding knowledge.

    Many thanks!

    -Chris

  2. #2
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    25,926
    Post Thanks / Like
    Blog Entries
    1
    If possible, please post and Auto-Scan so people can see how your car is equipped and configured.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  3. #3
    New User
    Join Date
    Apr 2016
    Location
    USA
    Posts
    4
    Post Thanks / Like
    Thanks for the reply, I'll see if I can get that scanned this week.

  4. #4
    Verified VCDS User rlarsen's Avatar
    Join Date
    May 2015
    Location
    Copenhagen, Denmark
    Posts
    288
    Post Thanks / Like
    The guide isn't detailed enough, the coding change from Bulb to LED is missing.

    Have a look at the table below - where you need to re-calculate the value of Channel 181, and if this doesn't work then re-calculate the value of Channel 191 instead - or just set the value to 0:

    Rene Larsen

    Audi A4 Avant 3.0 TDI quattro tiptronic MY2009 - sold
    VCDS 19.6.2
    (HEX-V2)

  5. Likes Uwe liked this post
  6. #5
    New User
    Join Date
    Apr 2016
    Location
    USA
    Posts
    4
    Post Thanks / Like
    Gotcha, I'll try this. Thanks for the help Rene.

  7. #6
    New User
    Join Date
    Apr 2016
    Location
    USA
    Posts
    4
    Post Thanks / Like
    That did the trick! Thanks again for the assistance.

  8. Likes Uwe liked this post
  9. #7
    Verified VCDS User
    Join Date
    Feb 2019
    Location
    Miami, Fl
    Posts
    8
    Post Thanks / Like
    Quote Originally Posted by rlarsen View Post
    The guide isn't detailed enough, the coding change from Bulb to LED is missing.

    Have a look at the table below - where you need to re-calculate the value of Channel 181, and if this doesn't work then re-calculate the value of Channel 191 instead - or just set the value to 0:



    Do you convert this from binary to decimal? Or something else?
    |2012|A4|Avant|S-Line|Ibis|
    |2.0TFSI|Quattro|ZF-8Trans|
    |Custom CAI|P3 Gauge V1|
    |Luft-Tecknik Intercooler|
    |Exhaust Cutout|
    IG:RS4M8
    Blog Here
    *Vag-Com available to use locally or rent pm for details*

  10. #8
    Verified VCDS User rlarsen's Avatar
    Join Date
    May 2015
    Location
    Copenhagen, Denmark
    Posts
    288
    Post Thanks / Like
    Quote Originally Posted by Planekiller1 View Post
    Do you convert this from binary to decimal? Or something else?
    You read the decimal value from a channel - then you convert this value into a binary string - you can e.g. use the built in Windows Calculator, which I have created a small pdf about: Modifying Channel values with the help of Windows Calculator.pdf

    Rene Larsen

    Audi A4 Avant 3.0 TDI quattro tiptronic MY2009 - sold
    VCDS 19.6.2
    (HEX-V2)

  11. #9
    Verified VCDS User
    Join Date
    Feb 2019
    Location
    Miami, Fl
    Posts
    8
    Post Thanks / Like
    Quote Originally Posted by rlarsen View Post
    You read the decimal value from a channel - then you convert this value into a binary string - you can e.g. use the built in Windows Calculator, which I have created a small pdf about: Modifying Channel values with the help of Windows Calculator.pdf

    Ok I got 12044 with no errors on 181.
    Still getting double flash on the cluster however the lights and blinking at normal rate front mirror and rear all working right.
    All lights function as they should only issue is the cluster now.
    Thanks for the help looking forward to solving the cluster issue too.
    Kurt
    |2012|A4|Avant|S-Line|Ibis|
    |2.0TFSI|Quattro|ZF-8Trans|
    |Custom CAI|P3 Gauge V1|
    |Luft-Tecknik Intercooler|
    |Exhaust Cutout|
    IG:RS4M8
    Blog Here
    *Vag-Com available to use locally or rent pm for details*

  12. #10
    Verified VCDS User rlarsen's Avatar
    Join Date
    May 2015
    Location
    Copenhagen, Denmark
    Posts
    288
    Post Thanks / Like
    Quote Originally Posted by Planekiller1 View Post
    Ok I got 12044 with no errors on 181.
    Still getting double flash on the cluster however the lights and blinking at normal rate front mirror and rear all working right.
    All lights function as they should only issue is the cluster now.
    Thanks for the help looking forward to solving the cluster issue too.
    Kurt
    I don’t have the cure for this - but I’ve heard that some has got this fixed by using VCP or OBDeleven with their coding script - because they both do some kind of a flash of the unit.
    Rene Larsen

    Audi A4 Avant 3.0 TDI quattro tiptronic MY2009 - sold
    VCDS 19.6.2
    (HEX-V2)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •