Page 17 of 17 FirstFirst ... 7151617
Results 161 to 163 of 163

Thread: Testbench setup?

  1. #161
    Verified VCDS User
    Join Date
    Nov 2017
    Location
    Latvia
    Posts
    134
    Post Thanks / Like
    Need some help with CAN signal pairing between different generations...

    Current bench test setup:
    - 1K0 gateway (1K0907530C) from VW MK5. Obviously it has Convenience and Diagnostic CAN buses. Other ones doesn't matter now.
    - Parking aid ECU from Audi A6 C5. It has K2 line for diagnostics and Convenience CAN as shown in Elsa diagrams. A6 C5 facelift instrument cluster acts as "gateway" just like on newer cars. But because of instrument cluster is so bulky I'd like to wake up parking aid ECU with some real gateway which is many times smaller in size.

    I can connect gateway with VCDS, but parkings doesn't want to open a connection to K2.
    Parking aid ECU is ok, was tested in real A6 C5 car.
    Tried with parkings checked in installation list and unchecked. Didn't help either way.
    Wiring rechecked multiple times.

    Voltages on convenience CAN-H = (0.25V ... 0.32V changing) and CAN-L = (4.64V ... 4.75V changing) with parking ECU connected (don't have a scope for now, but analogue multimeter shows it).
    Voltages on convenience CAN-H = (2.53V) and CAN-L = (2.46V) with everything disconnected (except gateway itself).

    Isn't it possible?

  2. #162
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    23,816
    Post Thanks / Like
    Blog Entries
    1
    Quote Originally Posted by _Val View Post
    Isn't it possible?
    I am skeptical that it is possible. C5 Audi uses almost certainly used older CAN protocols (TP1.6) vs. Mk5 (TP2.0).

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  3. #163
    Verified VCDS User
    Join Date
    Apr 2014
    Location
    Acton, Ontario, Canada
    Posts
    45
    Post Thanks / Like
    Great thread and thanks for all the help. I've been able to log onto the RNS510 and alter the settings. Awesome input from everyone. Thanks again.
    Thanks Brett

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •