Results 1 to 9 of 9

Thread: Updating HEX-NET version via "web interface"

  1. #1
    Verified VCDS User
    Join Date
    Feb 2014
    Location
    Central IL
    Posts
    18
    Post Thanks / Like

    Updating HEX-NET version via "web interface"

    While HEX-NET works fine when connected to the car, when connected in Infrastructure via the updater, it's asking to be updated via a "web interface" when using the updater v.1.963. There is no interface listed in the updater apart from the HEX-NET unit itself. Wondering what is meant by the "web interface?"

    Log:

    Checking for updates...
    Update found!

    Changelog:
    CB: 0.4222
    The update to CB V0.4201 must be done through the web interface.
    The USB update process has changed behind the scenes,
    V0.4201 supports functions for the new V2.001 update utility.

  2. #2
    FoRT jyoung8607's Avatar
    Join Date
    Feb 2014
    Location
    Cincinnati, OH
    Posts
    2,443
    Post Thanks / Like
    Hello John,

    Been here? Ross-Tech has a walkthrough of the process:

    http://forums.ross-tech.com/showthre...-use-with-15-7

    You should also register your interface so that you can post in the HEX-NET Beta Support forum:

    http://forums.ross-tech.com/showthre...o-get-Verified

    Jason

  3. Likes Uwe liked this post
  4. #3
    Verified VCDS User
    Join Date
    Feb 2014
    Location
    Central IL
    Posts
    18
    Post Thanks / Like
    I want to thank you again for the link to the thread about updating. I think it identified my problem, even if it didn't provide a solution. There appears to be an ongoing issue with the ability of Ross-Tech's server to perform multiple updates. I'm getting the same 'internal server error' message as some others, and evidently a fix is not yet forthcoming. Oh, well, at least I know it's nothing I've done or don't understand at this point.

  5. #4
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    28,431
    Post Thanks / Like
    Blog Entries
    1
    Yeah, that interface is WAY behind the times and we suspect an issue with the dependency chain on the server. I'm it will get resolved next week.

    -Uwe-
    Lock-down of sick people: Quarantine
    Lock-down of healthy people: Tyranny

  6. #5
    Verified VCDS User
    Join Date
    Feb 2014
    Location
    Central IL
    Posts
    18
    Post Thanks / Like
    This morning I was successful in initiating the update process via my web browser (Chrome). After a number of update cycles (too numerous to list, it would probably be easier to list what wasn't updated than what was) I finally got a "You are up to date" message. When I get the time, I will hook up the HEX-NET to the car again and see if the full range of function in VCDS is now accessible.

    The "About" button on the VCDS-Mobile menu yielded:

    VCDS-Mobile
    Codebase: Mar 11 2016 - 19:36:26

    CodeBlock V0.4309
    FW version: 0.238
    Dataset: 10000039

    LSN: 000100-00014E-525D30-930000-648603-6C848A-06
    VSN: 0010D5-00EE04-011000-003900-180008-0100FF-FF0000-1F8E

    VINs: 1/10
    Faultcodes Cleared: 0

  7. Likes Uwe, jyoung8607 liked this post
  8. #6
    Verified VCDS User
    Join Date
    Feb 2014
    Location
    Central IL
    Posts
    18
    Post Thanks / Like
    I had a little time, so I hooked up the updated HEX-NET to our car ('13 VW Passat TDI) and activated in infrastructure mode. As far as I can determine, it's able to access the "extended" functions that are not supported in the HEX-NET device itself. I was unable to determine any more (what I would like to do is run a procedure, activating the fuel pump for starters seems simple enough), but may be able to accomplish that later today. So far, so good.

  9. Likes Uwe, jyoung8607, Andy liked this post
  10. #7
    Verified VCDS User
    Join Date
    Feb 2014
    Location
    Central IL
    Posts
    18
    Post Thanks / Like
    I can now state that the HEX-NET is working, as I managed to do a complete procedure this morning. I successfully connected, selected 01 (Engine) —> 04 (Basic Settings) —> 035 (Test transfer pump, number not given, this was from a drop-down list of what are evidently regarded as common procedures). The pump activated (and was audible). Ran pump for about 30 seconds, stopped, and backed out of the HEX-NET menu system. (I can now change my fuel filter. Yay!)
    The catch to using HEX-NET is to have a good wi-fi signal in the area, and at range (it's probably 100 feet from our detached garage to the router in the house) wi-fi can be notoriously fickle from day to day. Two days ago when I first tested the system, I had a full-strength signal. Today, it was marginal, causing everything to run slowly. In fact, I had to walk partway back to the house to get my tablet to connect to the network. Fortunately, the HEX-NET was able to access the network from within the car, sufficient to get the job done. I may dig out a spare router and configure it as a WAP for the garage, but this only points out how those HEX-NET users without a modicum of knowledge of wi-fi networks and Internet knowledge generally can find themselves at sea trying to accomplish this.

  11. Likes jyoung8607, Eric, Bruce, Dana, Uwe liked this post
  12. #8
    Verified VCDS User
    Join Date
    Feb 2014
    Location
    Central IL
    Posts
    18
    Post Thanks / Like
    Ran an Auto-Scan, and decided that the next step is to try to extend better Internet coverage into the garage. I'll wait to post that until I become "verified," that way I can post my network machinations under the HEX-NET category.

  13. #9
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    28,431
    Post Thanks / Like
    Blog Entries
    1
    Looks like you're Verified to me...

    -Uwe-

    PS: Moved to HEX-NET Beta support.
    Last edited by Uwe; 03-28-2016 at 08:35 PM.
    Lock-down of sick people: Quarantine
    Lock-down of healthy people: Tyranny

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •