Results 1 to 9 of 9

Thread: Audi Q7 DPF regeneration

  1. #1
    New User
    Join Date
    May 2015
    Location
    UK
    Posts
    5
    Post Thanks / Like

    Audi Q7 DPF regeneration

    Hi,

    I'm having some trouble regenerating my DPF on my 2008 Audi Q7 3.0L Diesel.

    I've seen a video on YouTube showing a Q5 having it's DPF regenned successfuly:



    So I thought it would work on my Q7 as the engine ID is practically the same. However, I am getting errors such as "redir labels fail" and "no documentation available".

    Is there something i'm missing, do I need to download a new labels file? My VCDS appears to be the newest available, it's official too, bought from a UK distributor.

    Here is the output from VCDS:

    Code:
    Friday,29,May,2015,11:12:38:45112
    VCDS -- Windows Based VAG/VAS Emulator
    VCDS Version: 14.10.2.0 (x64)
    Data version: 20150311
    www.Ross-Tech.com
    
    
    VIN: WAUZZZ4L88D059448   License Plate: MJ08 TYW
    Mileage: 94140km-58495mi   Repair Order: 
    
    
    
    --------------------------------------------------------------------------------
    --------------------------------------------------------------------------------
    
    
    Chassis Type: 4L (4L0)
    Scan: 01 02 03 05 07 08 09 0E 15 16 17 18 19 34 42 46 47 4F 52 56
              61 62 6F 72 76
    
    VIN: WAUZZZ4L88D059448   Mileage: 94140km-58495miles
    
    00-Steering Angle Sensor -- Status: OK 0000
    01-Engine -- Status: Malfunction 0010
    02-Auto Trans -- Status: OK 0000
    03-ABS Brakes -- Status: OK 0000
    05-Acc/Start Auth. -- Status: OK 0000
    07-Control Head -- Status: Malfunction 0010
    08-Auto HVAC -- Status: OK 0000
    09-Cent. Elect. -- Status: OK 0000
    0E-Media Player 1 -- Status: OK 0000
    15-Airbags -- Status: OK 0000
    16-Steering wheel -- Status: OK 0000
    17-Instruments -- Status: OK 0000
    18-Aux. Heat -- Status: Malfunction 0010
    19-CAN Gateway -- Status: OK 0000
    34-Level Control -- Status: Malfunction 0010
    42-Door Elect, Driver -- Status: OK 0000
    46-Central Conv. -- Status: OK 0000
    47-Sound System -- Status: Malfunction 0010
    4F-Centr. Electr. II -- Status: OK 0000
    52-Door Elect, Pass. -- Status: OK 0000
    56-Radio -- Status: OK 0000
    61-Battery Regul. -- Status: OK 0000
    62-Door, Rear Left -- Status: OK 0000
    6F-Centr. Conv. II -- Status: OK 0000
    72-Door, Rear Right -- Status: OK 0000
    76-Park Assist -- Status: OK 0000
     
    -------------------------------------------------------------------------------
    Address 01: Engine (CAS)       Labels: Redir Fail!
       Part No SW: 4L1 910 401 D    HW: 4L0 907 401 A
       Component: 3.0TDI EDC17G100AG  0080  
       Revision: --H01---    Serial number:               
       Coding: 0121002C190F0168
       Shop #: WSC 00482 210 91427
       VCID: 24404D4BE76BC7012A7-8071
    
    4 Faults Found:
    009263 - Diesel Particulate Filter (Bank 1) 
                   P242F - 001 - Restricted/Clogged - MIL ON
                 Freeze Frame:
                        Fault Status: 11100001
                        Fault Priority: 2
                        Fault Frequency: 1
                        Reset counter: 255
                        Mileage: 94133 km
                        Time Indication: 0
                        Date: 2015.05.27
                        Time: 10:50:37
    
                 Freeze Frame:
                        RPM: 0 /min
                        Speed: 0.0 km/h
                        (no units): 33.0
                        (no units): 39.5
                        Mileage: 840 km
                        (no units): 0.0
                        (no units): 24.0
    
    008194 - Particulate Trap Bank 1 
                   P2002 - 008 - Efficiency Below Threshold
                 Freeze Frame:
                        Fault Status: 01101000
                        Fault Priority: 2
                        Fault Frequency: 1
                        Reset counter: 255
                        Mileage: 94133 km
                        Time Indication: 0
                        Date: 2015.05.27
                        Time: 10:50:37
    
                 Freeze Frame:
                        RPM: 0 /min
                        Speed: 0.0 km/h
                        (no units): 33.0
                        (no units): 39.5
                        Mileage: 840 km
                        (no units): 0.0
                        (no units): 24.0
    
    001592 - Throttle Body Actuator Bank 1 (J338) 
                   P0638 - 000 - Implausible Signal - MIL ON
                 Freeze Frame:
                        Fault Status: 11100000
                        Fault Priority: 2
                        Fault Frequency: 2
                        Reset counter: 255
                        Mileage: 94133 km
                        Time Indication: 0
                        Date: 2015.05.27
                        Time: 10:50:39
    
                 Freeze Frame:
                        RPM: 0 /min
                        Speed: 0.0 km/h
                        Lambda: 99.2 %
                        Temperature: 16.2°C
                        Temperature: 23.4°C
                        Lambda: 4.7 %
                        Voltage: 11.93 V
    
    008213 - Intake Manifold Flap Position Sensor (Bank 1) 
                   P2015 - 003 - Implausible Signal
                 Freeze Frame:
                        Fault Status: 01100011
                        Fault Priority: 2
                        Fault Frequency: 1
                        Reset counter: 255
                        Mileage: 94148 km
                        Time Indication: 0
                        Date: 2015.05.29
                        Time: 10:58:59
    
                 Freeze Frame:
                        RPM: 1092 /min
                        Speed: 0.0 km/h
                        Voltage: 11.25 V
                        Lambda: 0.0 %
                        Lambda: 0.0 %
                        Voltage: 0.540 V
                        Bin. Bits: 00000000
    Any help would be much appreciated, thanks!
    Last edited by Uwe; 05-31-2015 at 12:44 PM. Reason: QUOTE -> CODE

  2. #2
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    26,398
    Post Thanks / Like
    Blog Entries
    1
    the engine ID is practically the same
    Except that the ECU in the video uses the UDS protocol for diagnostics and yours doesn't. That means procedures are completely different.

    I don't have a procedure for your engine handy, but I'm fairly confident you need to address the 001592/P0638 and 008213/P2015 codes before you will be able to run a successful regeneration in any case.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  3. #3
    New User
    Join Date
    May 2015
    Location
    UK
    Posts
    5
    Post Thanks / Like
    Hi,
    is there even a way to do the regen for this particular model then?

    I've tried as per in the video and it doesn't work and i've also tried the coding II input (10016) and that didn't work either.

    Problem is even if I fix those errors you mention i'll still be stuck in limp mode.

  4. #4
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    26,398
    Post Thanks / Like
    Blog Entries
    1
    I'm confident there's a way to force a regen -- provided the soot loading isn't too high yet, and provided the other issues are dealt with first.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  5. #5
    Ross-Tech Employee Sebastian's Avatar
    Join Date
    Feb 2014
    Location
    Magdeburg, Germany
    Posts
    1,948
    Post Thanks / Like
    What are your readings in MVB 104 and 107?
    Sebastian @ Ross-Tech.com // VCDS Rookie since 2003

    »Nichts erweitert das eigene Wissen mehr,
    als die Meinung eines Andersdenkenden.«

  6. #6
    New User
    Join Date
    May 2015
    Location
    UK
    Posts
    5
    Post Thanks / Like


    Hi,

    here are the readings as requested, thanks

  7. #7
    VCDS Distributor
    Join Date
    Feb 2014
    Location
    Denmark
    Posts
    1,896
    Post Thanks / Like
    Quote Originally Posted by winx1 View Post
    Is there even a way to do the regen for this particular model then?
    I've tried as per in the video and it doesn't work and i've also tried the coding II input (10016) and that didn't work either.
    Problem is even if I fix those errors you mention i'll still be stuck in limp mode.
    Yes there is way for regeneration on every Model.
    The problem is, as Uwe wrote, if you don't fix the error, you will not be able to do regeneration!

    The ash amount is 0.20 liter, maximum is 036 l (From the your screen shot).
    Soot amount calculated is 42.0 g and Soot amount measured is 37.0 g.
    The threshold of soot is 38.5 g (MWB 107.2) where you get:
    009263 - Diesel Particulate Filter (Bank 1)
    P242F - 001 - Restricted/Clogged - MIL ON

    If you have 59.5 g in 104.2 you can buy a new filter, if you don't get below that value first!

    The procedure showed in the Video is okay, but if your button [Coding II-11] is not greyed out, you may have to use that with the login.
    Enough fuel in the tank, temperatures okay, all electrical consumers on.
    But as your ECU is not UDS, you start [Basic settings-04] and choose MWB 226 direct.

    When MWB 104.2 is above 31.5 g (in your case now, it varies in other cases) the engine will start a regeneration when conditions are correct while driving.

    PS. You have not registered the forum yet?

  8. Likes Zenerdiode liked this post
  9. #8
    New User
    Join Date
    May 2015
    Location
    UK
    Posts
    5
    Post Thanks / Like
    Hi,

    thanks for the reply.

    So from what you are saying it is probably not the DPF that is causing the "limp mode" (power loss) but rather the Mass airflow/throttle body error?

    thanks

  10. #9
    New User
    Join Date
    May 2015
    Location
    UK
    Posts
    5
    Post Thanks / Like
    Hi,

    I managed to start the test:





    But when I do full throttle:



    I've tried doing just the brake, brake and accelerator together all different sequences but it doesn't work


    any ideas?

    thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •