Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: 03 Avant bulb out messages

  1. #21
    Verified VCDS User
    Join Date
    Feb 2020
    Location
    Oregon, USA
    Posts
    17
    Post Thanks / Like
    As far as I can tell I've removed the Curt wiring controller from the equation. The module it's self sits behind the driver's side tail light assembly. To get to it I'd have to remove quite a few things including that parcel shelf and the sub box built into it. That is not something I look forward to doing.

    It only had 2 wires going to the right side, power and a green wire tied into a Green/BLK wire. I have no idea what that gen/BLK wire is as it doesn't show up in my Chilton's.


    Today I'm going to focus on the front as it has started doing similar things as the rear. I'm going to swap a completely untouched headlight into it. The ones I'm currently running have been opened and painted plus a projector retrofit. Looking at the front blinker it's almost like the blinker and running filaments are shorting together.

  2. #22
    Verified VCDS User
    Join Date
    Feb 2020
    Location
    Oregon, USA
    Posts
    17
    Post Thanks / Like
    Compared these OEM (painted and projector swapped) housings with my spare OEM housings. The old OEM doesn't seem to make the same shenanigans happen. The other OEM housings have the blinker/parking tabs wired wrong. The ground and parking lamp are swapped. It's been a blast for the last 20 minutes to get one of the 2 pins in place working through that 1" diameter hole. One to go! Wish me luck! Really don't want to have to split the housings. Hope this fixes things. If so, I'm going back to my original CECM and returning the replacement I got, that doesn't illuminate my rear fog.

  3. #23
    Verified VCDS User PetrolDave's Avatar
    Join Date
    Dec 2014
    Location
    South Molton, UK
    Posts
    2,994
    Post Thanks / Like
    Quote Originally Posted by Deerhurst View Post
    If so, I'm going back to my original CECM and returning the replacement I got, that doesn't illuminate my rear fog.
    I was going to ask about the CECM, with the worsening problems I was beginning to suspect that the CECM could be faulty, maybe because of water damage (which is not uncommon in B6 and B7 A4/S4/RS4 models).

  4. Likes Uwe liked this post
  5. #24
    Verified VCDS User
    Join Date
    Feb 2020
    Location
    Oregon, USA
    Posts
    17
    Post Thanks / Like
    Quote Originally Posted by PetrolDave View Post
    I was going to ask about the CECM, with the worsening problems I was beginning to suspect that the CECM could be faulty, maybe because of water damage (which is not uncommon in B6 and B7 A4/S4/RS4 models).
    No apparent water damage to either CECM. The replacement one works worse than my original and will be sent back after a couple days of no issues.

    After about 45 minutes of nothing polite to say I finally got the 2 pins swapped on the bulb holder socket without taking the lens off. Checked the pinout. All of the pinout diagrams Ive found on the internet are for the drivers side headlight. The passenger side is mirrored. The pins that were swapped was the running lamp and ground pins. These pins were swapped when the light was built, not something I did. Yes, they are OEM Valeo and not aftermarket junk. I havnt found an aftermarket light with the autolevelling motors yet.

    All tested fine in the garage. No more blinking taillight and no more weird filament stuff in the front. Swapped my original CECM back in and I have a rear fog again! Yay!


    Shall see how it goes on the way to work tomorrow. Wish me luck!
    2003 A4 3.0 6MT Avant
    1986.5 Nissan Hardbody SE-V6 4x4 VG33 swapped

  6. Likes Uwe, PetrolDave liked this post
  7. #25
    Verified VCDS User
    Join Date
    Feb 2020
    Location
    Oregon, USA
    Posts
    17
    Post Thanks / Like
    Day one.

    The warnings have not returned! Yay!

    I'll wait one more day and call it. Then back to reinstalling the demon eyes.

  8. Likes Uwe liked this post
  9. #26
    Verified VCDS User
    Join Date
    Feb 2020
    Location
    Oregon, USA
    Posts
    17
    Post Thanks / Like
    Day 3. Mark this one up as solved! That's for the help, guys!

  10. Likes Uwe liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •