Results 1 to 2 of 2

Thread: When using a script, the value is not found.

  1. #1
    Verified VCDS User
    Join Date
    Sep 2019
    Location
    S.Korea
    Posts
    3
    Post Thanks / Like

    When using a script, the value is not found.

    I use script well.
    Always thank you.

    Often when I use some scripts I can't find a value.
    For example

    StartVCDS ()
    OpenUnit ("09")
    LoginToUnit ("31347")
    ChangeAdpChannel ("Leuchte23SL HLC10-Dimming Direction EF 23", "minimize")
    ChangeAdpChannel ("Leuchte24SL HRA65-Dimming Direction EF 24", "minimize")
    ChangeAdpChannel ("Leuchte23SL HLC10-Lichtfunktion C 23", "Brake light")
    ChangeAdpChannel ("Leuchte24SL HRA65-Lichtfunktion C 24", "Brake light")
    CloseUnit ()

    The two items above find the value and modify it, but in the case of the two-line "Brake light", the value is not found and the script stops.

    Please let me know if you know the cause.

    Thank you!

  2. #2
    Verified VCDS User hadez16's Avatar
    Join Date
    Jun 2017
    Location
    Germany
    Posts
    685
    Post Thanks / Like
    Hi there and thank you for using the tool

    At the moment I have no idea what the problem could be.
    What I already saw is that some fancy blank spaces are included in some values meaning something like "Brake light_"

    Could you manually change the value to Brake Light and create an CSV adaptation map of your BCM? Let's see how it is reflected in an admap.

  3. Likes Uwe liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •