Results 1 to 9 of 9

Thread: ECU does only answer once

  1. #1
    Verified VCDS User
    Join Date
    Dec 2019
    Location
    Germany
    Posts
    4
    Post Thanks / Like

    ECU does only answer once

    Hi guys,

    I have a VW Crafter 4motion Bj 2014 and a brand new VCDS V2 HEX cable with newest firmeware an SW.
    After connecting to the car I only can access several controll devices for one single time.

    Either I perform an autoscan or I try to connect to device directly, I can only connect once.
    After this the devices do not respond anymore.

    I have to unplug the ECU within the engine compartment.
    If I do so I can reach all the devices again for one scan.

    Does this behaviour make any sense to you guys. How can I fix this.

    Thank you.



    Here is a Autoscan I performed immediatly after connecting. All devices are there.


    Code:
    Sonntag,08,Dezember,2019,15:30:15:31547
    VCDS -- Windows-basierter VAG/VAS-Emulator läuft auf Windows 10 x64
    VCDS Version: MFT 19.6.2.1  HEX-V2 CB: 0.4508.4
    Datenstand: 20191020 DS308.0
    www.Diagnosetool.de
    Händler-/Werkstattname: Urs1000
    Fahrzeug-Ident.-Nr.: WV1ZZZ2EZE6030183   KFZ-Kennzeichen: 
    Fahrzeugtyp: 2E-n.v. (2E - VW Crafter Panel Van (LT3 / 2006 > 2016))
    Scan: 01 91 92 93 94 95 96 97 98 99 9A 9B 9C 9D 9E 9F A0 A1 A2 A3
              B0 B1 B2 B3 B4 B5 B6 C1
    Fahrzeug-Ident.-Nr.: WV1ZZZ2EZE6030183   
    -------------------------------------------------------------------------------
    Adresse 01: Motorelektronik (J623-CKUB)       Labeldatei:. DRV\03L-906-012-CKT.clb
       Teilenummer SW: 03L 906 012 DC    HW: 03L 906 012 A
       Bauteil: R4 2.0l BTD   H26 9977  
       Revision: 72H26---    Seriennummer: VWXDZ0N1008642
       Codierung: 0119401220062C080000
       Betriebsnr.: WSC 131071 1023 2097151
       ASAM Datensatz: EV_ECM20BTD01103L906012DC 002007
       ROD: EV_ECM20BTD01103L906012DC_002.rod
       VCID: 6888423A72F468F7616-803C
    3 Fehlercodes gefunden:
    
    5188 - Dieselpartikelfilter - Russbeladung zu hoch 
              P2463 00 [175] - -
              Warnleuchte EIN - bestätigt - geprüft seit letzter Löschung
    4984 - Glühkerze Zylinder 1 (Q10) 
              P0671 00 [039] - elektrischer Fehler im Stromkreis
              unbestätigt - geprüft seit letzter Löschung
    11866 - Positionsgeber für Ventil für Turbolader Turbineneingang 
              P22D5 00 [237] - Unplausibles Signal
              Warnleuchte EIN - bestätigt - geprüft seit letzter Löschung
    Readiness: 1110 1000
    -------------------------------------------------------------------------------
    Adresse 93: Wegfahrsicherung        Labeldatei: DRV\2E0-905-865-93.clb
       Teilenummer SW: 2E0 905 843 C    HW: 906 900 590 2
       Bauteil: IMMO          1231  1322  
       Revision: 00231000    Seriennummer: VWXDZ0N1008642
       Betriebsnr.: WSC 00000 000 00000
       VCID: 270A0106B3EAA78FA8C-8072
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse 94: Airbag 
       Teilenummer HW: 9069005701
       Betriebsnr.: WSC 00117 555 00000
       ASAM Datensatz: 3 3332
       ROD: CRFT_AB_3_3331.rod (*)
       VCID: 55F67BCED586E51FCA0-8000
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse 96: Schalttafeleinsatz 
       Teilenummer SW: 9069025601    HW: 9069010201
       Betriebsnr.: WSC 00000 000 00000
       ASAM Datensatz: 32 1048
       ROD: CRFT_KOMBI_32_1048.rod
       VCID: 06546C8258A09E87F3A-8052
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse 99: Zündstartschalter 
       Teilenummer HW: 9069005902
       Betriebsnr.: WSC 103996 432 62451
       ASAM Datensatz: 67 259
       ROD: CRFT_EZS_67_259.rod
       VCID: 55F67BCED586E51FCA0-8000
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse 9A: Funkfernbedienung        Labeldatei: DRV\2E0-905-865-9A.clb
       Teilenummer SW: 2E0 905 843 C    HW: 906 900 590 2
       Bauteil: HF-FFB        1231  1322  
       Revision: 00231000    Seriennummer: 12345678901234
       Betriebsnr.: WSC 00000 000 00000
       VCID: 270A0106B3EAA78FA8C-8072
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse 9B: Türelektr. Fahrer 
       Teilenummer HW: 9069000401
       Betriebsnr.: WSC 00000 000 00000
       ASAM Datensatz: 33 775
       ROD: CRFT_FTUHR_33_775.rod
       VCID: 55F67BCED586E51FCA0-8000
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse 9C: Heizung/Klima 
       Teilenummer SW: 2514450200    HW: 9068301285
       ASAM Datensatz: 21 4
       ROD: CRFT_KLIMA_21_260.rod (*)
       VCID: 77AA11462F4AF70FF8C-8022
    1 Fehler gefunden:
    9301 - Stellmotor der Temperaturklappe (V68): defekt/Unterbrechung/Kurzschluss 
                Prüfung abgeschlossen - gespeichert
    -------------------------------------------------------------------------------
    Adresse B3: Anhängerfunktion 
       Teilenummer HW: 1695455632
       ASAM Datensatz: 21 4
       ROD: CRFT_TRL_21_4.rod (*)
       VCID: 55F67BCED586E51FCA0-8000
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse B4: Zentralelektrik 
       Teilenummer SW: 9069024301    HW: 9069014500
       Betriebsnr.: WSC 00000 000 00000
       ASAM Datensatz: 33 852
       ROD: CRFT_EZE_33_851.rod (*)
       VCID: 025C70927488A2A7DF2-8056
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse B5: Sonderfunktion 
       Teilenummer SW: 9069021801    HW: 9064460046
       Betriebsnr.: WSC 103996 432 62451
       ASAM Datensatz: 9 773
       ROD: CRFT_PSM_9_773.rod (*)
       VCID: 0450768A6E9CAC97EDE-8050
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse B6: Lenkradelektronik 
       Teilenummer SW: 9065402345    HW: 9065402345
       Betriebsnr.: WSC 00000 000 00000
       ASAM Datensatz: 72 257
       ROD: CRFT_SML_72_257.rod (*)
       VCID: 06546C8258A09E87F3A-8052
    Kein(e) Fehlercode(s) gefunden.
    Ende(Dauer: 01:30, Batt.-Spannung Start/Ende: 11.6V/11.6V. VIgn 11.5V, udsna)
    =======================================================
    Controller Software Versions:
    ECU 1 = Motorelektronik 9977
    ECU 2 = Wegfahrsicherung        13
    ECU 3 = 
    ECU 4 = 
    ECU 5 = 
    ECU 6 = Funkfernbedienung        1
    ECU 7 = 
    ECU 8 = 
    ECU 9 = 
    ECU 10 = 
    ECU 11 = 
    ECU 12 =


    And here is one I performed a few minutes later, without changing the setup at all.
    Most of the devices are not there anymore.

    Code:
    Sonntag,08,Dezember,2019,15:32:07:31547
    VCDS -- Windows-basierter VAG/VAS-Emulator läuft auf Windows 10 x64
    VCDS Version: MFT 19.6.2.1  HEX-V2 CB: 0.4508.4
    Datenstand: 20191020 DS308.0
    www.Diagnosetool.de
    Händler-/Werkstattname: Urs1000
    Fahrzeug-Ident.-Nr.: WV1ZZZ2EZE6030183   KFZ-Kennzeichen: 
    Fahrzeugtyp: 2E (2E - VW Crafter Panel Van (LT3 / 2006 > 2016))
    Scan: 01 91 92 93 94 95 96 97 98 99 9A 9B 9C 9D 9E 9F A0 A1 A2 A3
              B0 B1 B2 B3 B4 B5 B6 C1
    Fahrzeug-Ident.-Nr.: WV1ZZZ2EZE6030183   
    -------------------------------------------------------------------------------
    Adresse 93: Wegfahrsicherung        Labeldatei: DRV\2E0-905-865-93.clb
       Teilenummer SW: 2E0 905 843 C    HW: 906 900 590 2
       Bauteil: IMMO          1231  1322  
       Revision: 00231000    Seriennummer: VWXDZ0N1008642
       Betriebsnr.: WSC 00000 000 00000
       VCID: 270A0106B3EAA78FA8C-8072
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse 94: Airbag 
       Teilenummer HW: 9069005701
       Betriebsnr.: WSC 00117 555 00000
       ASAM Datensatz: 3 3332
       ROD: CRFT_AB_3_3331.rod (*)
       VCID: 55F67BCED586E51FCA0-8000
    Kein(e) Fehlercode(s) gefunden.
    -------------------------------------------------------------------------------
    Adresse 96: Schalttafeleinsatz 
       Teilenummer SW: 9069025601    HW: 9069010201
       Betriebsnr.: WSC 00000 000 00000
       ASAM Datensatz: 32 1048
       ROD: CRFT_KOMBI_32_1048.rod
       VCID: 06546C8258A09E87F3A-8052
    Kein(e) Fehlercode(s) gefunden.
    =======================================================
    Controller Software Versions:
    ECU 1 = Wegfahrsicherung        13
    ECU 2 = Wegfahrsicherung        13
    ECU 3 =

  2. Likes Uwe liked this post
  3. #2
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    27,008
    Post Thanks / Like
    Blog Entries
    1
    Can you give more detail please?
    Is it enough to unplug the HEX-V2 from the vehicle?
    Or do you have to unplug it from the PC as well?
    What if you leave it connected and re-start VCDS?

    This is going to be difficult for us to reproduce because those Crafters are not available here at all.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  4. Likes Urs1000 liked this post
  5. #3
    Verified VCDS User
    Join Date
    Dec 2019
    Location
    Germany
    Posts
    4
    Post Thanks / Like
    Hi Uwe,
    thanks for your support. Maybe I did not describe the issue the right way. I try again.

    Unfortunatly it is not about unpluging the HEX-V2. That doesn´t help.
    No matter if I unplug it from the vehicle or from PC.

    What I meant is that I have to unplug the entire Engine Controll Unit itself. Modul 01.
    For the Crafter it is located in the front engine compartment.
    So I guess I have to cut the 12V power for Modul 01 Unit so it does kind of a reset.
    After that I can connect again.

    I know you guys do not have the Crafter over there. And I also know that not all modules of Crafter are supported.
    I am fine with that. I mainly need to access Modul 01 for the cumbustion engine.
    I also addressed this issue to MFT Fahrzeugtechnik who is the German reseller of VCDS.
    They could reprocess this issue with their own Crafter as well. They are alos working on it.



    Matthias

  6. Likes Uwe liked this post
  7. #4
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    27,008
    Post Thanks / Like
    Blog Entries
    1
    Quote Originally Posted by Urs1000 View Post
    What I meant is that I have to unplug the entire Engine Controll Unit itself. Modul 01.
    For the Crafter it is located in the front engine compartment.
    So I guess I have to cut the 12V power for Modul 01 Unit so it does kind of a reset.
    After that I can connect again.
    That is quite strange. Does disconnecting the battery also work? (This would probably be easier than disconnecting the ECU?)

    Can you verify that accessing the ECU is what causes this, rather than some other part of the Auto-Scan? In other words, will the ECU only answer once if you do just:
    [Select]
    [01-Engine]
    [Done, Go Back]

    What if you access other modules, one at a time when everything is working?

    -Uwe-

    PS: We very much appreciate feedback that will help us try to find out exactly what could be causing this.
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  8. Likes Urs1000 liked this post
  9. #5
    Verified VCDS User
    Join Date
    Dec 2019
    Location
    Germany
    Posts
    4
    Post Thanks / Like
    Disconnecting the battery should help as well I guess, didn´t try so far.
    For the Crafter the battery is located in the floor of the passenger compartment.
    Indeed it is easier to access the ECU.

    Can you verify that accessing the ECU is what causes this, rather than some other part of the Auto-Scan? In other words, will the ECU only answer once if you do just:
    [Select]
    [01-Engine]
    [Done, Go Back]
    Can not verify that for sure. But now when I think about it, it could be possible that the issue is caused by the autoscan only.
    I need to do some more investigation on that.
    Unfortunatly I put my car to the workshop yesterday as I was not able to get it diagonsed properly by myself.
    At the moment I have no access to it. As soon as I have it back I will do further investigations.

    A friend of mine has a Crafter and VCDS as well. He uses an older USB cable not the HEX-V2 but with the latest SW.
    He never experienced similar issues whereas the guy from MFT Fahrzeugtechnik could reproduce the behaviour with his HEX V2.

    Thats all I can tell so far. I keep you posted and will verify the requested as soon as I have my car back.

    Thanx Uwe

  10. Likes Uwe liked this post
  11. #6
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    27,008
    Post Thanks / Like
    Blog Entries
    1
    Quote Originally Posted by Urs1000 View Post
    A friend of mine has a Crafter and VCDS as well. He uses an older USB cable not the HEX-V2 but with the latest SW.
    He never experienced similar issues whereas the guy from MFT Fahrzeugtechnik could reproduce the behaviour with his HEX V2.
    That's another interesting data point. Let me see if I can arrange to get you an older cable too, so that we can be sure that the problem is specific to the HEX-V2.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  12. #7
    Verified VCDS User golfi_vend's Avatar
    Join Date
    Apr 2014
    Location
    Tartu, Estonia
    Posts
    2,072
    Post Thanks / Like
    Must say I experience this behaviour sometimes at workshop too when working with Crafters. But i never unplug ecu, i think what helps in my case is igniton and/or something else.

    Must remember next time to do debug.
    I am a VW Freak - Le WV Freaks OR Come visit me at my work with ODIS concerns - FORSS ODIS GeKo/FaZit access for VW/AUDI/Škoda
    The world is my oyster...

  13. Likes Uwe liked this post
  14. #8
    Verified VCDS User
    Join Date
    Dec 2019
    Location
    Germany
    Posts
    4
    Post Thanks / Like
    Let me see if I can arrange to get you an older cable too, so that we can be sure that the problem is specific to the HEX-V2.
    I had same idea. Unfortunatly my friend does not live close to me so I can´t borrow his.
    I asked the guys from MFT to check it out as well. The should have different cabels available...

  15. Likes Uwe liked this post
  16. #9
    Verified VCDS User
    Join Date
    Dec 2019
    Location
    UK
    Posts
    16
    Post Thanks / Like
    Getting something similar on my 2011 Crafter CECA 2.5lt 2E, sometimes it reads engine in Group 01, other times its in the LT3 091 group. Also sometimes in auto scan it reads the codes, other times i have to go to OBD2 for them.

    Very intermittent, what should i post here to show it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •