Results 1 to 3 of 3

Thread: HEX+CAN Interface Not Found

  1. #1
    Join Date
    Nov 2019
    Post Thanks / Like

    HEX+CAN Interface Not Found

    When attempting to Test the device in VCDS, I get the following error message:

    Port Status: Ok
    USB Library Version: 03.02.07
    USB Driver Version: 02.04.18
    Interface: Not Found!

    I am using the HEX+CAN cable with the following writing on it:

    Dual-k & CAN <-> USB
    Interface for VCDS

    and on the back


    there is a little sticker on the connect part that says

    VAG 12.12.0

    This is my first time using the device, I got it used in the mail the other day. When I got it I installed newest version of VCDS 19.6.2 and the newest drivers. The device shows up in Device Manager, noted to be working properly and with what looks to be the correct drivers installed. The car is a 2006 A4 Cabriolet. From the documentation, it seems like this should all work from a compatibility standpoint.

    I made many attempts at this including re-installing VCDS once, re-installing the drivers three times, rebooting my computer (Windows 10 on Microsoft Surface 2 computer), trying with car off/accessory mode/on.

    I most recently found the link to the virtual COM port drivers located here ( hence the out-of-date versions on the drivers noted above. On trying these drivers, I made sure to go into Device Manager and into the USB device and tried with the "Load VCP" checkbox both unchecked. Between each attempt at new drivers I made sure to fully uninstall the drivers via the Device Manager to make sure there were no lingering drivers. With these drivers I have attempted the Test with COM ports 1 to 5 with the same results.

    When I hit the test button, the LED on the interface cable goes from steady red to green for 1 second, red for 1 second, then flashes back and forth rapidly for 3 seconds, then returns to red. Once it has gone back to red, a few seconds later I get the error message. I am using the default settings for Port and Protocol Options.

    Regardless of what I do, I still get the error message above noting the "Interface: Not Found" line.

    Any guidance on this would be greatly appreciated!

  2. #2
    Verified VCDS User
    Join Date
    Oct 2014
    Post Thanks / Like
    No genuine interface has a version number stuck on it.

    At a guess, you've bought a clone. You should demand a refund from the seller...

  3. Likes Uwe, PetrolDave liked this post
  4. #3
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Post Thanks / Like
    Blog Entries
    Yep, "Rev B" without a serial number and "VAG 12.12.0", leaves no question that this interface is a HEX-CLONE+CAN.

    Legitimate VCDS are available directly from us:

    ... Or from any of our authorized resellers:

    Let us know if/when you get one and we'll adjust your forum status.

    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts