Results 1 to 8 of 8

Thread: VW T5.1 Trailer Coding Problem. Help Please.

  1. #1
    Verified VCDS User
    Join Date
    Nov 2019
    Location
    Wrexham, UK
    Posts
    4
    Post Thanks / Like

    VW T5.1 Trailer Coding Problem. Help Please.

    Hi, been using VCDS for a few years but never got round to needing to code things, however I've just fitted a towbar and dedicated vehicle electrics to a 2014 T5.1. Successful installation and all lights work, the trailer shows on the 'Radio' screen when connected and sensors are inhibited so pretty happy. However! When I use a trailer light board to test the 'Bulb Out' sensing, I don't get any indication on the MFD that I have removed a bulb. Without the trailer the 'Bulb Out' sensing works as it should.
    The dedicated electrics kit was purchased from P.F.Jones in UK, and the kit is made by ConWys of Switzerland. All the reviews say that this is a perfectly good dedicated wiring kit.
    I have included an Auto Scan. In particular, I added module 69 (Trailer)to the Gateway, and adapted the coding in 10(Park/Steer Assist) to show 'trailer hitch installed'.
    I have received some help from Ross Tech support which suggested I change the coding of module 69, however, when I go to try and access module 69 it requires a Security Access code before it will allow access to coding. When I hover over the security access box I don't get any 'pop up' as I would expect. Is this because Ross Tech does not have any suggestions? I have tried 12345 but that didn't work either.
    Please could someone suggest how I find a security code to use to get into the trailer coding so I can try the coding Ross Tech have suggested.
    Any other ideas about how to make the 'Bulb out' system work on the trailer would be appreciated.
    Regards and Thanks. New to the Forum. Martin.

    Code:
    Monday,04,November,2019,17:18:49:27292
    VCDS -- Windows Based VAG/VAS Emulator Running on Windows 10 x64
    VCDS Version: 19.6.2.0 (x64)
    Data version: 20190930 DS308.0
    www.Ross-Tech.com
    
    
    VIN: WV1ZZZ7HZFH045096   License Plate: HJ64KUT
    Mileage: 111130km-69052mi   Repair Order: 
    
    
    
    --------------------------------------------------------------------------------
    --------------------------------------------------------------------------------
    
    
    Chassis Type: 7H-VN75 (6N0)
    Scan: 01 03 04 08 09 10 15 17 19 25 37 56 69
    
    VIN: WV1ZZZ7HZFH045096   Mileage: 111130km-69052miles
    
    01-Engine -- Status: OK 0000
    03-ABS Brakes -- Status: OK 0000
    04-Steering Angle -- Status: OK 0000
    08-Auto HVAC -- Status: OK 0000
    09-Cent. Elect. -- Status: OK 0000
    10-Park/Steer Assist -- Status: OK 0000
    15-Airbags -- Status: OK 0000
    17-Instruments -- Status: OK 0000
    19-CAN Gateway -- Status: OK 0000
    25-Immobilizer -- Status: OK 0000
    37-Navigation -- Status: OK 0000
    56-Radio -- Status: OK 0000
    69-Trailer -- Status: OK 0000
     
    -------------------------------------------------------------------------------
    Address 01: Engine (J623-CAAC)       Labels:. 03L-906-022-CAA.clb
       Part No SW: 03L 906 019 GH    HW: 03L 907 309 M
       Component: R4 2,0L EDC   H45 8437  
       Revision: 26H45---    Serial number: 00000000000000
       Coding: 01194012232400080000
       Shop #: WSC 00534 210 00000
       ASAM Dataset: EV_ECM20TDI01103L906019GH 003006
       ROD: EV_ECM20TDI01103L906019FM_003.rod
       VCID: 77FDEB59CEA7D8F796-8022
    
    1 Fault Found:
    4807 - EGR System 
              P0401 00 [096] - Insufficient Flow
              Intermittent - Not Confirmed - Tested Since Memory Clear
    
    Readiness: 0 0 0 0 0 
    
    -------------------------------------------------------------------------------
    Address 03: ABS Brakes (-----)       Labels: 7E0-907-37x-MK25AXT.clb
       Part No SW: 7E0 907 379 K    HW: 7E0 907 379 E
       Component: ESP MK25A XT  H43 0110  
       Revision: 00H43001    
       Coding: 508724AD89A80A9A24A2917AA96410
       Shop #: WSC 02737 790 49152
       VCID: 3A7B326DB535059FA9-806E
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 04: Steering Angle (G085)       Labels:* 6R0-959-654.clb
       Part No SW: 6R0 959 654     HW: 6R0 959 654 
       Component: LENKW.SENSOR  H07 0070  
       Serial number: 21081404650212
       Coding: 01
       Shop #: WSC 00000 000 00000
       ASAM Dataset: EV_LWSKLOVW25X 005001
       ROD: EV_LWSKLOVW25X.rod
       VCID: 7EF3FE7DE19DE9BFD5-802A
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 08: Auto HVAC (J301)       Labels:| 7E5-907-047.clb
       Part No SW: 7E5 907 047 BG    HW: 7E5 907 047 BG
       Component: Climatic-T5   H20 0506  
       Revision: 00001012    
       Coding: 0000000002
       Shop #: WSC 02737 790 50316
       ASAM Dataset: EV_ClimaticT5 A01003
       ROD: EV_ClimaT5Basis.rod
       VCID: 75E1E151D4ABAAE784-8020
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 09: Cent. Elect. (J519)       Labels:. 7H0-937-08x-09.clb
       Part No SW: 7H0 937 087 P    HW: 7H0 937 087 
       Component: BCM T5GP H+4  H34 0424  
       Revision: BO034001    Serial number: 0673 251140050
       Coding: A0A4303A0A613431922848106C2B8C540080632F60840000320000000800
       Shop #: WSC 02739 790 12345
       VCID: 41894581D8E35647E8-8014
    
       Subsystem 1 - Part No SW: 7E0 959 801 L    HW: 7E0 959 801 L  Labels: 7E0-959-80X-V2.CLB
       Component: J386__TSG_FT  003 8653 
       Serial number: KU0KU005091442485173
       Coding: 1000B1
    
       Subsystem 2 - Part No SW: 7E0 959 802 L    HW: 7E0 959 802 L  Labels: 7E0-959-80X-V2.CLB
       Component: J387__TSG_BT  003 8653 
       Serial number: KU0KU010091442537027
       Coding: 0000A1
    
       Subsystem 3 - Part No: 7E1 951 172 
       Component: DWA-Sensor 00  001 0104 
       Coding: 000000
    
       Subsystem 4 - Part No: 1K0 951 605 C
       Component: LIN BACKUP HO  H05 1501 
       Coding: 000000
    
       Subsystem 5 - Part No: 7E1 951 172 
       Component: DWA-Sensor 00  001 0104 
       Coding: 000000
    
       Subsystem 6 - Part No SW: 3C8 959 537 D    HW: 3C8 959 537 D  Labels: 3C8-959-537.CLB
       Component: E221__MFL-TK6  H07 0023 
       Serial number: 70000000000000799490
       Coding: E20000
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 10: Park/Steer Assist (J446)       Labels:| 7E0-919-475.clb
       Part No SW: 7E0 919 475 L    HW: 7N0 919 475 
       Component: PARKHILFE 8K  H06 0106  
       Revision: --------    Serial number: 28261420400910
       Coding: 118004
       Shop #: WSC 02739 790 50316
       ASAM Dataset: EV_VW75XParkAssis8K 001003
       ROD: EV_VW75XParkAssis8K_001_VN75.rod
       VCID: 3B753769B20F3C97B2-806E
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 15: Airbags (J234)       Labels:| 5K0-959-655.clb
       Part No SW: 7E0 959 655 B    HW: 7E0 959 655 B
       Component: VW10Airbag009 H07 0013  
       Revision: --------    Serial number: 003HL00SDTWE
       Coding: 000000000000000000000000000000003039
       Shop #: WSC 02734 790 50316
       ASAM Dataset: EV_AirbaVW10BPAVN750 A01026
       ROD: EV_AirbaVW10BPAVN750_VW12.rod
       VCID: 35612151942BEAE744-8060
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 17: Instruments (J285)       Labels:| 5K0-920-xxx-17.clb-SRI1
       Part No SW: 7E0 920 970 N    HW: 7E0 920 970 N
       Component: KOMBI         H03 0805  
       Serial number: 00000000000000
       Coding: 160A00
       Shop #: WSC 12345 123 12345
       ASAM Dataset: EV_Kombi_UDS_VDD_RM09 A04727
       ROD: EV_Kombi_UDS_VDD_RM09_004_VW32.rod
       VCID: 35612151942BEAE744-8060
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 19: CAN Gateway (J533)       Labels:. 6N0-909-901-6R.clb
       Part No SW: 6N0 909 901     HW: 7H0 937 087 
       Component: GW-K-CAN TP20 H34 0424  
       Revision: BO034001    
       Coding: 042300
       Shop #: WSC 02739 790 12345
       VCID: 70EFD045A3C98FCF57-8024
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 25: Immobilizer (J334)       Labels:| 5K0-920-xxx-25.clb
       Part No SW: 5K0 953 234     HW: 5K0 953 234 
       Component: IMMO          H03 0805  
       Serial number:               
       Coding: 000000
       Shop #: WSC 00000 000 00000
       ASAM Dataset: EV_Immo_UDS_VDD_RM09 A03710
       ROD: EV_Immo_UDS_VDD_RM09.rod
       VCID: 6ADBC22D8D15751F19-803E
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 37: Navigation (J794)       Labels:| 1K0-035-27x-37.clb
       Part No SW: 3C8 035 279 R    HW: 3C8 035 279 R
       Component: RNS315-EU   H80 0500  
       Serial number: VWZAZ2P0470904
       Coding: 000002110200140000039002
       Shop #: WSC 02734 790 50316
       ASAM Dataset: EV_RNS315EUV2UDS 001705
       ROD: EV_RNS315EUV2UDS.rod
       VCID: 3A7B326DBD35059FA9-806E
    
       Data medium: 
       Subsystem 1 - Part No: 3AA 919 866 
       Component: EUR_W_V6  0062 
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 69: Trailer (J345)       Labels:. 1K0-907-383-V2.clb
       Part No SW: 1K0 907 383 F    HW: 1K0 907 383 F
       Component: ConWysTrailer H07 0100  
       Revision: 3A001001    Serial number: 00000132425721
       Coding: 0100000100000000
       Shop #: WSC 00007 223 174336
       VCID: 306F10456349CFCF17-8064
    
    No fault code found.
    
    End-------------------------(Elapsed Time: 02:37)--------------------------
    Last edited by Uwe; 11-06-2019 at 11:48 AM. Reason: CODE tags

  2. #2
    Verified VCDS User iichel's Avatar
    Join Date
    Aug 2016
    Location
    The Hague, NL
    Posts
    1,562
    Post Thanks / Like
    Looks like a third-party module, perhaps you can contact them to see if their module is capable of light diagnostics.

  3. #3
    VCDS Distributor
    Join Date
    Feb 2014
    Location
    Denmark
    Posts
    1,807
    Post Thanks / Like
    So is this what you are trying,
    You enter this coding: 410D000100000000
    and then a VCDS window comes up, where it says, a security access is needed ?

    I have only seen this coding for ConWysTrailer module on T5: 0100000100000000

    Is the part number on trailer module: 12270548C ?

    What bulb do you remove ?

  4. Likes Uwe liked this post
  5. #4
    Verified VCDS User
    Join Date
    Nov 2019
    Location
    Wrexham, UK
    Posts
    4
    Post Thanks / Like
    Firstly, many thanks for your answers and advice. I am learning fast and very grateful for the help. Just to clear up your questions NEtech, my question about changing the coding in ’69 Trailer’ is that when I open 69 all the Advanced Options are greyed out with the exception of ‘Security Access 16’, which, if I open it, requires a code, and nothing comes up if I ‘hover’ over it? That said, I am beginning to think you are right with the coding as it is, and my problem is elsewhere.
    So I need to eat a bit of ‘Humble Pie’, and explain a bit more background. I bought this van 3 weeks ago, and my first priority was to fit a towbar as I need to tow a trailer. Installation went well, indeed all works well, including all the lights. I have also discovered that the indicator substitution aspect of the towbar electrics works ( If I remove a trailer indicator bulb, the adjacent stop/tail light flashes instead), and the reverse sensors are inhibited, and ‘trailer attached’ shows on the radio screen as it should.
    So all is good except the ‘bulb failure’ side of things.
    Back to basics, I removed the trailer and tested the van itself for ‘bulb failure’. NOTHING!!
    And what’s worse is that since I have only had the van 3 weeks, I don’t know if the system worked before I started playing with the towbar electrics!
    So that’s when I looked closer and noticed that the previous owner had fitted LED bulbs to the Daylight Running Lamps, and the Side lights. The headlights and front foglights are blue, and probably Xenon. All rear bulbs are conventional. Yet I was getting no warnings at all. So I am wondering if the previous owner has inhibited the ‘bulb failure’ system when fitting LED bulbs? I immediately replaced the LED bulbs with conventional bulbs. No change.
    So in to VCDS, Central Electrics. No fault codes, so looking in to any Long Coding Bit that might relate to ‘Lamp Diagnostics’. None of the available Bits were ticked? But then, I don’t know which ones should be ticked? Bytes 16 and 19 have options, but should I tick them and change the coding? Or is there something else I should check that may have been used to inhibit the ‘bulb failure’ system?
    I don’t even know what the ‘bulb failure’ system should be doing on a T5.1?? I have 2 Mk6 Golfs. A Mk7 Golf, a Tiguan and an Eos, and they all tell you as soon as any bulb fails.
    Once again, thanks for your patience. Any help or suggestions would be much appreciated.

  6. #5
    VCDS Distributor
    Join Date
    Feb 2014
    Location
    Denmark
    Posts
    1,807
    Post Thanks / Like
    Well there are many combinations.
    For a start, you could test this coding for [09]
    Code:
    A0A4303A0A613431922848F06C2B8CD4F780612F60840000320000020800
    Specific, Byte 11, 16, 18, 19, 27
    It seems heated rear window, has been disabled for some reason, Byte 15.

  7. Likes Uwe liked this post
  8. #6
    Verified VCDS User
    Join Date
    Nov 2019
    Location
    Wrexham, UK
    Posts
    4
    Post Thanks / Like
    Many thanks for the suggested coding. I am beginning to feel either frustrated or stupid! I've just re-coded [09]to the long code you sent and still no bulb failure warnings. I wonder if my way of testing is wrong?? I am removing the bulb (headlight in this case)from the connector. Is this a viable way of testing the system on this 2014 vehicle? I've just done the same thing on a 2011 Mk6 Golf and it works exactly as I would expect -immediately you turn the ignition on the amber bulb light comes on and the MFD tells you which bulb it is.
    Also, I notice that the coding you sent me does not check Bits 4, 6 , or 7 in Byte 19. Is this normal? I would have thought that warning of a Turn light, tail light or brake light failure was desired?
    Anyway. I still have no indication of a bulb failure. Am I testing correctly please?

  9. #7
    VCDS Distributor
    Join Date
    Feb 2014
    Location
    Denmark
    Posts
    1,807
    Post Thanks / Like
    Byte 19 is like your coding.
    Bit 4, 5, 6, 7 mean lamp diagnosis NOT active.
    Please use long coding help.

    Try and remove battery connection 20 minutes.

  10. #8
    Verified VCDS User
    Join Date
    Nov 2019
    Location
    Wrexham, UK
    Posts
    4
    Post Thanks / Like
    Many thanks for your last suggestion. I disconnected the battery for 30 mins but no change I’m afraid. I am a bit confused by your ‘NOT’ comment. I may have got this all wrong, but when you use the Long Coding Helper and look at a Byte, it shows several Bits. If a Bit is ‘Blue’, does that mean it is active and being used? In particular, for this issue, I am in [09] Central electrics, Byte 19, and this vehicle has 4 available Bits. Namely 4,5,6 and 7.
    The long coding you sent me, which I am using for [09] Central Electrics, has Byte 19, Bits 4,6 and 7 with no tick in the box and grey. Bit 5 is ticked and blue.( Lamp Diagnostics for Fog Lights and/or Cornering Turn Lights) This vehicle has Fog Lights and they work as cornering lights too.
    My question was, shouldn’t I have Bits 4,6 and 7 ‘ticked and blue’, as they are:-
    4.Lamp Diagnostics for Turn Lights Active
    6.Lamp Diagnostics for Tail Lights Active
    7.Lamp Diagnostics for Brake Lights Active.
    There is no 'NOT' word in the Bit description??
    And my last question is, Is removing a bulb an effective way of testing this system? I have just tried removing a bulb from a headlight on a 2011 Mk6 Golf and as soon as you turn the ignition on and the car does it’s scan, it pops up with a bulb fail light, and the MFD tells me which one it is, but when I do the same thing on the 2014 T5.1, or a 2015 Tiguan I have, I don’t get a warning??? Is the newer vehicle using a more sophisticated resistance based sensing system? Is there a better way of ‘simulating’ a bulb failure to test the system?
    Sorry to keep asking all these questions. I am learning a great deal about VCDS and my VW’s, and hopefully people following this post may be likewise.
    Thanks. Martin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •