Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: AUDI A6 (C7) intermittent (and very persistent) problem with ABS electronics

  1. #11
    Verified VCDS User
    Join Date
    Jan 2018
    Location
    Cheshire UK
    Posts
    68
    Post Thanks / Like
    Disconnect the original flexray that comes form the abs module and connect it directly to the j533 diagnostic interface under the back seat. Some modules run the flexray to the sensor unit 3B and some to the j533. so as you have acc your flexray runs from abs unit to J851 (image processor unit) to J533. If you have the wring diagrams you will know what im referring to
    Use a twisted pair for now ie from a cat 5 cable as its only a temporary connection.
    A6 BiTdi Avant MTM
    Retrofitted: Full Led Headlights, DAB, Full Electric Seats, Power Tailgate, Surround View Cameras, Genuine RS6 Grille, RS6 Seats,Leather Door Armrests, Soft Close Doors, Rear Side Blinds, Electric Steering Column, LED Sill Plates, Ambient Lighting Pack, High Beam Assist, Eibach Springs, Led Roof Console, 4 Zone Climate, Rear Heated Seats, Head Up Display, Side assist, Alcantara Interior Retrim

  2. Likes Jack@European_Parts, vladomkd liked this post
  3. #12
    Verified VCDS User
    Join Date
    Aug 2019
    Location
    Macedonia
    Posts
    7
    Post Thanks / Like
    i have used this weekend to dig under the carpet and take a look at the image processing ECU. the visual inspection did not reveal anything suspicious (i know this is not a scientific approach) and i still haven't got into running a flexray bypass.

    i'm more and more considering replacing the ABS ECU, since after everything that i have checked and modified it seems less and less likely that it is wiring problem. i have two dilemmas here... first of all it is very likely that the new ABS ECU will be a different version (mine is 4G0907379B, as far as i can tell from ETKA newer compatible ones are G and J). will these new versions require the same code as my current one (or a different one considering the different HW revision) and will i be able to code the new ECU myself using VCDS or ODIS?

    also, can please somebody check if there is some sort of service bulletin for this unit? i can't seem to find this info publicly available... as far as i can tell this revision (B) was dropped from use very early in the production run (car is 03.2011, version J is in use since 01.2012) and i find this strange, it is likely they have located some issue with revision B.

    thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •