After stripping down the dsg box and replacing a selector.
Refitting the mechatronic and dsg box we was stuck doing basic settings for quite a while until we following instructions from Snapon Verus instead of vcds.

We followed the following page: http://wiki.ross-tech.com/wiki/index...rbox_(DSG/0AM)

Basic Setting
Prerequisites:
No Fault Codes stored in the TCM
Temperature 30C - 60C. The Measuring Block value for G510 is found in group 011.1
Selector Lever in P
Ignition ON, Engine OFF
Parking brake applied
Brake Pedal operated (hold for the whole procedure)
Throttle Pedal not operated
See the Special Notes if the Mechatronic unit needs to be replaced.

NOTE: Be sure to perform the following steps in the sequence shown, followed by the defined test drive.

[Select]
[02 - Transmission]
[Basic Settings - 04]
Group 060
[Go!]
[ON/OFF/Next] may be necessary
The live data should display 4 | 0 | 0 in Basic Settings. This may take up to 2 -to- 5 minutes.
After the 4 | 0 | 0 results are displayed, start the engine immediately and allow it to idle. If 4 | 0 | 0 is not shown do NOT start the engine, something is wrong with the procedure or the transmission.
It is normal for the transmission to make noise while the tolerances are adapting. Do not exit or abort the Basic Settings sequence prematurely if you hear clacking noises. This is similar to the 02E 6-Speed DSG.
The live data should display 254 | 0 | 0 to confirm a successful Basic Settings after 3 -to- 6 minutes.
254 | 7 | 0 alone would Not be complete yet and 255 | 0 | 0 would indicate the basic settings was interrupted or failed.
[Done, Go Back]
Switch off Ignition, wait for a few seconds and switch it back on.
[Fault Codes - 02]
Check and clear any fault codes.
[Close Controller, Go Back - 06]
Perform the Defined Test Drive below.

Following the above we couldn't get the box to select any gear at the stage of 255 | 0 | 0 was successful, ign off and check for fault codes (none present at any stage)
We tried to drive and was unable to still select gears.

We did this loads of times times without any success.

The Snapon Verus we did only 1 time and at the 255 | 0 | 0 it was successful and we could select gears immediately.

We was a little shocked to find we could get the procedure to work with VCDS and it worked with Snap-on.

Has anyone else come across this issue?