Hello

I own Golf MK6 2009 (quite old these days) and I have done retrofit of Bluetooth unit (original from factory - old fashion) - so no harness had to be added, but anyway. I had issues and was hard for me to find any info. That is why I am writing this because it could help someone. More experienced probably know already.

So:

I wanted to use handsfree calling and A2DP streaming of music. I have White instrument cluster 5K0 920 870 C, H21 0030 - old SW, multifunction steering wheel, and RNS 510 - 1T0 035 680 B and had H04 1200 - also old SW

First I changed BT unit for phone and music. I had 5N0 035 730 A unit and changed it for 7P6 035 730K (9W7). Handsfree calling worked great. I had to added wires for stereo music. Only right side was playing because of that - simply added two wires for Green connector of RNS 510 Pin 5 Audio LF - and PIN 11 Audio LF + and on the BT blue connector PIN 4 Audio LF - and PIN 5 Audio LF + . Pins I had to find on the internet, crimped it, set wire under carpet inside a car and went to the Radio - all works perfectly.

But:

What little bothered me - if I connected the phone I was not able to control songs (Next/Previous/Pause) and I didn't see any info about song (like name etc.) Only BT Audio.. Voice control "Music, Next" worked fine..). It did not worked with steering buttons and on the touch screen of RNS also. I came through lot of forums, I was asking questions, sending private messages (thank you Mr. Kamold for the answer btw.) of course without reply or anything. So I did the standard procedure with RNS unit and what I typically do with other units if something does not work according to my imagination.

Flashing the new software for RNS unit is the answer for everything! If someone struggle with same thing as me - Use K index of BT unit starting ith 7P6 (or newer - maybe J will work too yet), flash the RNS 510 with newest SW for your unit, do the coding and everything will work!

This info I needed to know - now I know and I can save nerves to newbees working with retrofit! Now I only have "problem" with icons on instrument cluster (like battery and player small icon, I have only BT icon) and it is probably because of old SW inside - I will maybe update it later cause I don't care too much...

Thank you.