Results 1 to 4 of 4

Thread: Audi A4 avant 3.0L 2003 cant connect to ecm k-line?

  1. #1
    New User
    Join Date
    Mar 2019
    Location
    Sweden
    Posts
    2
    Post Thanks / Like

    Talking Audi A4 avant 3.0L 2003 cant connect to ecm k-line?

    Hello, i have problems with connecting to the engine module, i can actually connect to all other systems except engine and after searching the internet i came to see that you wrote an article about k-line problems with aftermarket stereos here at ross-tech but this is still an standard (concert) stereo.
    In the article it said that you could measure with multimeter between pins 4+7 and should then have an reading under 9V (around 12V should mean problem) I had 10V, also I did the other test with an 1K-ohm resistor between and measure in parallel and then the value should be under 1V and my reading was then 5V does that mean I have problems with the k-line?
    Happy for any advice, cheers in advance

  2. #2
    Verified VCDS User PetrolDave's Avatar
    Join Date
    Dec 2014
    Location
    South Molton, UK
    Posts
    1,972
    Post Thanks / Like
    Do you have an aftermarket radio fitted? They are well know for causing problems on the K-line.

  3. #3
    New User
    Join Date
    Mar 2019
    Location
    Sweden
    Posts
    2
    Post Thanks / Like

    Yes i know

    Quote Originally Posted by PetrolDave View Post
    Do you have an aftermarket radio fitted? They are well know for causing problems on the K-line.
    Yes i know, but I tested another diagnostic tool and hurray I got in to the ecm
    Got some codes about missfireing on some cylinders I deleted these but still engine lamp and that other lamp epic I think it says is on.
    When I press the "check" button on instrument cluster it repeats (brake,oil,fuel,washer fluid and coolant) I checked the fluids and all is good except fuel and washer fluid is low but that should not be the problem for check engine lamp, am I right?
    Do I have to drive some distance for engine lamp to go away?

  4. #4
    Verified VCDS User PetrolDave's Avatar
    Join Date
    Dec 2014
    Location
    South Molton, UK
    Posts
    1,972
    Post Thanks / Like
    We'll need to see a VCDS Auto-Scan to be able to help you - even if that means unplugging your aftermarket radio.

  5. Likes Uwe liked this post

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •