Results 1 to 7 of 7

Thread: Audi A6 C5 Tiptronic doesn't work (P0702)

  1. #1
    New User
    Join Date
    Jan 2019
    Location
    Finland
    Posts
    4
    Post Thanks / Like

    Audi A6 C5 Tiptronic doesn't work (P0702)

    Hello!

    My Audi A6 C5 Allroad 2.5 TDI AKE 2000 has run to some problems. During the weekend I was in the warm garage doing maintenance (changed CV joint and track rod end). After that I drove my car outside where was -25C, and noticed that my steering wheel wasn't straight. It was little bit to the left while driving straight. Next day after a very cold night, I did an test drive and everyhting was fine except that steering wheel was to the left. Until I noticed that the tiptronic didn't change gears at all.


    On the dashboard where is visible current selected gear, there was all lights "on" like I had every gear in. P,R,N,S,D were all "on". Car was powerless, and even that manual gear select +/- didn't work. So i drived back home. After that I checked with VCDS I noticed it had the 4th gear in all the time. I checked the faultcodes and got only one code from transmission:


    Code:
    Sunday,27,January,2019,14:05:08:61411
    VCDS -- Windows Based VAG/VAS Emulator Running on Windows 10 x64
    VCDS Version: 18.9.1.0 (x64)
    Data version: 20190114 DS296.0
    www.Ross-Tech.com
    
    
    VIN: WAUZZZ4B42N026830   License Plate: ILT-788
    Mileage: 314660km-195520mi   Repair Order: Auto.Vaihteisto vika
    
    
    Chassis Type: 4B (4B - Audi A6/S6/RS6/allroad C5 (1998 > 2005))
    Scan: 01 02 03 06 08 15 16 17 18 22 34 35 36 37 45 55 56 57 65 67
              75 76 77
     
    VIN: WAUZZZ4B42N026830   Mileage: 314660km-195520miles
    -------------------------------------------------------------------------------
    Address 01: Engine        Labels: 059-907-401-AKE.clb
       Part No: 4Z7 907 401 B
       Component:  2.5l/4VTEDC G000AG D06    
       Coding: 01016
       Shop #: WSC 02325  
       VCID: 3C7CE7332C8444AAC1-4B00
    
       Subsystem 1 - Part No: 00015059
       Component: 130 106EC150_1.R75438336187  
       WAUZZZ4B42N026830     AUZ7Z0A1903996
    
    No fault code found.
    Readiness: N/A
    
    -------------------------------------------------------------------------------
    Address 02: Auto Trans        Labels: 01V-927-156.lbl
       Part No: 4Z7 927 156 H
       Component: AG5 01V 2.5lTDI RdW 2121  
       Coding: 00001
       Shop #: WSC 00000  
       VCID: 4B9EB4EF792AF31278-513C
    
    1 Fault Found:
    17086 - Transm. Control Module Electrical Malf. (SAE) or Control Module Defective (VAG) 
                P0702 - 35-00 - 
    
    -------------------------------------------------------------------------------
    Address 03: ABS Brakes        Labels: 8D0-907-389.lbl
       Part No: 4Z7 907 389 
       Component: ABS/ESP allrad      D57  
       Coding: 06357
       Shop #: WSC 02325  
       VCID: 09124EE733D6A1028A-513C
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 08: Auto HVAC        Labels: 4B0-820-043-MY2.lbl
       Part No: 4B0 820 043 AD
       Component: A6-Klimavollautomat 0104  
       Coding: 00003
       Shop #: WSC 02325  
       VCID: 5CBC47B3CCC464AAE1-2578
    
    1 Fault Found:
    01592 - Air Quality Sensor (G238) 
                57-00 - Electric Circuit Failure
    
    -------------------------------------------------------------------------------
    Address 15: Airbags        Labels: 4B0-959-655-AI84.lbl
       Part No: 4Z7 959 655 D
       Component: Airbag 8.4E         3000  
       Coding: 0000106
       Shop #: WSC 02325 785 00200
       VCID: 50A4A383C00CD0CA0D-5120
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 17: Instruments        Labels: 4B0-920-xxx-17.lbl
       Part No: 4B0 920 933 M
       Component: KOMBI+WEGFAHRS. VDO D07  
       Coding: 04160
       Shop #: WSC 00001  
       VCID: 2D5ADA77E7FEDD2246-5120
       WAUZZZ4B42N026830     AUZ7Z0A1903996
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 34: Level Control        Labels: 4Z7-907-553.lbl
       Part No: 4Z7 907 553 E
       Component:  - 2C1A1          D040    
       Coding: 25500
       Shop #: WSC 09999  
       VCID: 479688DF654217725C-5120
    
    1 Fault Found:
    01772 - Signal from Level Control Pressure Sensor (G291) 
                27-10 - Implausible Signal - Intermittent
    
    -------------------------------------------------------------------------------
    Address 35: Centr. Locks        Labels:. 4B0-962-258.lbl
       Part No: 4B0 962 258 K
       Component: Zentralverrieg.,DWA D35  
       Coding: 06987
       Shop #: WSC 02325  
       VCID: 3162C607FBC6B9C262-4ECA
    
    5 Faults Found:
    01560 - Passenger Door 
                59-10 - Can't Unlock - Intermittent
    01561 - Rear left door 
                59-10 - Can't Unlock - Intermittent
    01562 - Rear right door 
                60-00 - Won't Safe
    01560 - Passenger Door 
                61-10 - Won't De-Safe - Intermittent
    01561 - Rear left door 
                61-00 - Won't De-Safe
    
    -------------------------------------------------------------------------------
    Address 36: Seat Mem. Drvr        Labels: None
       Part No: 4B0 959 760 B
       Component: Sitzmemory R1 F     0101  
       Coding: 00001
       Shop #: WSC 00000  
       VCID: 2C5CD773DCE4D42A51-4B00
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 37: Navigation        Labels: 4B0-035-192-RNSD-37.lbl
       Part No: 4B0 035 192 M
       Component: RNS 4.1 H06    BNO 0017  
       VCID: 2756285FC502F772BC-4ACE
    
    1 Fault Found:
    00862 - Antenna for GPS Navigation (R50/R52) 
                36-00 - Open Circuit
    
    -------------------------------------------------------------------------------
    Address 45: Inter. Monitor        Labels: 4B0-951-173.lbl
       Part No: 4B0 951 173 
       Component: Innenraumueberw.    D03  
       Coding: 00002
       Shop #: WSC 02325  
       VCID: 60C47343E0AC404ABD-4B32
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 55: Headlight Range        Labels: 4Z7-907-357.lbl
       Part No: 4Z7 907 357 
       Component: dynamische LWR       D06  
       Coding: 00030
       Shop #: WSC 02325  
       VCID: 040C5FD314F4FC6AF9-4B7C
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 56: Radio        Labels: 4B0-035-192-RNSD-56.lbl
       Part No: 4B0 035 192 M
       Component: Radio          BNO 0001  
       Coding: 00117
       Shop #: WSC 02325  
       VCID: 2756285FC502F772BC-4AE6
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 57: TV Tuner        Labels: 4D0-919-146.clb
       Part No: 4D0 919 146 B
       Component: TV Tuner        H05 0704  
       Coding: 0000160
       Shop #: WSC 00000 000 00000
       VCID: 28542B63981CF80AB5-5120
    
    No fault code found.
    
    -------------------------------------------------------------------------------
    Address 76: Park Assist        Labels: 8E0-919-283-8E2.lbl
       Part No: 8E0 919 283 
       Component: Parkingsyst. A6 RDW D09  
       Coding: 01186
       Shop #: WSC 02325  
       VCID: 6DDA1A77277E1D2206-513C
    
    1 Fault Found:
    01627 - Sensor for Parking-Aid; Front Mid-Right (G253) 
                37-00 - Faulty
    
    End-------------------------(Elapsed Time: 04:44)--------------------------

    After that, I took TCU out and got it inside to warm up. I kept it in warm for 2 days, plugged it in again, heated car from inside, and deleted faultcodes. Fault gets back.

    I have no idea what should I do next. Do I need to buy new TCU, or is there something else I should check before that?

    Thanks for help!
    Last edited by Uwe; 01-29-2019 at 09:50 AM. Reason: PHP -> CODE

  2. #2
    Verified VCDS User
    Join Date
    Jul 2014
    Location
    UK
    Posts
    120
    Post Thanks / Like
    I think the first thing to do is retrace your steps of fitting the CV and track rod end, did you displace/disconnect/damage a TCM connector. Have you checked the fuses that power the TCM. You also need to get the wheel alignment done as the track rod end is not in the same place or has different dimensions from the original.
    Regards HMC

  3. #3
    New User
    Join Date
    Jan 2019
    Location
    Finland
    Posts
    4
    Post Thanks / Like
    Thanks for tips!

    What should I look for at wheel surrounding? Is there somewhere TCM connector or something? I have checked all the fuses on the drivers side inside car, but I have no idea where the TCM fuse is. Is it where is ECU, under the hood and on the drivers side?

    I will get the Wheel alignment done as soon as I get this sorted out, I dont want to drive with that car in case if that would brake the transmission completely… Getting pretty frustrated, should get the car working so I could go to work

  4. #4
    New User
    Join Date
    Jan 2019
    Location
    Finland
    Posts
    4
    Post Thanks / Like
    Quote Originally Posted by HMC View Post
    I think the first thing to do is retrace your steps of fitting the CV and track rod end, did you displace/disconnect/damage a TCM connector. Have you checked the fuses that power the TCM. You also need to get the wheel alignment done as the track rod end is not in the same place or has different dimensions from the original.
    Regards HMC
    I checked all fuses, they are okay. Could wheel alignment differense cause this? Or some other minor thing? Is there any way to see/test my TCM condition?

  5. #5
    Verified VCDS User
    Join Date
    Jul 2014
    Location
    UK
    Posts
    120
    Post Thanks / Like
    You need to make sure the TCM is powered and has a good earth. I cannot look at a wiring diagram until Monday. If you are sure it is powered, http://wiki.ross-tech.com/wiki/index...6/P0702/001794 does not look good.
    HMC

  6. #6
    New User
    Join Date
    Jan 2019
    Location
    Finland
    Posts
    4
    Post Thanks / Like
    Quote Originally Posted by HMC View Post
    You need to make sure the TCM is powered and has a good earth. I cannot look at a wiring diagram until Monday. If you are sure it is powered, http://wiki.ross-tech.com/wiki/index...6/P0702/001794 does not look good.
    HMC
    Yes, I found at ebay some used boxes for around 300€. Could you please provide me with an wiring diagram so I could check the wirings? I've been trying to look it myself, but havend found any diagrams.

  7. #7
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    23,448
    Post Thanks / Like
    Blog Entries
    1
    Please see: Where do I get a Wiring Diagram.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •