Results 1 to 6 of 6

Thread: Coding labels wrong for 8L0 central locking

  1. #1
    Verified VCDS User
    Join Date
    Nov 2017
    Location
    Latvia
    Posts
    137
    Post Thanks / Like

    Coding labels wrong for 8L0 central locking

    First tests of V2. Found a central locking pump behind my desk.
    Yes, oldschool you may have never seen in your life.

    [1]
    Tried to change coding of it.
    If I sum it myself looking at balloon popup, it's fine.
    Problem if I want to use Coding helper.



    "Coding details can be found it byte 01 & byte 02." Actually they are not.
    I can spoil totally valid coding by ticking/unticking some checkboxes and trying to save it.

    How to fix 8D0-862-257.lbl?
    Code:
    ;---------------------------------------------------
    ;
    ; converted coding
    ; (short coding displayed as long coding for easier modifications)
    ;
    ;---------------------------------------------------
    ;
    ;
    LC,01,0,Rear Lid Opening via Rear Lid Lock
    LC,01,1,Anti-Theft Confirmation via Blink
    LC,01,2,Selective Locking
    LC,01,3,Anti-Theft-System
    LC,01,5,Locking via Speed
    LC,01,6,Comfort Closing via Remote Control
    LC,00,0,Rear Lid Logic
    LC,00,1,Remote Control "Close" Confirmation (1x Blink)
    LC,00,3,Door/Window Logic (USA)
    LC,00,4,Remote Control "Open" Confirmation (2x Blink)
    LC,00,5,Remote Control
    LC,00,7=,Additional Coding Options can be found in Byte 01!
    ;
    OR needs another "00" automatically on the left of current coding in hex.


    [2]
    Let's say I take 8D0-862-257.lbl label from \Labels directory, make a copy into \Labels\User and edit wrong short coding (converted coding) in here.
    Later open 35 central locking, Coding, Coding Helper, but checkboxes are still labeled as in \Labels directory but not \Labels\User.
    Why isn't \Labels\User directory higher priority than \Labels?
    Last edited by _Val; 01-24-2019 at 03:18 AM.

  2. Likes Sebastian, Uwe, PetrolDave, Dana liked this post
  3. #2
    Ross-Tech Employee Sebastian's Avatar
    Join Date
    Feb 2014
    Location
    Magdeburg, Germany
    Posts
    1,945
    Post Thanks / Like
    There was a change in how we the decimal<>hexadecimal conversion is being handled and even though that was some time ago, it seems I did not make the correlating changes in all relevant places. Thanks for the hint, I'll make sure this is addressed in the next data version. As far as the LCode handling for \Labels\User\ goes, that was never really relevant - though maybe Niels will chime in and comment on whether or not he is going to alter the behavior.
    Sebastian @ Ross-Tech.com // VCDS Rookie since 2003

    »Nichts erweitert das eigene Wissen mehr,
    als die Meinung eines Andersdenkenden.«

  4. Likes Dana, _Val liked this post
  5. #3
    Verified VCDS User
    Join Date
    Nov 2017
    Location
    Latvia
    Posts
    137
    Post Thanks / Like
    Another observation when running Lcode.exe as standalone from windows explorer when need to load information file for checkboxes (label file), then default file type to choose from is XPL, not LBL although XPL files in \Labels are only 3 compared to 1333 LBL files. It just takes time to switch to LBL.

  6. #4
    Verified VCDS User TBAx's Avatar
    Join Date
    Dec 2016
    Location
    DE
    Posts
    478
    Post Thanks / Like
    ...but XPL is the standard.

  7. #5
    VCDS Distributor
    Join Date
    Feb 2014
    Location
    Denmark
    Posts
    1,743
    Post Thanks / Like
    Quote Originally Posted by _Val View Post
    It just takes time to switch to LBL.
    I have changed it to LBL first now, so now it takes time to change to XPL
    I use it daily about 52% for loading XPL and 48% for loading LBL, the time it takes is about 1 second!
    With the file manager open > press Tab > Press arrow down > Press arrow down > Enter > Enter > Write what you want to find your file.

    I also changed LCode, so LBL files are checked in \User directory.

  8. Likes _Val, Uwe, Dana, DrPeter liked this post
  9. #6
    Verified VCDS User TBAx's Avatar
    Join Date
    Dec 2016
    Location
    DE
    Posts
    478
    Post Thanks / Like
    Why not both? 😅

    I mean, why not add a default option „All supported files“ which contains *.lbl;*.xpl.

  10. Likes Uwe, _Val, Sebastian liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •