Page 6 of 6 FirstFirst ... 456
Results 51 to 56 of 56

Thread: 2013 A6 Allroad 4G C7 - xenon retrofit

  1. #51
    Ross-Tech Employee Dana's Avatar
    Join Date
    Jan 2014
    Location
    United States
    Posts
    3,516
    Post Thanks / Like
    That's a perfectly valid theory however my baseline scans have 34 coded to 008000, 008001, 008002 and 008003 so I don't believe that's the missing key. The 34 module LCH includes options such as:

    Trailer Recognition Control Module installed [PR-1D4/1M6/KF0/KF1/KF4/KF5]
    Adaptive Cruise Control (ACC) installed [PR-8T4]
    Audi Drive Select (ADS) Steering installed [PR-QZ7]

    Nothing headlight system specific as far as I can tell.

  2. Likes Uwe liked this post
  3. #52
    Verified VCDS User
    Join Date
    Jan 2019
    Location
    UK
    Posts
    82
    Post Thanks / Like
    OK - good to know. Here is another question - bear in mind this car was not equipped in factory with extended CAN bus and I have essentially directly connected the J431 module to the 'new' J533 module with twisted pair connection supplied in Kufatec loom - do the necessary CAN Bus termination resistors always reside in the CAN gateway ?

  4. #53
    Ross-Tech Employee Dana's Avatar
    Join Date
    Jan 2014
    Location
    United States
    Posts
    3,516
    Post Thanks / Like
    The resistors should reside inside the CAN Gateway to the best of my knowledge.

  5. Likes Uwe, nugentp liked this post
  6. #54
    Verified VCDS User
    Join Date
    Jan 2019
    Location
    UK
    Posts
    82
    Post Thanks / Like
    So a happy update which just about closes this thread nicely - I took the first code suggested by Dana - 11116F101000A200 and it was accepted.

    I noticed that called out an ECE LIMO so changed Bytes 00 & 01 to reflect RDW AVANT - 17226F101000A200

    The main byte that was blocking my attempts to get a code that worked was Byte 3 = 6F which was something I didn't try - gave up after other combinations that failed to get accepted.

    With the correct coding I was only left with a fault code for basic setting / calibration, so I ran through the sequence and fault codes all cleared. BRILLIANT - Thanks so much to Dana & others for helping me along the way on this - this thread should help others get the same result so much faster than I did !

    The only remaining niggle is that the module is coded as AVANT instead of ALLROAD - doubt it matters much but I tried all combinations of chassis type with ALLROAD in Byte 1 and none were accepted.

  7. Likes Dana, Uwe liked this post
  8. #55
    Ross-Tech Employee Dana's Avatar
    Join Date
    Jan 2014
    Location
    United States
    Posts
    3,516
    Post Thanks / Like
    Awesome! Do you mind posting a final Auto-Scan?

  9. #56
    Verified VCDS User
    Join Date
    Jan 2019
    Location
    UK
    Posts
    82
    Post Thanks / Like
    I already posted that in another thread about a possibly related coding related issue on the gateway. Link below:

    https://forums.ross-tech.com/showthr...l=1#post168781

    My theory is that the new CAN gateway is from a non-allroad 4G/C7 vehicle and the same coding bytes as my original CAN gateway (without ext bus) make it behave differently... or worse I need a very specific allroad version of the CAN gateway with extbus hardware. I need to look into that as the coding helper for the new gateway is all in German.

  10. Likes Uwe, Dana liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •