Results 1 to 3 of 3

Thread: Replaced manual gearbox cruize control doesn't function

  1. #1
    New User
    Join Date
    Aug 2018
    Location
    Romania
    Posts
    2
    Post Thanks / Like

    Replaced manual gearbox cruize control doesn't function

    Hello!
    First time poster, thanks for having me!

    I own a 2011 Exeo ST 2.0 143HP CAGA engine code, manual transmission.
    I've replaced the factory gearbox, code MPA, with a shorter geared HCK one. Since then the gear suggestion on the MFD rarely displays something, and when it does it's wrong. EX: telling me to change into 6'th when i'm already in it.
    The cruise control will only engage IF the gear suggestion is displayed.
    I'm guessing there must be a table somewhere based on wheel speed and engine rpm.

    Otherwise the car is much more flexible with this gearbox. I can now overtake on the highway in 6'th and the engine doesn't sound like a truck going uphill anymore.
    MPA: 3.30:1 differential, 78 Mph at 2000 revs in 6'th
    HCK: 3.75:1 differential, 68 Mph at 2000 revs in 6'th.

    How can it be fixed?
    Thank you!

  2. #2
    Verified VCDS User iichel's Avatar
    Join Date
    Aug 2016
    Location
    Switzerland
    Posts
    1,382
    Post Thanks / Like
    Well, the engine deduces the gear it's in with the clutch/neutral position sensor and then calculates the ratio between wheel speed and engine speed.
    Since your rations don't match what the engine is expecting it to be, ECU goes like 'NOOOPPE' and there goes your CC.

    I guess a solution would be to find a firmware or SW from a similar engine, but with this gearbox on it. Then flash it to your ECU.
    Even though that probably sounds more easy than it is.
    Or you have to be lucky and there is a shorter geared gearbox available in the long coding helper.

  3. Likes Uwe, Jack@European_Parts, Jetta ,97 liked this post
  4. #3
    New User
    Join Date
    Aug 2018
    Location
    Romania
    Posts
    2
    Post Thanks / Like
    Yes, that's what i was thinking.
    I had a look into the long coding.
    Current coding: 0304002C18072118.
    This was read last week. I seem to rememer there was one byte where i had the option to switch between 4 speed manual, 5 speed manula, 6 speed manual and automatic.
    I'll recheck once i get to the garage.
    I have my ecu dump if anyone is willing to assist.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •