Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: VW e-Golf MK 7 - 2015/16 - Coding issues

  1. #31
    Verified VCDS-User
    Join Date
    Jul 2018
    Location
    Netherlands
    Posts
    24
    Post Thanks / Like
    Hi All,

    Is someone able to tell me what the security code is for the "BD" module?

    Thanks!

  2. #32
    Administrator Andy's Avatar
    Join Date
    Jan 2014
    Location
    Sector 7G
    Posts
    2,502
    Post Thanks / Like
    I checked but have not found a Security Access for the BD module.

  3. Likes Uwe liked this post
  4. #33
    VCDS Distributor
    Join Date
    Feb 2014
    Location
    Denmark
    Posts
    1,736
    Post Thanks / Like
    Quote Originally Posted by trangakil View Post
    Is someone able to tell me what the security code is for the "BD" module?
    If any used, there can be more than one.
    Why and for what do you need a security code ?

  5. #34
    Verified VCDS-User
    Join Date
    Jul 2018
    Location
    Netherlands
    Posts
    24
    Post Thanks / Like
    Quote Originally Posted by Andy View Post
    I checked but have not found a Security Access for the BD module.
    Hi Andy,

    Thank you for the brief call yesterday and your reply!

  6. #35
    Verified VCDS-User
    Join Date
    Jul 2018
    Location
    Netherlands
    Posts
    24
    Post Thanks / Like
    Quote Originally Posted by NEtech View Post
    If any used, there can be more than one.
    Why and for what do you need a security code ?
    Hi NEtech,

    Changes to the module require a security access code. I have used a variety of the know codes, but it seems not to be one of those.
    I need it to change some values in the adaption mode (channels). Please see the third page for a more detailed description. If you have any knowledge about this code, I would really appreciate if you can help me out with it.

    Thanks.

  7. #36
    VCDS Distributor
    Join Date
    Feb 2014
    Location
    Denmark
    Posts
    1,736
    Post Thanks / Like
    First check measurement value: "Security Access: Number of invalid keys"

    If you want to test, try this, no guaranties.
    Copy this file to C:\Ross-Tech\VCDS-Beta\Labels\User
    Enter the show text for secure access in [BD].
    Please make screenshot of message(s).

  8. Likes Uwe, trangakil liked this post
  9. #37
    Verified VCDS-User
    Join Date
    Jul 2018
    Location
    Netherlands
    Posts
    24
    Post Thanks / Like
    Quote Originally Posted by NEtech View Post
    First check measurement value: "Security Access: Number of invalid keys"

    If you want to test, try this, no guaranties.
    Copy this file to C:\Ross-Tech\VCDS-Beta\Labels\User
    Enter the show text for secure access in [BD].
    Please make screenshot of message(s).

    Hi NEtech,
    Read your message today and tried it out, it worked! Unfortunately the goal is not achieved (I keep getting faults).
    Just wanted to thank you and update you, I will post a more eleborated update (with pictures) tomorrow.

  10. #38
    Verified VCDS-User
    Join Date
    Jul 2018
    Location
    Netherlands
    Posts
    24
    Post Thanks / Like
    Quote Originally Posted by trangakil View Post
    So after fixing the light problem, the next is already waiting. As described above I have tried some things, just one error I made in my description above. The adjustments can be made in the "BD-Hi Volt. Batt. Charg" module and not the 8c module as mentioned above.
    When I finished the lights yesterday, I started to swap (again) the wiring harness, so the same issues applied at first. However as recommended by Uwe earlier I have installed the Beta version of VCDS and started coding.
    The results are below:

    Original coding 1
    [IMG]

    Original coding settings


    Changes (after these changes 2 faults)


    The following 2 fault codes resulted after this:
    Code:
    1059842 - Charging Socket B 
              P33E2 00 [009] - Electrical Malfunction
              Confirmed - Tested Since Memory Clear
                 Freeze Frame:
                        Fault Status: 00000001
                        Fault Priority: 2
                        Fault Frequency: 5
                        Reset counter: 47
                        Mileage: 35950 km
                        Date: 2018.08.03
                        Time: 14:00:23
    
    1059074 - Charging Socket B; Plug Locking Detection 
              P31D6 00 [009] - Electrical Malfunction
              [Socket_B_Lock_Check_short_circuit_high]
              Confirmed - Tested Since Memory Clear
                 Freeze Frame:
                        Fault Status: 00000001
                        Fault Priority: 2
                        Fault Frequency: 5
                        Reset counter: 47
                        Mileage: 35950 km
                        Date: 2018.08.03
                        Time: 14:00:23

    So after trying some more coding options I changed the following and just one fault code remained:

    Changes part 2:




    1 Fault code remains:


    With this remaning fault code the car thinks the cable is plugged in (while it is not) and therefore it won't start.

    So in my opinion, based on the information I have at the moment, the following options have came up (from my side):
    1. I'm missing something in the Codingtable (I have to select another option);
    2. I have to adapt some things through the adaption channels (however I don't now what the settings should be and in addidion there is a accescode required which I don't have);
    3. The VCDS beta version, has some bugs and therefore not working properly when coding this module (experimental coding);
    4. The relais of the locking mechanism is broken, that is also what the fault code is indicating. However should not be the case, but anything is possible!

    Does someone have any other ideas / solutions?

    Thanks in advance!
    So as promised yesterday, I would provide a more elaborated update today.
    After the last coding attempt as described in post 33, I asked a cardealership (which had a EU e-Golf from 2015 for sale) if I could hook up VCDS to it. After doing that I made an autoscan of that vehicle and a controllermap of the "BD" unit.
    Comparing my controllermap to this one showed me some differences:


    In order to change the values I needed to code the module, with help of NEtech I was able to gain security access and to change values within the adaption channels.

    However after changing the values (tried for socket A and B) it still gave me one fault and the car still thinks there is a cable plugged in (while it is not).

    Code:
    2097921 - External Plug on Charging Socket A 	
              P33EC 00 [009] - Electical Malfunction	
              Confirmed - Tested Since Memory Clear	
                 Freeze Frame:	
                        Fault Status: 00000001	
                        Fault Priority: 2	
                        Fault Frequency: 1	
                        Reset counter: 48	
                        Mileage: 35996 km	
                        Date: 2018.08.16	
                        Time: 15:33:10	
    	
                        Power outlet A for battery charging-Locking for H-V charge plug: not locked	
                        Power outlet A for battery charging-Status connect. recognition: detected	
                        Power outlet A for battery charging-Connector locking requirement: 0	
                        Power outlet A for battery charging-Connector unlocking requirement: 0	
                        Power outlet A for battery charging-Max. current of charge connector: 0 A	
                        Power outlet A for battery charging-Activation charge cover lock charge socket A: not requested	
                        Power outlet A for battery charging-Status charge cover lock charge socket A: not locked	
                        Power outlet A for battery charging-Activation charge cover unlock charge socket A: not requested	
                        Power outlet A for battery charging-Charge socket temperature sensor AC: 21.80 C	
                        Power outlet A for battery charging-Charge sensor temperature sensor DC: 21.80 C
    And if I code socket B:
    Code:
    1059074 - Charging Socket B; Plug Locking Detection 	
              P31D6 00 [009] - Electrical Malfunction	
              [Socket_B_Lock_Check_short_circuit_high]	
              Confirmed - Tested Since Memory Clear	
                 Freeze Frame:	
                        Fault Status: 00000001	
                        Fault Priority: 2	
                        Fault Frequency: 1	
                        Reset counter: 48	
                        Mileage: 35996 km	
                        Date: 2018.08.16	
                        Time: 16:24:37
    After also swapping the relais for the locking mechanism it seems the relais is working correct.

    Leaving me with the remaning conclusion:
    1. I'm just doing it wrong and missing something;
    2. I need to flash the module to an EU version with ODIS.


    Screenshots for NEtech:







Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •