Results 1 to 4 of 4

Thread: Hex-v2 worked at first...now I just get communication errors

  1. #1
    Verified VCDS User
    Join Date
    Apr 2018
    Location
    USA
    Posts
    2
    Post Thanks / Like

    Hex-v2 worked at first...now I just get communication errors

    Trying to adapt a used ecm from the junkyard to my 2000 mk4 golf gls tdi Immo-2. Doing this to minimize downtime while I send off my current ecu to get tuned. Both part numbers are exactly the same except one is German (original) and the secondhand one I bought From the junkyard says Brazil on the metal housing. I was only able to communicate with my ecu a handfull of times before I just kept getting communication errors. On the used ecu I followed the instructions on the Immo 2 instructions and I couldn’t get it to start the car, then it wouldn’t connect at all. I tried two different computers same result. Also of note is I’ve bought a used cluster off eBay as well because I ruined my old cluster with a botched soldiering job where I tore off a pad to the check engine light led, which was probably just fine. but I’ve been chasing this no check engine light on key on down a long and deep bunny hole it’s driving me nuts I’ve got about 50 days until the smog is due. looking for guidance

  2. #2
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    23,087
    Post Thanks / Like
    Blog Entries
    1
    I rather doubt the problem is your HEX-V2. More likely the car, which sounds to be something of a disaster area.

    Communications with the ECU on those cars goes through the cluster. Pull the cluster, put a jumper between the "K" and the "W" pins on the two harness connectors and then see if you have comms to the ECU.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

  3. #3
    Verified VCDS User
    Join Date
    Apr 2018
    Location
    USA
    Posts
    2
    Post Thanks / Like
    Will do. Is that on the blue connector? Yah this car has turned into a bit of a dumpster fire disaster. And to top it off I had the spiciest Indian food I’ve ever eaten in my life yesterday, which is ok because I do my best thinking and paperwork on the toilet.

  4. #4
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    23,087
    Post Thanks / Like
    Blog Entries
    1
    Quote Originally Posted by Shiftypower View Post
    Will do. Is that on the blue connector? Yah this car has turned into a bit of a dumpster fire disaster. And to top it off I had the spiciest Indian food I’ve ever eaten in my life yesterday, which is ok because I do my best thinking and paperwork on the toilet.
    I don't have wiring diagrams handy, but my recollection is that "K" is on one connector and "W" is on the other.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •