Results 1 to 10 of 10

Thread: Interface Not Found

  1. #1
    Verified VCDS User
    Join Date
    Sep 2014
    Location
    USA
    Posts
    3
    Post Thanks / Like

    Interface Not Found

    Have a HEX-CAN USB that has worked like a charm for the past year. Suddenly not working - tried it on 3 different vehicles, 2 different laptops, no luck. Getting "Interface: Not Found!" message when I test the port. LED on the interface is solid green.



    Any ideas?

    Thanks!

  2. #2
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    22,996
    Post Thanks / Like
    Blog Entries
    1
    What happens if you just plug it into your computer (but not the car)?

    Also, does Device Manager see it?

    -Uwe-

  3. #3
    Verified VCDS User
    Join Date
    Sep 2014
    Location
    USA
    Posts
    3
    Post Thanks / Like
    Device manager recognizes it as "Ross-Tech Direct USB Interface" and indicates that "This device is working properly". Tried it on 2 different laptops with same result.

  4. #4
    FoRT jyoung8607's Avatar
    Join Date
    Feb 2014
    Location
    Cincinnati, OH
    Posts
    2,294
    Post Thanks / Like
    Quote Originally Posted by VectorA7 View Post
    Device manager recognizes it as "Ross-Tech Direct USB Interface" and indicates that "This device is working properly". Tried it on 2 different laptops with same result.
    We've seen this problem on the forum once before, and the original owner was able to fix it, but there was some debate as to how. Is it possible you've used it with version 14.X, either Beta or Release, and are now trying to use it with an older release of 12.X? Once the interface's firmware has been updated with one of the 14.X releases, it will only work with 14.X or the very latest 12.X release (12.12.3). It's best if you download and install the current release of VCDS if you haven't already. That's version 14.10.0 as of today.

    If that doesn't work, let's de-install the odd driver, and get the right driver installed. With your HUC interface plugged in, go into Device Manager and find the Ross-Tech interface. Right-click and bring up Properties, and go to the Driver tab. It should look something like this, although this is with the correct driver:



    Then, click the Driver Details button and make note of the files and versions listed. It would be good if you can post those here. It would be nice to know where this strange driver is coming from.



    Then, click the Uninstall button and un-install the current drivers.



    After that, un-plug your HUC interface. Then, un-install and re-install VCDS. It should install the correct, current driver package. Once that's done, go ahead and plug your HUC interface back in, and hopefully it will pick up the correct drivers this time.

    Jason

  5. #5
    FoRT jyoung8607's Avatar
    Join Date
    Feb 2014
    Location
    Cincinnati, OH
    Posts
    2,294
    Post Thanks / Like
    Following up to myself --

    If the above doesn't work, please post the hardware PID/VID info as Uwe described in the other thread I linked. I peeked at the driver INF file and "Ross-Tech Direct USB Interface" does seem to be a valid name for a hardware variant supported by that same driver. I'm not sure why mine would identify differently from yours, but mine is almost ten years old.

    Jason

  6. #6
    Ross-Tech Employee Eric's Avatar
    Join Date
    Jan 2014
    Location
    Lansdale, PA, USA
    Posts
    2,724
    Post Thanks / Like
    First things first, as Jason mentioned, which version of VCDS are you running?

  7. #7
    Verified VCDS User
    Join Date
    Sep 2014
    Location
    USA
    Posts
    3
    Post Thanks / Like
    OK guys - think you nailed it. I was originally using a laptop with vers 12.12.0, switched to a laptop with 14.8 Beta, and then switched back to the original laptop with 12.12.0. And had the problem with both laptops.

    So now, just upgraded the first laptop to 14.10.0 and reloaded the current drivers as Jason said. Everything seems to be working.

    Thanks for all the help!

  8. Likes Eric, jyoung8607 liked this post
  9. #8
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    22,996
    Post Thanks / Like
    Blog Entries
    1
    Yeah, when in doubt, make sure all software, drivers, and firmware are current.

    -Uwe-

  10. #9
    Verified VCDS User
    Join Date
    Nov 2014
    Location
    Romania
    Posts
    1
    Post Thanks / Like
    got similar problem interface not found. Device manager does not recognizes it as "Ross-Tech Direct USB Interface" any help ?

  11. #10
    Benevolent Dictator Uwe's Avatar
    Join Date
    Jan 2014
    Location
    Earth
    Posts
    22,996
    Post Thanks / Like
    Blog Entries
    1
    Quote Originally Posted by tuner View Post
    got similar problem interface not found. Device manager does not recognizes it as "Ross-Tech Direct USB Interface" any help ?
    Which interface? I show two in your records, a HEX+CAN from 2014 and a HEX-V2 from 2018.

    The HEX-V2 enumerates as an HID device.

    -Uwe-
    The engineering problems are likely insurmountable. It would be like proposing to land a rocket booster section on a barge floating in the middle of the ocean.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •