Results 1 to 4 of 4

Thread: 2010 TDI Cluster Reading 2-4 not mileage

  1. #1
    Verified VCDS User
    Join Date
    Mar 2014
    Posts
    16
    Post Thanks / Like

    2010 TDI Cluster Reading 2-4 not mileage

    Anyone have anything like this happen before, the cluster display shows a 2-4 where it should read the miles, do I need to reprogram it, or buy a new one and enter in the correct miles from the ecu?

    If you swap in another cluster from a gas or other tdi, it simply says safe or safe and immobilzer. Car just needs to run and show the miles so I can turn it back to vw, any advice or things to check would be very helpful.

  2. #2
    Verified VCDS User
    Join Date
    Mar 2014
    Posts
    16
    Post Thanks / Like
    Forgot to add my car is an automatic, I do have another car for parts that I can swap the key, ecu, and cluster in to see if that would work but it is a manual car.

  3. #3
    Verified VCDS User iichel's Avatar
    Join Date
    Aug 2016
    Location
    The Hague, NL
    Posts
    1,535
    Post Thanks / Like
    A bit more background info (i.e. JPPSG) and a full autoscan would be very helpful to see what exactly we're dealing with here.

  4. Likes Uwe liked this post
  5. #4
    Verified VCDS User
    Join Date
    Aug 2015
    Location
    UK
    Posts
    60
    Post Thanks / Like
    That is what comes up when programming keys. That means the car has been told there are 4 keys, the 2 means there are 2 that have been successfully programmed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •