Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: HEX-V2 software periodically freezing using UDS

  1. #21
    Ross-Tech Employee Eric's Avatar
    Join Date
    Jan 2014
    Posts
    2,511
    Post Thanks / Like
    Quote Originally Posted by VWT6 View Post
    Thanks. Mailed to support@ debug and log files for 2 runs with 1024 debug option on.

    Unfortunately I didn't realize that VCDS concatenated both runs into one debug file - that's why it is huge . And there doesn't seem to be obvious point where second debug starts in the file. Originally planned just to have a short run and mail the results. But continued after the first one to gather more data in case the first one fails to glitch.

    Anyways, seems that it made it's way through ... at least I haven't received reject note...
    Confirmed same issue, the "Turbocharger 1 turbine inlet; temp. sensor 1 bank 1; raw value" result sometimes confuses VCDS with regards to the "Lambda value at inlet of particulate filter". I'll mull on it
    You ain't metal till you got a clutch pedal

  2. Likes Uwe, VWT6 liked this post
  3. #22
    Ross-Tech Employee Eric's Avatar
    Join Date
    Jan 2014
    Posts
    2,511
    Post Thanks / Like
    Try this:
    http://download.ross-tech.com/VCDS/d...x64-171004.rar
    I'm pretty happy with this new idea; it should cure all your issues and is even more efficient than before. Let me know if anything looks wrong, but I did quite a bit of testing already.
    You ain't metal till you got a clutch pedal

  4. Likes Uwe, Zenerdiode, Dana, VWT6 liked this post
  5. #23
    Verified VCDS User
    Join Date
    Jan 2017
    Location
    Finland
    Posts
    19
    Post Thanks / Like
    Quote Originally Posted by Eric View Post
    Try this:
    http://download.ross-tech.com/VCDS/d...x64-171004.rar
    I'm pretty happy with this new idea; it should cure all your issues and is even more efficient than before. Let me know if anything looks wrong, but I did quite a bit of testing already.
    Thanks again. Unfortunately I won't have a chance to try before 15th of Dec. I'll report back then.

  6. Likes Eric liked this post
  7. #24
    Verified VCDS User
    Join Date
    Jan 2017
    Location
    Finland
    Posts
    19
    Post Thanks / Like
    Quote Originally Posted by Eric View Post
    Try this:
    http://download.ross-tech.com/VCDS/d...x64-171004.rar
    I'm pretty happy with this new idea; it should cure all your issues and is even more efficient than before. Let me know if anything looks wrong, but I did quite a bit of testing already.
    Yep. A lot better . I did three runs, total of 13551 lines each 12 measuring values with same setup as before. I found one (1) glitch similar to what saw before. Unfortunately it was in first run when I didn't yet have the debug on

  8. Likes Uwe liked this post
  9. #25
    Verified VCDS User
    Join Date
    Jan 2017
    Location
    Finland
    Posts
    19
    Post Thanks / Like
    Quote Originally Posted by VWT6 View Post
    Yep. A lot better . I did three runs, total of 13551 lines each 12 measuring values with same setup as before. I found one (1) glitch similar to what saw before. Unfortunately it was in first run when I didn't yet have the debug on
    Oops.. Well, just being back on-line noticed that there was a firmware update for HEX-V2 (CB: 0.4409.4) which has an improvement related to grouped requests. So, the previous runs were with CB: 0.4408 = the exact same setup as a few weeks ago.

    I'll do another run with updated one soon...

  10. Likes Uwe liked this post
  11. #26
    Verified VCDS User
    Join Date
    Jan 2017
    Location
    Finland
    Posts
    19
    Post Thanks / Like
    Quote Originally Posted by VWT6 View Post
    Oops.. Well, just being back on-line noticed that there was a firmware update for HEX-V2 (CB: 0.4409.4) which has an improvement related to grouped requests. So, the previous runs were with CB: 0.4408 = the exact same setup as a few weeks ago.

    I'll do another run with updated one soon...
    I did a run. Recorded probably just one glitch at time stamp 1232.73 sec in total of more than 160 ksamples - not too bad - emailed the debug files to support@ross-tech.com - if interested...

  12. Likes Andy, Dana, Uwe, Eric liked this post
  13. #27
    Ross-Tech Employee Eric's Avatar
    Join Date
    Jan 2014
    Posts
    2,511
    Post Thanks / Like
    Here: http://dltemp.ross-tech.com/VCDS/dow...taller-RC0.exe
    This one took quite a bit of thinking, but I think I've found a way to prevent VCDS from being confused when the data for a given identifier is the same as the identifier itself which is what was happening for your lone glitch with the O2 sensor. Again, I truly appreciate all you've done to help us come this far compared to the original glitches (and freezes)
    You ain't metal till you got a clutch pedal

  14. Likes Andy, Uwe, VWT6, Bruce, DrPeter and 1 others liked this post
  15. #28
    Verified VCDS User
    Join Date
    Jan 2017
    Location
    Finland
    Posts
    19
    Post Thanks / Like
    Quote Originally Posted by Eric View Post
    Here: http://dltemp.ross-tech.com/VCDS/dow...taller-RC0.exe
    This one took quite a bit of thinking, but I think I've found a way to prevent VCDS from being confused when the data for a given identifier is the same as the identifier itself which is what was happening for your lone glitch with the O2 sensor. Again, I truly appreciate all you've done to help us come this far compared to the original glitches (and freezes)
    While you were working on my debug file, I did another run of 30+ minutes using old setup just to gather more data just in case... and noticed two glitches in that run. So it was quite rare event already then.

    First thing in the morning I downloaded the installer and updated also HEX-V2 firmware to CB:0.4410.4 as instructed by the installer. I did two runs, each 32+ minutes. Total of 24820 lines, each 12 measuring values. Not a single glitch and all the values seem to carry plausible values. Thanks again

  16. Likes Uwe, jyoung8607, Eric, Andy, Dana liked this post
  17. #29
    Verified VCDS User
    Join Date
    Jun 2014
    Location
    Latvia
    Posts
    43
    Post Thanks / Like
    Hello.
    Is this 17.12 beta fw update issue is connected with some kind of my vcds status due to this thread?



  18. #30
    Ross-Tech Employee
    Join Date
    Jan 2014
    Posts
    1,591
    Post Thanks / Like
    Your HEX-NET is not set to Beta Channel. Click the advanced tab and select beta and press change channel. Once changed, Check for updates.


  19. Likes Eric, Uwe liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •