Quote Originally Posted by Davekes View Post
Can you glean anything useful from the battery log? It suggests that the battery currently in the car was never coded. But the dates are weird, the car wasn't built until 2005 but the dates in the log file are earlier than this.
I think you're misinterpreting some dates as 'funny dates'. I believe the BEM populates some data table entries with data that looks like it was written 01/01/2000 [before the car was even designed]. The BEM clears the tables to dummy entries when the Battery is recoded.

Here's an edited sample from my A8 straight after a battery recode

Code:
Record 1/18: No-load voltage underranging
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000*00000***
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000*00000***
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000**
2000-01-01,00:00:00*0000*000*00000***

Record 2/18: No-load current overranging 
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000**
2000-01-01,00:00:00*0000*00.00*000*00000***
The only 'old dates' I see in your BEM logs are from Nov/Dec 2004, which is not invalid for a 2005 Model Year car. There are Record 5 [Battery change] and Record 18 [Cluster Date change] dates that come from this era too. Have you actually checked the build date of your car? 2005 cars were built from July 2004 onwards ...

Julian