Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: 1996 passat GLX won't record readiness

  1. #11
    NostraJackAss Jack@European_Parts's Avatar
    Join Date
    Jan 2014
    Location
    1001 State Route 17K Montgomery New York 12549
    Posts
    16,770
    Post Thanks / Like
    Same result. Amazingly, SAI runs and passes on this car and is the easiest test to see if it passes readiness. So I run that test first and check readiness. Cycle the key and still readiness isn't set for SAI. Throttle body adapted okay in MBV 098. Both EVAP and LDP pass in their respected MBV, but still don't record.
    That's because you haven't done all the readiness tests and in sequence as identified in the RTFB, further know how you think the tests work or as defined in the diagnostic stack.

    In order for SAI to pend and flip the actual bit the EVAP, OXS + aging and Knock sensor slope and after the CAT will it flip the bit and all in the same DCY!

    Just because you have a "100" in a respective basics block test, doesn't mean you automatically get a bit flip in the actual readiness status of zero.


    NostraJackAss Has Spoken!
    European Parts Emporium/Performance / Immobilizer Solutions EPE
    Certified Master Trained NY/BAR/BAD 7076062/ASE/SAE/NASTF Legal Factory Authorized/Licensed GeKo/FaZit # 403738
    Specializing in Custom Services IE: "welding-fabrication" / EPA-SMOG Update or Pass-Thru-Programming / Data Transfer / Immobilizers & OEM Quality Parts
    Above Magic! No Written record, AUTO-SCAN or Appointment = NO HELP!
    www.FixMyEuro.com <<<<<CLICK HERE! or vwemporium@aol.com ( JPPSG & Unverified members need not PM me & Please don't email or call facility for free tech support...use the forum )
    Getting you CONTROL again of your property - TAKE IT! In Conjunction with.........

  2. Likes Uwe liked this post
  3. #12
    Verified VCDS User hans j's Avatar
    Join Date
    Mar 2014
    Location
    Utah
    Posts
    44
    Post Thanks / Like
    I realize that, and have experienced it before. But the first time I tried to set the readiness I followed the procedure found on page 23 here: https://www1.snapon.com/Files/Diagno...CodeCharts.pdf

    Pretty much all of them were set to 100 after a short test drive, ~3 miles. I have had issues setting a few Mk3 and B4 cars in the past, and it usually works out after a short drive and cycling the key. That is why I know something is up with this one, or else I wouldn't have asked for help here!

    I'll try it yet again though, not much else going on at work today...

  4. #13
    NostraJackAss Jack@European_Parts's Avatar
    Join Date
    Jan 2014
    Location
    1001 State Route 17K Montgomery New York 12549
    Posts
    16,770
    Post Thanks / Like
    I realize that, and have experienced it before. But the first time I tried to set the readiness I followed the procedure found on page 23 here: https://www1.snapon.com/Files/Diagno...CodeCharts.pdf

    Pretty much all of them were set to 100 after a short test drive, ~3 miles. I have had issues setting a few Mk3 and B4 cars in the past, and it usually works out after a short drive and cycling the key. That is why I know something is up with this one, or else I wouldn't have asked for help here!

    I'll try it yet again though, not much else going on at work today...
    I wouldn't.........there is your problem my friend, that is not the correct procedure documented accurately in the PDF & the tests are out of sequence!

    You need to follow the OEM guide in the "factory repair" manual for a 1996 GLX OBD2 AAA to the letter not some incomplete Snap-On tool guide.
    European Parts Emporium/Performance / Immobilizer Solutions EPE
    Certified Master Trained NY/BAR/BAD 7076062/ASE/SAE/NASTF Legal Factory Authorized/Licensed GeKo/FaZit # 403738
    Specializing in Custom Services IE: "welding-fabrication" / EPA-SMOG Update or Pass-Thru-Programming / Data Transfer / Immobilizers & OEM Quality Parts
    Above Magic! No Written record, AUTO-SCAN or Appointment = NO HELP!
    www.FixMyEuro.com <<<<<CLICK HERE! or vwemporium@aol.com ( JPPSG & Unverified members need not PM me & Please don't email or call facility for free tech support...use the forum )
    Getting you CONTROL again of your property - TAKE IT! In Conjunction with.........

  5. #14
    NostraJackAss Jack@European_Parts's Avatar
    Join Date
    Jan 2014
    Location
    1001 State Route 17K Montgomery New York 12549
    Posts
    16,770
    Post Thanks / Like
    Please see the JPPSG I amended it for ABA and AAA readiness.

    http://forums.ross-tech.com/showthre...ll=1#post95202
    Last edited by Jack@European_Parts; 05-12-2017 at 04:42 PM.
    European Parts Emporium/Performance / Immobilizer Solutions EPE
    Certified Master Trained NY/BAR/BAD 7076062/ASE/SAE/NASTF Legal Factory Authorized/Licensed GeKo/FaZit # 403738
    Specializing in Custom Services IE: "welding-fabrication" / EPA-SMOG Update or Pass-Thru-Programming / Data Transfer / Immobilizers & OEM Quality Parts
    Above Magic! No Written record, AUTO-SCAN or Appointment = NO HELP!
    www.FixMyEuro.com <<<<<CLICK HERE! or vwemporium@aol.com ( JPPSG & Unverified members need not PM me & Please don't email or call facility for free tech support...use the forum )
    Getting you CONTROL again of your property - TAKE IT! In Conjunction with.........

  6. #15
    Verified VCDS User hans j's Avatar
    Join Date
    Mar 2014
    Location
    Utah
    Posts
    44
    Post Thanks / Like
    Unfortunately the rest of the literature I have read on setting readiness for this vehicle is much less specific than what the Snap On PDF says, and what I've done for years. Once upon a time I found the same procedure in eBahn or something, but now the only procedure I'm finding in IATN, eBahn, and my Mk3 Bentley manual says to run SAI then go drive it.

    I just went out again and set everything except MBV 125 and 153, but everything else passed their tests, SAI, O2 aging and cycles, catalytic converter, and the 150 EVAP.

    Your list might even have some discrepancies, but I did follow it and then move on to the rest of the tests as I know them...

    Quote Originally Posted by Jack@European_Parts View Post
    Now back to readiness for geeks ........

    Early ME 5.xx short VAG Readiness for ABA and AAA 96-99

    Key On not running.
    0x01-07- Same data default eeprom Key off 1 minute.
    0x01-10-00 Clear ADP default Key off 1 minute
    0x01-02-05 Read/Clear DTC's
    0x01-04-098 ADP TV wait until unit stops buzzing 30 seconds! Then Key off 1 minute.
    0x01-02 check DTC's if none commence if not sort conditions.
    * Proceed*
    0x01-08-098 Verify ADP-ok for TV.
    * Proceed*
    Engine running at idle and clear out with a couple blips of TV before testing.
    0x01-04-053 LDP if supported field 4 0000100 desired as passed. ( separate vacuum line test not N80 )
    0x01-04-151 EVAP shared byte with LDP for readiness monitor same desired value in binary. ( N80 Test )
    0x01-04-160 SAI test 00000100
    0x01-04-103 Getting tired will finish later on.
    Did you mean 0x01-04-153 for LDP?
    and 0x01-04-151 doesn't work for EVAP, and I don't think I've ever had it test or need to test it. But 0x01-04-150 runs the N80.

    If you have a specific way of setting the readiness, I"m ready to try it. But honestly I'm not sure it will work.

    Also when I was swapping to another ECU to try, apparently VCDS was in the middle of thinking it needed to update, but my HEX-NET didn't tell me. So I was only able to read the first field of each MBV, and it was really messing with my head. Readiness said it was set at the top of the readiness screen, but no tests would run and below in the description it said it was all not ready. It wasn't until I tried to check for misfires on another car that I realized it was a VCDS issue, not a Passat ECU or wiring issue. I updated to the latest firmware and beta 17.4.2 and everything now works correctly again!

  7. #16
    NostraJackAss Jack@European_Parts's Avatar
    Join Date
    Jan 2014
    Location
    1001 State Route 17K Montgomery New York 12549
    Posts
    16,770
    Post Thanks / Like
    I was writing that half asleep a while back and the forum doesn't let me edit old posts so yeah that snippet wasn't meant to be left up.

    Please go here http://forums.ross-tech.com/showthre...ll=1#post95202
    European Parts Emporium/Performance / Immobilizer Solutions EPE
    Certified Master Trained NY/BAR/BAD 7076062/ASE/SAE/NASTF Legal Factory Authorized/Licensed GeKo/FaZit # 403738
    Specializing in Custom Services IE: "welding-fabrication" / EPA-SMOG Update or Pass-Thru-Programming / Data Transfer / Immobilizers & OEM Quality Parts
    Above Magic! No Written record, AUTO-SCAN or Appointment = NO HELP!
    www.FixMyEuro.com <<<<<CLICK HERE! or vwemporium@aol.com ( JPPSG & Unverified members need not PM me & Please don't email or call facility for free tech support...use the forum )
    Getting you CONTROL again of your property - TAKE IT! In Conjunction with.........

  8. #17
    Verified VCDS User hans j's Avatar
    Join Date
    Mar 2014
    Location
    Utah
    Posts
    44
    Post Thanks / Like
    Well thanks for the belittling reply, very helpful. It's actually not that different from the Snap On version which I've used successfully many times. This car however needed an extra step that isn't even in your chart.

    I followed your directions with the exception of 1- The WSC wouldn't change for me, and 2- LDP (153) has not ever run for me, so I would have been waiting all day. So I skipped it and went on to 150 as I always have. SO everything passed as usual in the MBV, but not record it. I did it twice, with the same result.

    It turns out that after everything has been set, this particular car needed 0x01-04-103 to run again with the result of XX1XXX10. So why don't you add that to your reply for the next dumbass to come along...

    Quote Originally Posted by Jack@European_Parts View Post
    Readiness code, creating 96 > 1999 ABA AAA for the complete Stupid Dumbass!
    http://forums.ross-tech.com/showthre...ut-0x01-08-000

    Note for vehicles all M.Y. 96>99!
    If using the procedure to verify a repair, go to the appropriate work step and verify that
    repair but, if creating a readiness code from scratch, follow the work steps in sequence and do not
    switch the ignition off until the sequence has been completed, okay dumbass?

    Note:
    If a particular bit that you are watching in the Readiness code is obtained sooner than
    the time specified in the procedure, you can immediately proceed to the next work step.
    An "x" in the diagnostic status means the display can be either a "0" or a "1"
    There must not be a malfunction stored in DTC memory and there must not be any
    malfunctions detected during diagnostic test!

    Work Step 1 compounded work procedure!

    Hook up VCDS and with ignition ON "not running", check for DTC's and even if none present, erase DTC's after doing an Output diagnostic test mode. Do this to at least hear the SAI pump or combi & N80 EVAP solenoid click!
    0x01-03 > GO

    These steps will ensure clearing the EEPROM.
    0x01-02-05
    Now recode the model with an alternate WSC, other than what is present dumbass & be sure your VCDS is configured for WSC Importer # and Tester #..... You with me so far dumbass?
    0x01-07-SAME codification data and your new WSC should be displayed in main ID of 0x01 follow it up being observed!
    0x01-10-00 SAVE clear all ADP data!
    KEY off 1 minute and wait dumbass!

    Step 2

    Open hood and observe the throttle cable is set correctly & for full basic setting sweep offset and that the TV is clean + Lubricated
    You with me so far dumbass? Now check the battery health or at very least assist with battery charger if under 12.5 after 15 minutes static on the stop watch during your aforementioned TV clean up!
    Check the SAI fuse condition by the battery because it always gets corroded stupid!

    Now get your ass back in the car turn Ignition ON "engine not running" check DTC's.
    0x01-02 >No codes proceed stupid!
    0x01-04-098 ADP TV
    Wait stupid & until the TV stops buzzing!
    Turn off the key for 1 minute to ensure a saved consistent EEPROM.

    Step 3

    Turn Key ON again, "engine not running" yet and scan for DTC's
    0x01-02 NONE GOOD >
    Now check the TV status in blocks.
    0x01-08-098 ADP-OK 4TH field >
    Now check the battery voltage
    0x01-08-004 and if OK start engine let idle.
    0x01-04-000 Basics ON initiated 1 minute at idle.

    Shared bit for EVAP and LDP so pay attention stupid!
    At idle Immediately switch to LDP test if supported at 0x01-04-153 ON > Wait for Binary display XXXXX100 If a 1 is indicated in last binary location you have a DTC so stop and go fix it dumbass!
    0x01-04-150 EVAP XXXXX100 Good proceed > or same as aforementioned in LDP

    Step 4

    Prepare for short slow road test in second gear and the following queried.
    Do this at 2000 RPM and up to 3500 and get the 1 to be there for 1 minute during steady RPM to achieve the below binary result.
    0x01-08-103
    Field 4 xx1x xx00 <<<<<<<<<<<<<< The one is what you are looking for to indicate the OXS control has become active.
    Be advised you are to be in blocks 08 dumbass, not 04 basic settings when doing this observation test!

    Once achieved OXS control pull over and idle for 30 seconds before commencing next step!

    Step 5

    SAI Command
    0x1-04-160 at idle.
    Result should be : XX11X100

    Step 6

    TWC Aging using OXS control.
    Again road test in second gear and limit steady speed to RPM value for 2 minutes @ 2100-2400 RPM range.

    0x01-04-103

    This time yes dumbass we are in basic settings, very good for realizing & FYI the book is wrong asking for blocks again!
    Your catching on.........now they are dumbass's and you are matriculating in the school of hard NOX.
    Now after you have the binary XX1XXX00 and a temp in field 3 of 360 Celsius or better pull over!

    Not driving parked idling switch to 0x01-04-131 ON and more aging the OXS test commences.
    Result XXXXX100
    Note:
    Avoid deceleration fuel cut-off during this diagnostic test. It causes the three way catalytic
    converter to store oxygen, diagnostic test will then be blocked for at least 10 seconds


    Step 7

    OXS adaption mean value!
    0x01-04-125
    Okay back on the road second gear again and RPM range 2000-4000 RPM until binary until shows 01X1XXXX
    Now stop again and pull over to let it idle with basics still active & binary should complete XXXXX100

    Note:
    Avoid deceleration fuel cut-off during this diagnostic test. It causes the three way catalytic
    converter to store oxygen, diagnostic test will then be blocked for at least 10 seconds.

    Step 8

    Car parked.
    The slope 0x01-04-130 at 2200-2800 RPM & in less than 15 seconds should be at least 0-4 in field 3
    XXXXX100

    Step 9

    Car Parked.
    CAT test 0x01-04-136
    RPM range 2500-4500 observe the amplitude in field 3 and temp in field 2 must be above 360 C
    before starting this test.
    I recommend running the car at 3000 RPM steady for 1 minute before engaging this test!

    Step 10

    Throttle test......offset and lift after acceleration.
    Road test again using second gear RPM value 3200-4000 RPM for 15 seconds!
    0x01-04-180
    XXXXX100

    Step 11

    Parked!
    Knock sensor amplification factor.
    2500 RPM steady.
    0x01-04-145 Field 3 should count to about 5-6 7 max
    XXXXX100

    Step 12

    Parked!
    OXS heaters 0x01-04-115
    RPM 2100-2800 range to initiate test steady throttle
    XXXXX100

    Step 13

    Parked!
    OXS after CAT
    RPM 2100-2800 range to initiate test steady throttle
    0x01-04-116
    XXXXX100

    Step 14

    Parked!
    OXS heating before TWC
    0x01-04-120 & 121
    RPM 2100-2800 range to initiate test steady throttle
    XXXXX100

    Step 15
    Parked!
    0x01-04-140, 141, 142 at idle in each for at least 1 minute each!

    Step 16
    0x01-15- 00000000
    You should be READY & no longer a loser .......Congratulations dumbass!
    Oh, and battery voltage is in 0x01-08-002
    Last edited by hans j; 05-15-2017 at 11:42 AM.

  9. #18
    NostraJackAss Jack@European_Parts's Avatar
    Join Date
    Jan 2014
    Location
    1001 State Route 17K Montgomery New York 12549
    Posts
    16,770
    Post Thanks / Like
    Well thanks for the belittling reply, very helpful. It's actually not that different from the Snap On version which I've used successfully many times. This car however needed an extra step that isn't even in your chart.

    I followed your directions with the exception of 1- The WSC wouldn't change for me, and 2- LDP (153) has not ever run for me, so I would have been waiting all day. So I skipped it and went on to 150 as I always have. SO everything passed as usual in the MBV, but not record it. I did it twice, with the same result.

    It turns out that after everything has been set, this particular car needed 0x01-04-103 to run again with the result of XX1XXX10. So why don't you add that to your reply for the next dumbass to come along...
    Ummm Your welcome.........

    Totally different than the Snap-On tool guide.

    LDP "if supported"

    02 or 04 whatever depends & voltage is pretty straight forward to find for everyone.

    It is ref to run the 103 test twice......... once in measuring blocks on road test and one time in basics, so you just didn't do it right..............It often gets omitted or skipped which is what you did because if you had the XXXXX100 it would of passed the first time. No reason to say it twice because you failed to read or do a step and forums can't be edited by me so oh well.

    The dumbass stuff was in draft and for any dumbass not to belittle you.....I ended up taking it out anyway and I make mistakes but at least I wrote something for everyone and wasn't crying.
    Last edited by Jack@European_Parts; 05-15-2017 at 01:54 PM.
    European Parts Emporium/Performance / Immobilizer Solutions EPE
    Certified Master Trained NY/BAR/BAD 7076062/ASE/SAE/NASTF Legal Factory Authorized/Licensed GeKo/FaZit # 403738
    Specializing in Custom Services IE: "welding-fabrication" / EPA-SMOG Update or Pass-Thru-Programming / Data Transfer / Immobilizers & OEM Quality Parts
    Above Magic! No Written record, AUTO-SCAN or Appointment = NO HELP!
    www.FixMyEuro.com <<<<<CLICK HERE! or vwemporium@aol.com ( JPPSG & Unverified members need not PM me & Please don't email or call facility for free tech support...use the forum )
    Getting you CONTROL again of your property - TAKE IT! In Conjunction with.........

  10. #19
    Verified VCDS User hans j's Avatar
    Join Date
    Mar 2014
    Location
    Utah
    Posts
    44
    Post Thanks / Like
    I ran the tests exactly like you outlined with exception to the things I already mentioned, and 103 set to XXXXX100 both times. It was only after ALL the bits were set that I was scrolling through the list again to make sure I didn't miss anything and I was only on 103 for a second and then it changed to XXXXXX10. After that, the readiness was saved in the ECU. It's not my first rodeo with these cars or setting readiness. I've known these have been difficult to set for a long time, but I've never had one not set after hundreds miles of driving and passing all the tests at least 15 times, but not having it record it passing.

  11. Likes Uwe liked this post
  12. #20
    NostraJackAss Jack@European_Parts's Avatar
    Join Date
    Jan 2014
    Location
    1001 State Route 17K Montgomery New York 12549
    Posts
    16,770
    Post Thanks / Like
    I ran the tests exactly like you outlined with exception to the things I already mentioned, and 103 set to XXXXX100 both times. It was only after ALL the bits were set that I was scrolling through the list again to make sure I didn't miss anything and I was only on 103 for a second and then it changed to XXXXXX10. After that, the readiness was saved in the ECU. It's not my first rodeo with these cars or setting readiness. I've known these have been difficult to set for a long time, but I've never had one not set after hundreds miles of driving and passing all the tests at least 15 times, but not having it record it passing.
    Apparently it is an inexperienced rodeo than .......... because once you have a static 100, this means the test is done .......if you didn't have the 100 this means it isn't done. Static 100 means you are done....... not a floating 100 based on RPM.

    They are not difficult to set........
    I run through them with no issue, that is providing nothing is wrong and the sequence is right.

    Bits are either not ready in channels, ready static in DCY locked until key flip or DTC/recoded or ADP cleared.
    The condition you state above is not possible unless the ECU is tampered or test isn't static complete.
    Last edited by Jack@European_Parts; 05-15-2017 at 02:48 PM.
    European Parts Emporium/Performance / Immobilizer Solutions EPE
    Certified Master Trained NY/BAR/BAD 7076062/ASE/SAE/NASTF Legal Factory Authorized/Licensed GeKo/FaZit # 403738
    Specializing in Custom Services IE: "welding-fabrication" / EPA-SMOG Update or Pass-Thru-Programming / Data Transfer / Immobilizers & OEM Quality Parts
    Above Magic! No Written record, AUTO-SCAN or Appointment = NO HELP!
    www.FixMyEuro.com <<<<<CLICK HERE! or vwemporium@aol.com ( JPPSG & Unverified members need not PM me & Please don't email or call facility for free tech support...use the forum )
    Getting you CONTROL again of your property - TAKE IT! In Conjunction with.........

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •