Android 4.3 wouldn't stay connected to HEX-NET in AP mode

   #1  

Derek

VCDS Distributor
Joined
Feb 19, 2014
Messages
455
Reaction score
373
Location
UK (ilexa)
VCDS Serial number
C?ID=56983
Nothing wrong with HEX-NET, just something that might help someone else who gets this problem

I couldn't make my Galaxy S3 running Android 4.3 stay connected to my HEX-NET in AP mode until I unticked a setting

At first I was seeing a message saying "Network disabled because Internet connection is slow" in the WiFi network list under the entry for HEX-NET, and Android was changing back to my normal AP or switching to mobile to reinstate a connection to the Internet. It wasn't happy to stay connected to an AP that did not offer internet access

To keep the HEX-NET connected in AP mode I had to go into advanced WiFi settings and untick "Auto Network Switch".

all the best
Derek
 
   #2  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
30,427
Reaction score
21,710
Location
USA
VCDS Serial number
HC100001
Thanks for the pointer.

I haven't seen that myself, probably because (I just checked my phone, a Note 3) and it's un-ticked. However, I don't recall un-ticking it.

Anyway, with the HEX-NET in AP mode, Android clearly won't have any internet access via WiFi, so this is an excellent tip.

-Uwe-
 
   #3  

jyoung8607

FoRT
Verified
Joined
Feb 25, 2014
Messages
2,531
Reaction score
4,115
Location
Cincinnati, OH
VCDS Serial number
C?ID=25607
I believe I enabled it on my handset. It helps if you're roaming around and you come across a hot-spot that requires a web-based accept or login. By default the phone will just switch networks and be dead-in-the-water until you leave the hotspot or manually login.

I think the metric it uses is connectivity to Google services. It's the thing that makes your cell/WiFi link turn from gray to blue/green. Anyway, I'm thinking it would be a good addition to the FAQ. It will only become more common over time.
 
Top