Coding / Cloud timeout

   #1  

midnightgolfer

Verified VCDS User
Verified
Joined
Feb 17, 2014
Messages
9
Reaction score
5
VCDS Serial number
C?ID=125003
I can successfully connect the both infrastructure and access point of hexnet
but in neither one can I figure out how to get the cloud or coding options to work without telling me that it timed out


Is coding available yet?
 
   #2  

Santos

Administrator
Staff member
Administrator
Joined
Jan 29, 2014
Messages
333
Reaction score
2,923
Location
Lansdale, PA, USA
Coding is available.

Under VCDS-Mobile, go into Options -> Self Test -> Advanced Network test, then post the results.
 
   #3  

midnightgolfer

Verified VCDS User
Verified
Joined
Feb 17, 2014
Messages
9
Reaction score
5
VCDS Serial number
C?ID=125003
I still haven't had it ever finish and give me results for that, yet. It just spins for several minutes. (I will try again and post, soon.) Thank you.
 
   #4  

Santos

Administrator
Staff member
Administrator
Joined
Jan 29, 2014
Messages
333
Reaction score
2,923
Location
Lansdale, PA, USA
Thanks for the reply. It sounds like there isn't an active internet connection.

Lets backup a bit, What is your current setup?

what viewing device?

what router?

What colors are the LEDS on the HEX-NET?

Can you open a browser and Visit a website?

Can you access VCDS-cloud.com in a web browser?


-Santos
C?ID=125003&TC=1
 
Last edited:
   #5  

midnightgolfer

Verified VCDS User
Verified
Joined
Feb 17, 2014
Messages
9
Reaction score
5
VCDS Serial number
C?ID=125003
Okay, it works. I had set my network settings to connect to my home wifi, which worked, everything except VCDS-cloud.com

I believe this was because I had chosen, rather than DHCP, to assign a manual IP address to the Hex-net, which I assume is why my home wifi router wasn't letting it see the outside world, but was letting it communicate with my iPhone and laptop just fine.

Moral of the story: when I switched back to DHCP, and used Fing app on the phone to figure out which ip it was getting from the router... it works.

Thanks for your help.
 
   #6  

Uwe

Benevolent Dictator
Administrator
Joined
Jan 29, 2014
Messages
38,973
Reaction score
27,540
Location
USA
VCDS Serial number
HC100001
When you assigned it an IP manually, did you also tell it what IP on your local subnet is your gateway to the outside world, and tell it where to find a DNS server? DHCP does more than just assign an IP address.

-Uwe-
 
   #7  

midnightgolfer

Verified VCDS User
Verified
Joined
Feb 17, 2014
Messages
9
Reaction score
5
VCDS Serial number
C?ID=125003
All I remembering seeing in the settings was Gateway:
my router's ip ending in dotted quad of .1,
manual IP address of HexNet: same three first dotted quads of router and then I picked .100 for the last dotted quad, (high and easy to remember)
and the subnet mask: 255.255.255.0 to allow the last dotted quad to go high

I saw no manual DNS setting option

my router's an Airport Extreme, and it gave me trouble with a laptop once before, when I added that one with a manual IP. local worked, but outside world wouldn't
 
   #8  

dopo

Verified VCDS User
Verified
Joined
Feb 24, 2014
Messages
8
Reaction score
2
VCDS Serial number
C?ID=172049
I can echo the observation here that there is no way to configure a DNS server when configuring a static IP on a network profile, neither via the VCDS-Mobile web page nor via the Java tool for network configuration. This means that using a profile with a static IP effectively prevents you from checking for software updates or using any VCDS Cloud functions, since DNS will not work.

I know there's plenty of work to be done, but I just wanted to make sure that "Add DNS configuration to interface" is an item somewhere on the development roadmap -- Uwe's comment above makes it sound like he thinks it's in there already :-)
 
   #9  

Santos

Administrator
Staff member
Administrator
Joined
Jan 29, 2014
Messages
333
Reaction score
2,923
Location
Lansdale, PA, USA
The Gateway (router) should resolve the DNS for the hex-net.

You can check your Gateway by:

Windows:

1. Open a command prompt. Usually located at c:\Windows\system32\cmd.exe

2. type: Ipconfig

3. Press Enter.

Results:
ArPhg3D.png



MAC OSX:

1. Open Terminal

2. type: route -n get default

3. Press Enter.

results:

a1B8fUZ.png


Both examples have a gateway: 192.168.1.1 . Use the same gateway number for the HEX-NET and it should be able to connect to the internet.

xqm7JYn.png



You can test the network connection through VCDS-Mobile by clicking:

[Options]
[Self Test]
[Advanced Network Test]

The HEX-NET will now ping the cloud and display the results:

WPVQO38.png
 
   #10  

invisiblewave

Verified VCDS User
Verified
Joined
Feb 25, 2014
Messages
56
Reaction score
8
Location
USA
VCDS Serial number
C?ID=208767
Normally the gateway (router) would act as the DNS server, with the external DNS entries being set in the router config. Does the HEX-NET default to using the gateway for DNS?

Edit: I think you answered my question as I was typing it!
 
Top