VCDS asking me to register VIN to interface

   #1  

avisonjohn

Verified VCDS User
Verified
Joined
May 29, 2020
Messages
53
Reaction score
4
Location
UK
VCDS Serial number
C?ID=403276
Hi there.

I have an Audi A4 B7 Cab, and VCDS has this VIN linked to it correctly.
I have swapped the ECU with another one and attempted to connect VCDS to it, and it asks me to register the VIN against the interface.

Normally, this would be a problem.
However, when asking me to enter the last characters of the VIN to confirm, it is displaying the entire VIN as 'XXXXXXXXXXXXXXXXX'

The entire dialog says:

"VCDS: Add VIN confirm

This vehicle's VIN (XXXXXXXXXXXXXXXXX)
is not registered in your interface.
Would you like to add it?
(1 VIN(s) currently registered)

Please confirm by entering
the VIN's last three digits:"


To be clear, the "XXXXXXXXXXXXXXXXX" is literally the character 'X' repeated - I've not obscured it just for the post or as an example.

Is this going to pose any issues with VCDS only seeing the VIN as "XXXXXXXXXXXXXXXXX" etc, and if there is no problem with this, do I actually enter the last 3 of the VIN, or do I simply enter 3 crosses ("XXX")?
 
   #2  

PetrolDave

Verified VCDS User
Verified
Joined
Dec 16, 2014
Messages
4,835
Reaction score
4,839
Location
Trowbridge, UK
VCDS Serial number
C?ID=1423
It sounds like the new ECU has been hacked for it to report the VIN as all X's.

Worth doing an Auto-Scan with the new ECU installed (this won't use up a VIN) and posting that here to confirm that suggestion.
 
   #3  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
34,422
Reaction score
24,530
Location
USA
VCDS Serial number
HC100001
Indeed, it appears the ECU in question has been hacked to remove the VIN.

I doubt the HEX-V2 will allow a VIN consisting of all X's to be registered.

-Uwe-
 
Top