Golf 7 / MK7 Cluster/Speedometer Swap

   #21  

downtime

Verified VCDS User
Verified
Joined
May 27, 2017
Messages
2,224
Reaction score
1,440
Location
Finland
VCDS Serial number
C?ID=280813
Thanks Dana. Exactly those. OP, run the reset to factory setting basic setting. Exit abs module, wait for the lights to stop blinking, turn off ignition. Wait a few seconds, ignition on and go to abs module, clear dtcs. EEPROM error should be gone

And as Dana adviced, only ignition, do not turn engine on.
 
   #22  

Dana

Administrator
Staff member
Ross-Tech Employee
Joined
Jan 29, 2014
Messages
4,546
Reaction score
6,707
Location
Western PA, USA
Please do work on the 03-ABS / TPMS issue first but after doing so I think you also have Adp problems in address 17. This DTC

16776980 - Databus​
U1121 00 [009] - Missing Message​
[New feature! Extended UDS fault detail is only supported by current gen. interfaces]​
Confirmed - Tested Since Memory Clear​

.. would read [PLA_Status_01 keine Kommunikation] in the Extended DTC line with a current interface. That leads me to believe Adaptation values likely need to be modified in address 17 (since Coding should already be ruled out). When you get to that point, perhaps after the ABS is in a better condition, this page should be helpful:


Similar to scans, you can run the Adaptation function map on address 17, open it with Notepad and paste the contents within CODE tags to this thread. If you happened to have one when the old cluster was installed it would be ideal to post both for comparison.
 
   #23  

krustyx

Verified VCDS User
Verified
Joined
Apr 27, 2014
Messages
28
Reaction score
4
Location
Canada / Netherlands
VCDS Serial number
C?ID=142005
Ok, finally it worked!!

I went back (after you mentioned the full cycle) and

logged into the ABS module,
then basic settings,
changed Reset to factory setting of tire pressure monitoring display. It told me that password/pin was required (cant' remember the exact wording)
went back, unlocked the module
then back to basic settings, Reset to factory setting of tire pressure monitoring display
all was accepted, then did the full cycle (turning the ignition off, etc)
and voilà!

Thanks to everybody that helped me, greatly appreciated!

Now wife can drive without freaking out of the yellow flashing light (because i said yellow light is ok, yellow flashing light is bad).

:) Thanks!
 
Top