Readiness tests not running / hanging for a long time?

   #1  

Cryptic1911

Verified VCDS User
Verified
Joined
Dec 31, 2020
Messages
3
Reaction score
1
Location
CT, USA
VCDS Serial number
C?ID=36582
Hello, I seem to be having issues getting the readiness tests to run. I was able to run the readiness script a few years ago to make it do the tests and they all passed, so I was able to go get my emissions done. I just tried it again a few days ago and I ran into issues. First one was that I updated to the new version 20.12 and it seemed error as soon as I touched any of the pedals, so I uninstalled and put 17.8? on since I had an old installer. That version lets me get to the screen and I go into basic mode, press the brake then the gas and it starts at the beginning, so it would say | step 20 | brake | full throttle | hold | in four the status boxes. Anyways, it seems to start something a few things clicked/clacked, engine revved up a few times as it drops from 20 to 19, etc and then gets to 15 sits and doesn't appear to be doing anything but idling. I sat there on that step for 10+ minutes and I didn't hear anything clicking / turning on/off or the engine rev up (for that test) and it just stayed on 15. Does anyone know what step 15 is? It doesn't really give any status as to what it was trying to test and it didn't say that there were any errors. I do remember it took a little bit when I did it last time, but I don't recall it sticking at any certain spot. It just went through each til it got to zero. Also, I want to say that I think it would say test on / test off while it was doing things? It just stays on "hold" the whole time. It never stopped and gave an error. Am I just being impatient and need to let it sit longer on step 15? I don't think it too more than 15 mins to do all 20 tests last time, so I'm not sure why it would hang on step 15 for over ten mins

Also, as a sort of related question - I found a post about entering a security login pw #29791 I believe?, so it will run the tests without having to hold the pedals. I logged into that and tried it.. I think it said to press clutch and release, brake and release then throttle and release, but it immediately seemed like it reset like I had done something wrong and got out of that mode. Maybe I did the pedals out of order or something? From what I read, it was so techs could initiate the tests then get out of the car and go do something else while it ran. I'd like to do that if possible

info on the car -

2008.5 gti w/ tsi engine
apr k04 v3.0 tune
yes its got a "stock" non test pipes mode and yes I was in it that mode. I switched tunes with my phone, turned off car, restarted, rechecked phone to verify it was in stock non testpipes mode, etc. I haven't touched or reflashed the tune or anything software wise since last time. I did have the engine out of the car for a bunch of maintenance stuff, but it's been driving fine and I wasn't getting any dtc codes at the time when I tried running the tests. I checked codes first, cleared anyways even though there were none before attempting to run tests and even checked after running). This is the exact setup I got it to run the tests on previously


Thanks
 
   #2  

_Val

Verified VCDS User
Verified
Joined
Nov 7, 2017
Messages
183
Reaction score
140
Location
Latvia
VCDS Serial number
C?ID=356659
Could we start with autoscans from both 20.12 and 17.8 versions? You can keep both of them, just install in different directories, for example:
c:\ross-tech\vcds 20.12
c:\ross-tech\vcds 17.8
 
   #3  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
31,618
Reaction score
22,590
Location
USA
VCDS Serial number
HC100001
It sounds like he's running the Automatic Test Sequence in Group 200..?

In that case, VCDS itself doesn't "step" anything. It's all under control of the ECU and I would consider it highly improbable that the version of VCDS being used would make any difference at all.

-Uwe-
 
   #4  

Cryptic1911

Verified VCDS User
Verified
Joined
Dec 31, 2020
Messages
3
Reaction score
1
Location
CT, USA
VCDS Serial number
C?ID=36582
Could we start with autoscans from both 20.12 and 17.8 versions? You can keep both of them, just install in different directories, for example:
c:\ross-tech\vcds 20.12
c:\ross-tech\vcds 17.8

I'll grab a laptop from work and install them both on there and see what I get for info in an autoscan


It sounds like he's running the Automatic Test Sequence in Group 200..?

In that case, VCDS itself doesn't "step" anything. It's all under control of the ECU and I would consider it highly improbable that the version of VCDS being used would make any difference at all.

-Uwe-

I went into 01-engine / view readiness and then clicked on the set readiness button and then followed the prompts. In that screen, version 20.12 would just go into error status. On 17.8 it would start the tests at 20 and cycle through them until it got to 15 and just seem to sit there.

I'll give it a try on another laptop and try and do an autoscan to see what comes up
 
   #5  

Cryptic1911

Verified VCDS User
Verified
Joined
Dec 31, 2020
Messages
3
Reaction score
1
Location
CT, USA
VCDS Serial number
C?ID=36582
Well, crisis averted.. took me a few days to get a different laptop that I could try, and by then it had set enough of the readiness that I was able to pass emissions anyways. I still had evap unset and one stored o2 lean dtc code, but it passed since all the emissions readiness was set and i had no cel's. I'll have to do it again next Jan, so we'll see what happens
 
  • Like
Reactions: Uwe
Top