Airbag Light On Instrument Cluster NEVER Lights

   #1  

TheFrenchman

Verified VCDS User
Verified
Joined
Jul 23, 2020
Messages
2
Reaction score
0
Location
USA
VCDS Serial number
C?ID=303522
I have a 2003 New Beetle Turbo S. I found out, after I bought it, that it was in a crash and was repaired. Not repaired very well. The airbag module had 11 fault codes including crash data. I noticed the airbag light never comes on. I put in new seats and a new airbag control module part number 1C0 909 605 T/025. I coded the module using VCDS with a coding of 12853 which VCDS calculated using the index.

I used a workshop code of 00000. The module seemed to take that without any errors. There are now no faults, but the airbag light still doesn't come on at all when the engine is started and it goes through its self test. I now don't know if the airbag system is working or not. What can I do to get the airbag light to come on like it should during startup? I tried to change the workshop code, but it seems to be 'read only.' How to I change the workshop code from 'read only?'

I have pulled the instrument cluster, and it appears to never have been taken apart and tampered with as there are factory stickers across the seam where the halves go together. I know the seat airbags are good but don't know if the steering wheel, passenger side airbags or either of the seat belt igniters are good. There were fault codes that the both seat belt igniters fired in the crash. Both seat belts do lock when you pull on them quickly.

Here is the most recent full scan of the car, performed after the new airbag module was installed and coded.

Code:
Thursday,23,July,2020,11:31:03:56773
VCDS -- Windows Based VAG/VAS Emulator Running on Windows 7 x86
VCDS Version: 20.4.1.0  HEX-V2 CB: 0.4508.4
Data version: 20200331 DS317.0
www.Ross-Tech.com


VIN: 3VWFE21C13M434233   License Plate: AOJ1670
Mileage: 151510km-94143mi   Repair Order: 



--------------------------------------------------------------------------------
--------------------------------------------------------------------------------


Chassis Type: 1C (1Y - VW New Beetle Cab (2003 > 2010))
Scan: 01 02 03 08 15 17 19 25 26 29 35 37 39 46 54 56 65 75
 
VIN: 3VWFE21C13M434233   Mileage: 151510km-94143miles
-------------------------------------------------------------------------------
Address 01: Engine        Labels: 06A-906-032-AWP.lbl
   Part No: 06A 906 032 LS
   Component: 1.8l 5VT NB MT  G   4745  
   Coding: 00002
   Shop #: WSC 00066  
   VCID: 7AAEFB93D5C2858B1DF-513C
   3VWFE21C13M434233     VWZ5Z0C0301056

1 Fault Found:
17608 - Boost Pressure Control Valve (N249) 
            P1200 - 35-10 - Mechanical Malfunction - Intermittent
Readiness: 0000 0000

-------------------------------------------------------------------------------
Address 03: ABS Brakes        Labels: 1C0-907-37x-ESP-F.lbl
   Part No: 1C0 907 379 M
   Component: ESP FRONT MK60      0102  
   Coding: 0019970
   Shop #: WSC 00066 000 00000
   VCID: 343215ABB226B3FB873-5160

No fault code found.

-------------------------------------------------------------------------------
Address 15: Airbags        Labels: 6Q0-909-605-VW5.lbl
   Part No: 1C0 909 605 T
   Component: 25 AIRBAG VW51 0E   0015  
   Coding: 12853
   Shop #: WSC 00000  
   VCID: 353428AFBC5CAAF3B0D-4B3C

No fault code found.

-------------------------------------------------------------------------------
Address 17: Instruments        Labels: 1C0-920-x4x.lbl
   Part No: 1C0 920 951 JX
   Component: KOMBI+WEGFAHRS. M73 V02  
   Coding: 07234
   Shop #: WSC 03999  
   VCID: 005A897BB31EDF5B53B-4B1E
   3VWFE21C13M434233     VWZ5Z0C0301056

No fault code found.

-------------------------------------------------------------------------------
Address 19: CAN Gateway        Labels: 6N0-909-901-19.lbl
   Part No: 6N0 909 901 
   Component: Gateway K<->CAN    V022  
   Coding: 00006
   Shop #: WSC 19410  
   VCID: 70BAD9BB83BECFDBA3B-4B00

No fault code found.

-------------------------------------------------------------------------------
Address 46: Central Conv.        Labels: 1C0-959-799.lbl
   Part No: 1C0 959 799 G
   Component: 2K Komfortgerát HLO 0004  
   Coding: 00064
   Shop #: WSC 23071  
   VCID: 3B203E979A787C83469-4B00

   Subsystem 1 - Part No: 1C2959802A
   Component: 2K Tõrsteuer.FS KLO 0009  

   Subsystem 2 - Part No: 1C2959801A
   Component: 2K Tõrsteuer.BF KLO 0009  

No fault code found.

-------------------------------------------------------------------------------
Address 54: Rear Spoiler        Labels: 1C0-959-733.lbl
   Part No: 1C0 959 733 E
   Component: Heckspoiler         0002  
   VCID: 2D0400CF540CE233C8D-51A8

No fault code found.

-------------------------------------------------------------------------------
Address 56: Radio        Labels: 1J0-035-18x-56.lbl
   Part No: 1C0 035 196 CL
   Component:  RADIO DE2         0006  
   Coding: 06033
   Shop #: WSC 23320  
   VCID: 6B80CED7AA982C03969-51CE

1 Fault Found:
00855 - Connection to CD changer 
            49-00 - No Communications

End----------(Elapsed Time: 03:43, VBatt start/end: 12.3V/12.2V)-----------
Log-AOJ1670-3VWFE21C13M434233-151510km-94143mi.txt
Displaying Log-AOJ1670-3VWFE21C13M434233-151510km-94143mi.txt.
 
Last edited:
   #3  

Jack@European_Parts

NostraJackAss
Joined
Jan 29, 2014
Messages
21,619
Reaction score
9,131
Location
Montgomery, NY, USA
VCDS Serial number
C?ID=57337
Run outputs in VCDS for cluster yet?

Did you inspect for FOD since no fault such as black tape?
 
  • Like
Reactions: Uwe
   #4  

TheFrenchman

Verified VCDS User
Verified
Joined
Jul 23, 2020
Messages
2
Reaction score
0
Location
USA
VCDS Serial number
C?ID=303522
I ran the instrument cluster output tests using VCDS. The airbag light DID NOT come on during the lamp test portion. When viewing videos of the test being performed on other VAG cars, I didn't see the airbag light go on. So I am confused about if the airbag light is a part of the lamp test. All the other output tests appeared correct/good.

When I had the instrument cluster out, I took a very close look where the airbag light is and didn't see any kind of blocking of the light present.

If I had the correct electrical diagnostic leads I could back probe the airbag light pin on the instrument cluster connector and use a voltmeter to detect if voltage is present during the startup time of the engine. I have not tried this yet.
 
   #5  

marco105

Verified VCDS User
Verified
Joined
Nov 30, 2017
Messages
15
Reaction score
0
Location
UK
VCDS Serial number
C?ID=13130
Hi, did you get to the bottom of this ?
I have the same problem with a 2006 Skoda Octavia mk2. Uk Right hand drive
Air bag light never lights up on ignition cycle.
I ran instrument cluster test, but older Style, it doesn’t have test for airbag light. Just next, start etc etc
No drop down menu. For individual named test.
The engine Management light doesn’t light up correctly either. 3/4 of it lights up but not 100% perfect
Would this indicate Instrument cluster fault ?
The passenger front seat has been replaced (different colour seat)
Any help on this would helpful.
Also would this pass the UK MOT TEST without the light ever coming on ?
Thanks
 
   #6  

morski

Verified VCDS User
Verified
Joined
Jan 28, 2018
Messages
138
Reaction score
93
Location
Cheshire UK
VCDS Serial number
C?ID=90186
Common thing to do by dodgy repairers is to remove the airbag light from the cluster so it never illuminates as they want to replace the ecu and even worse case critical airbag parts
Open the cluster and check the bulb is there or if there is tape etc over the bulb if its led
 
  • Agree
Reactions: Uwe
   #7  

langers2k

Verified VCDS User
Verified
Joined
Oct 20, 2014
Messages
301
Reaction score
280
Location
UK
VCDS Serial number
C?ID=224085
You could also try doing something to force the airbag light on like unplugging the passenger airbag switch?
 
  • Like
Reactions: Uwe
Top