Relatively new user: ZERO results from scan from 2004 Passat

   #1  

Dunwood

Verified VCDS User
Verified
Joined
Jun 10, 2019
Messages
21
Reaction score
18
Location
CA, USA
VCDS Serial number
C?ID=370890
I'm a relatively new user, you can find another of my threads under repairs for a different vehicle.

I attempted to TWICE "autoscan" a potential new vehicle (2004 Passat pre-purchase). After scanning (and seeing very little activity of moving data during the scan),
VCDS ended after #75 or #77 (I don't remember) with results similar to the below. VCDS didn't give me the option to generate a log nor allow me to copy All and paste somewhere.

Chassis Type: 9M - VW Jetta IV (1998 > 2014)
Scan: 01 02 03 08 09 15 16 17 19 22 29 35 36 37 39 46 47 55 56 57
75 76

(the above is from my own vehicle, and is not the result i got but is similar to the ONLY data that displayed AFTER the TWO scans).
That is it, no nothing! No addresses, no faults no nothing. I can't copy. Two sentances!

Background: This vehicle was being shown by a "dealer" who purchased it wholesale. He ran OBELEVEN on it.
Something doesn't smell right. I'm assuming VCDS will autoscan this platform just like my 2001 MK4 platform.

I don't think there is a problem with VCDS, I think it's a vehicle issue.
 
   #3  

Dunwood

Verified VCDS User
Verified
Joined
Jun 10, 2019
Messages
21
Reaction score
18
Location
CA, USA
VCDS Serial number
C?ID=370890
What type of VCDS interface cable You have?
Try to run VCDS Port Test while connected to car in question.
Its registered and recently updated version of VCDS with Hex-V2 cable. I walked away from the vehicle, so I don't have access to it.
It works fine on my 2001 1.8T Jetta. The scan on the Passat didn't even pickup the VIN, yet the scan ran thru the entire scan process without an error code.
 
Last edited:
   #4  

PetrolDave

Verified VCDS User
Verified
Joined
Dec 16, 2014
Messages
3,999
Reaction score
3,983
Location
South Molton, UK
VCDS Serial number
C?ID=1423
No 12V power to the OBD connector in the car?
 
   #5  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
30,465
Reaction score
21,732
Location
USA
VCDS Serial number
HC100001
No 12V power to the OBD connector in the car?
Easy to check with a HEX-V2 (or HEX-NET): [Options] -> [Test] reports the voltage at Pin 16 (unswitched) and Pin 1 (switched, but may not exist on a B5 Passat). Also the color of the LEDs on the HEX-V2 will indicate when it sees power from the car. If plugged into a PC only, they will be blue. If plugged into a car and power is present, they will be green.

I doubt it's a power problem. I think the HEX-V2 won't start a scan w/o power from the car side. I think it's more likely a blocked or disconnected K-line. If the K-line is blocked hard, as in truly stuck to +12 or GND, the HEX-V2 should pick that up and flag it as an error, but we've seen cases were it's blocked softly, for example connected to the speaker output of an aftermarket radio, where it didn't get picked up.

-Uwe-
 
   #6  

Dunwood

Verified VCDS User
Verified
Joined
Jun 10, 2019
Messages
21
Reaction score
18
Location
CA, USA
VCDS Serial number
C?ID=370890
Also the color of the LEDs on the HEX-V2 will indicate when it sees power from the car. If plugged into a PC only, they will be blue. If plugged into a car and power is present, they will be green.

I doubt it's a power problem. I think the HEX-V2 won't start a scan w/o power from the car side. I think it's more likely a blocked or disconnected K-line. If the K-line is blocked hard, as in truly stuck to +12 or GND, the HEX-V2 should pick that up and flag it as an error, but we've seen cases were it's blocked softly, for example connected to the speaker output of an aftermarket radio, where it didn't get picked up.

-Uwe-
I had the "green light". Uwe, you confirmed what I suspected, the scan won't start w/o power from the vehicle. I had power.
Therefore something else was wonky. But I walked away from the car sale, so I can't retest. Thank you.
 
   #7  

ChandlersHax

Verified VCDS User
Verified
Joined
Mar 31, 2019
Messages
4
Reaction score
3
Location
USA
VCDS Serial number
C?ID=356080
Hopefully I'm not "necroing" a thread, but I'm having an identical issue, and this thread is only a couple of months old, so I figured this would be better than a duplicate. Like OP, I've got a 2004 Passat GLS Wagon. To re-hash what the OP said, the port test comes back and says everything is fine, and I've got green lights on my HEX V2. I'm running the stock radio, and I don't have any reason to believe that the stock harness has been modified in any way. I know my cable/configuration is fine, because it works on my DD 2015 GTI just fine. Any additional information I can provide/things I can check on the car?
 
   #8  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
30,465
Reaction score
21,732
Location
USA
VCDS Serial number
HC100001
I know my cable/configuration is fine, because it works on my DD 2015 GTI just fine. Any additional information I can provide/things I can check on the car?
Well, a 2015 GTI does all its communications via CAN bus, on pins 6 and 14 of the diagnostic connector, but a 2004 Passat does it all via single K-line on Pin 7, so that doesn't 100% rule out a problem with the HEX-V2 itself..

The fact that you've got green LEDs and [Options] -> [Test] comes back good tells us you've got power at the diagnostic socket and the K-line isn't hard-shorted to anything, but it doesn't tell us that the Pin 7 in the diagnostic socket is connected to anything either.

So the first thing I would do is inspect the diagnostic socket, paying particular attention to pin 7 to see if it may be damaged or have gotten pushed in. If it looks OK, then trace the wire back. Somewhere it goes to a "star" junction from which it fans out to the various modules. Use an ohm-meter to verify continuity between pin 7 and that junction.

-Uwe-
 
   #9  

ChandlersHax

Verified VCDS User
Verified
Joined
Mar 31, 2019
Messages
4
Reaction score
3
Location
USA
VCDS Serial number
C?ID=356080
Unsurprisingly, you were spot on about the connector ;) After dropping the lower trim to get better access to the connector/harness, I was able to see that at some point, it appears someone jammed a probe into pin 4 and 7, which bent the terminals. https://i.imgur.com/gixUh3o.jpg After disassembling the connector and bending the terminals back into place, I'm able to read almost all of the modules in the car (The malfunctioning ones are due to other issues I'm sure). Thanks for sharing the knowledge!

Out of curiosity (And because I had the trim dropped), I tried looking for the star junction you mentioned for the K-line, but the green (pin 7) wire just goes up and into a bundle of seemingly hundreds of other wires. Do you have any pics/diagrams of where that junction might be? A few searches didn't turn up anything, and I wasn't able to find a junction even after removing most of the fuse/relay panels from the car.

Thanks again!
 
Last edited:
  • Like
Reactions: Uwe
   #10  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
30,465
Reaction score
21,732
Location
USA
VCDS Serial number
HC100001
Out of curiosity (And because I had the trim dropped), I tried looking for the star junction you mentioned for the K-line, but the green (pin 7) wire just goes up and into a bundle of seemingly hundreds of other wires. Do you have any pics/diagrams of where that junction might be? A few searches didn't turn up anything, and I wasn't able to find a junction even after removing most of the fuse/relay panels from the car.
Nope. I'm confident such a junction exists, but I don't know where it is on that car.

-Uwe-
 
Top