00301 – ABS return flow pump (V39), Pump works, ECU is rebuilt, BRAKE light at 10 mph

   #1  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
00301ABS return flow pump (V39) 35-00 - - Pump works, controller is rebuilt, BRAKE light comes on at 10 mph

I’m stumped. The ABS rebuilder has graciously tested the ABS controller twice, and it works for them. Since rebuilding, it now exhibits a new error: 00301ABS return flow pump (V39) 35-00 - - . However, the ABS pump appears to rotate when 12VDC is applied directly to the contacts.

So the rebuilder says the ABS controller is fine – but it does not appear to turn the ABS pump, which runs great on 12VDC.

The 2005 8H Audi S4 cabriolet first exhibited an Intermittent error code: 01435 - Brake Pressure Sensor 1 (G201) 57–00 Electric Circuit Failure, also 48-00 Supply Voltage. The ABS controller (only) for 0 265 225 239, Esp 012 09A, 487289, Bosch part # 0 265 950 106, Bosch 5.7, was removed and sent to BBA for remanufacture.

Before sending the ABS controller in, the driver complained of a soft brake pedal, so the car was sent to the dealer for a brake fluid replacement and mechanical component check, with the understanding that the ABS controller was not operational (but was communicating). The car appeared to drive and brake acceptably, with the brake sensor error code 01435 - Brake Pressure Sensor 1 (G201) 57–00 Electric Circuit Failure still showing. The sensor tested normally when disconnected from the harness.

While waiting on the controller, the tires were replaced and the wheels were refinished.

Upon reinstallation of the remanufactured ABS controller, a new error code appeared as stated by VAG-COM: 00301ABS return flow pump (V39) 35-00 - - . The controller was sent back to BBA for warranty repair.

After reinstalling the ABS controller, the car still exhibits a 00301 error code, as before, starting when the car reaches 10 mph. This code coincides with a flashing red BRAKE light accompanied by the solid yellow electronic stability program (ESP) light and solid yellow ABS light. The flashing BRAKE light disappears after turning the car off and restarting, but the ABS light, the electronic stability program light and the error code (within VAG-COM) remain. Brake pressures, switches and wheel speed sensors appear to have normal values, as do all other measuring blocks through 6. The pump makes noise when 12VDC is applied directly to the spring electrical contact tangs, both polarities (with the ABS controller removed).

• The Ross-tech VAG-com ABS function test cannot make the return flow pump run with the controller connected in the car. The function test does trigger the 00301 error code.
• The pump runs consistently when tested directly from the spring contacts with 12VDC.
• Resistance on pump contacts (isolated) is 0.4 ohms.
• The contacts between the ABS valve block and the controller have been checked, cleaned, and make good electrical and mechanical contact.
• The wiring harness and connector has tested successfully for the following: positive voltage picked up at pins 2, 6, and 23, and good grounds at pin 1 and pin 5.
• The wiring harness contacts and fuses are verified through the Bentley factory manual for the 2005 Audi S4 cabriolet.
• The previous error code which the ABS controller exhibited as sent to BBA rebuilder, 01435 – Brake Pressure Sensor 1, has not returned. The sensor returns normal values as I step on the brake.
• The car had never before exhibited an error code related to 00301, and that is the only related code present now.
• No germane warning lights or error codes are present after clearing codes. They occur after driving. Only 00301 remains.
• The BRAKE, ABS and ESP lights activate consistently at around 10 mph.
• Brake pressures, switches and wheel speed sensors appear to have normal values.
• The car does exhibit typical radio codes and comfort / convenience code error messages, as it has for several years. These do not appear to be a part of the problem.
• Fuses checked (for resistance, not just visually): 50 amp fuse S123 (50A) in driver’s side dash panel, in relay carrier (4-pin) with threaded connection, S7 (10A) S13 (10A), S14 (10A) and S242 (25A), aka fuse 42 in block.
• Have not yet checked fuse S102 (15A) - the ECM fuse, within the plenum chamber. It is not likely to be the cause, as there is no ECM code.
• The ABS controller has been recoded, no change was seen.
• Brake fluid is full.

Thoughts? I hate to send the valve block in if there is a simple answer. Is there some secret code that turns the pump off, once it has malfunctioned? And what physical happening triggers 00301ABS return flow pump (V39) 35-00 ? Pump current or resistance outside parameters, or lack of a successful test at 10 mph?

i have a full diagnostic scan, but I have not yet posted it...unremarkable except for the ABS code.

RichS
 
Last edited:
   #2  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
00301 S4 ABS - scan

Here is the scan - unremarkable, save for the 00301 code. I am not sure I have used the correct method in loading the scan...I'll keep trying until it appears.

I'm having a little trouble, but here is a link to the scan on imgur .

https://imgur.com/a/WT0jmGR
 
Last edited:
   #3  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
Next steps - Could it be there is air in the ABS? the dealer bled the system, but the ABS controller was generating error codes at that time. I will attempt to bleed the ABS through the pressure sensor. The other lines should have bled, but the pressure sensor is way up high on the valve block.
 
Last edited:
   #5  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
As far as I know, the major components of the ESP - the steering wheel sensor, the steering column control module, the sender for the rotation rate - have never been under water. The ABS controller is just back from BBA as remanufactured. Good to hear from you, Jack - thanks.
 
Last edited:
   #6  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
Update: During one Ross-Tech VCDS ABS brakes output test, the ABS pump ran for about 10 seconds, decreasing in speed as the 10 seconds went by. The car then has no error codes until it got to about 20 mph, then the previous symptoms - amber ESP, amber ABS and flashing red brake light - returned. Subsequent tests would not trigger more than a quick bump on the pump.

Is it possible to apply 12VDC directly to the Bosch 5.7 pump motor contacts for 10 seconds at a time without damaging or overpressurizing the system? i did this before for about 1 second. Would it help for me to exercise this pump?

Not sure if it matters - but the brake pressure is 120+ bar when pressed hard, no difference between strokes.
 
Last edited:
   #7  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
31,140
Reaction score
22,170
Location
USA
VCDS Serial number
HC100001
   #8  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
S4 Cabriolet 2005 8H ABS return pump (V39) 00301 Scan - Stumped, update

Here we go with the scan - thank you, Uwe! Good to hear from you!


Code:
Friday,20,September,2019,13:20:29:29481
VCDS -- Windows Based VAG/VAS Emulator Running on Windows 7 x64
VCDS Version: 19.6.1.0 (x64)
Data version: 20190529 DS308.0
www.Ross-Tech.com


VIN: WUARL48H95K902547   License Plate: 
Mileage: 195840km-121689mi   Repair Order: 9-20-19 1 pm post drive v39 abs pump


Chassis Type: 8H (8H - Audi Cabrio B6/B7 (2003 > 2009))
Scan: 01 02 03 08 09 0F 11 15 16 17 18 25 26 36 37 45 46 55 56 57
          63 65 67 73 75 76 77
 
VIN: WUARL48H95K902547   Mileage: 195840km-121689miles
-------------------------------------------------------------------------------
Address 01: Engine        Labels: 079-910-560-BBK.lbl
   Part No SW: 8H0 910 560 L    HW: 8E0 907 560 
   Component: 4.2L V8/5V      G   0010  
   Revision: 00000000    Serial number: AUX6Z0D0436780
   Coding: 0007774
   Shop #: WSC 00672 785 00200
   VCID: 316933DDAB5A73C726-5140

No fault code found.
Readiness: 0010 1101

-------------------------------------------------------------------------------
Address 02: Auto Trans        Labels: 09L-927-760.lbl
   Part No SW: 8E0 910 156 R    HW: 09L 927 156 
   Component: AG6 09L 4.2L5V USA  0060  
   Revision: --H01---    Serial number:        0098085
   Coding: 0001002
   Shop #: WSC 00672 785 00200
   VCID: 356107CD5F325FE77A-5140

No fault code found.

-------------------------------------------------------------------------------
Address 03: ABS Brakes        Labels: 8E0-614-517.lbl
   Part No: 8E0 614 517 Q
   Component: ABS/ESP allrad      4533  
   Coding: 04597
   Shop #: WSC 00672  
   VCID: 366300C1123454FF73-5106

1 Fault Found:
00301 - ABS Return Flow Pump (V39) 
            35-00 - -

-------------------------------------------------------------------------------
Address 08: Auto HVAC        Labels: 8E0-820-043.lbl
   Part No: 8E0 820 043 AM
   Component:   A4 Klimaautomat   2831  
   Coding: 00100
   Shop #: WSC 00672  
   VCID: 6CD7E2A91CF8DE2F55-517C

No fault code found.

-------------------------------------------------------------------------------
Address 09: Cent. Elect.        Labels: 8E0-907-279-8E2.lbl
   Part No: 8E0 907 279 F
   Component: int. Lastmodul  USA 0517  
   Coding: 01013
   Shop #: WSC 00672  
   VCID: 356107CD0F325FE77A-4B1A

No fault code found.

-------------------------------------------------------------------------------
Address 0F: Digital Radio        Labels: 8E0-035-593-XM.lbl
   Part No SW: 8E0 035 593 E    HW:             
   Component: SDAR XM              
   Revision:             Serial number: AUZ4Z7D2021424
   Shop #: WSC 00000 000 00000
   VCID: 2B5521B5897619171C-517C

2 Faults Found:
02633 - Antenna for Satellite Tuner 
            009 - Open or Short to Ground
02635 - Tuner Not Enabled/Activated 
            000 - -

-------------------------------------------------------------------------------
Address 15: Airbags        Labels: 8H0-959-655-84.lbl
   Part No: 8H0 959 655 D
   Component: Airbag 8.4EC        0015  
   Coding: 0010105
   Shop #: WSC 00672 785 00200
   VCID: 3B7511F5791689978C-515E

No fault code found.

-------------------------------------------------------------------------------
Address 16: Steering wheel        Labels: 8E0-953-549.lbl
   Part No: 8E0 953 549 N
   Component: Lenksáulenmodul     0611  
   Coding: 01141
   Shop #: WSC 00672  
   VCID: 3E7318E13A049CBFAB-4B00

No fault code found.

-------------------------------------------------------------------------------
Address 17: Instruments        Labels: 8E0-920-9xx-8E2.lbl
   Part No SW: 8H0 920 980 S    HW: 8H0 920 980 S
   Component: KOMBI+WFS 3     H12 0020  
   Revision: 0020        Serial number: AUX6Z0D0436780
   Coding: 0001231
   Shop #: WSC 19346 002 1048576
   VCID: 3F8D65E56D0E95B7A0-515E

No fault code found.

-------------------------------------------------------------------------------
Address 25: Immobilizer        Labels: 8E0-920-9xx-8E2.lbl
   Part No SW: 8H0 920 980 S    HW: 8H0 920 980 S
   Component: KOMBI+WFS 3     H12 0020  
   Revision: 0020        Serial number: AUX6Z0D0436780
   Coding: 0001231
   Shop #: WSC 19346 002 1048576
   VCID: 3F8D65E56D0E95B7A0-515E

No fault code found.

-------------------------------------------------------------------------------
Address 26: Auto Roof        Labels: 8H0-959-255.lbl
   Part No: 8H0 959 255 
   Component:  VSG  B6 CABRIO     6389  
   Shop #: WSC 00672 785 00200
   VCID: 73E5F9D511C601D794-5140

No fault code found.

-------------------------------------------------------------------------------
Address 36: Seat Mem. Drvr        Labels: None
   Part No: 8H0 959 760 
   Component: Sitzmemory EE H06   0010  
   Coding: 00002
   Shop #: WSC 00065  
   VCID: 74E7FAC944C806EF8D-4B00

2 Faults Found:
02011 - Right Entry Assistance Control Module (J573) 
            49-00 - No Communications
02010 - Left Entry Assistance Control Module (J572) 
            79-00 - Please Check Fault Codes

-------------------------------------------------------------------------------
Address 37: Navigation        Labels: None
   Part No SW: 8H0 035 192 B    HW: 8H0 035 192 B
   Component: RNS-E US3       H53 0110  
   Revision:      03S    Serial number: AUZBZ7E1700297
   Coding: 0419133
   Shop #: WSC 03751 444 57240
   VCID: 2643D0819294247FC3-517C

1 Fault Found:
00858 - Connection; Radio Intermediate Frequency (IF) Output to Antenna Amplifier 
            007 - Short to Ground
             Freeze Frame:
                    Fault Status: 01100111
                    Fault Priority: 5
                    Fault Frequency: 1
                    Reset counter: 89
                    Time Indication: 0
                    Date: 2004.06.22
                    Time: 00:38:05

             Freeze Frame:
                    Mileage: 655350 km
                    Count: 2206
                    Clock: 00:37


-------------------------------------------------------------------------------
Address 46: Central Conv.        Labels:. 8E0-959-433-MAX.clb
   Part No: 8H0 959 433 E
   Component: Komfortgerát T7B    3320  
   Coding: 11788
   Shop #: WSC 00672  
   VCID: 366300C1123454FF73-4B1A

   Subsystem 1 - Part No: 8H1959801B
   Component: Tõrsteuer.FS BRM 3020  

   Subsystem 2 - Part No: 8H1959802B
   Component: Tõrsteuer.BF BRM 3020  

   Subsystem 3 - Part No: 8H0959801A
   Component: Tõrsteuer.HL BRM 0002  

   Subsystem 4 - Part No: 8H0959802A
   Component: Tõrsteuer.HR BRM 0002  

No fault code found.

-------------------------------------------------------------------------------
Address 55: Headlight Range        Labels: 4Z7-907-357.lbl
   Part No: 4Z7 907 357 
   Component: dynamische LWR       D09  
   Coding: 00070
   Shop #: WSC 00672  
   VCID: 0407AA091468366FBD-4B1A

No fault code found.

-------------------------------------------------------------------------------
Address 56: Radio        Labels: 8E0-035-192-RNSE.clb
   Part No SW: 8H0 035 192 B    HW: 8H0 035 192 B
   Component: RNS-E US3       H53 0110  
   Revision:      03S    Serial number: AUZBZ7E1700297
   Coding: 0419133
   Shop #: WSC 03751 444 57240
   VCID: 2643D0819294247FC3-5198

1 Fault Found:
00858 - Connection; Radio Intermediate Frequency (IF) Output to Antenna Amplifier 
            007 - Short to Ground
             Freeze Frame:
                    Fault Status: 01100111
                    Fault Priority: 5
                    Fault Frequency: 1
                    Reset counter: 89
                    Time Indication: 0
                    Date: 2004.06.22
                    Time: 00:38:05

             Freeze Frame:
                    Mileage: 655350 km
                    Count: 2206
                    Clock: 00:37


-------------------------------------------------------------------------------
Address 63: Entry Assist,D        Labels: None
   Part No: 8H0 959 760 A
   Component: EasyEntry F M H13   0010  
   Coding: 00006
   Shop #: WSC 00065  
   VCID: 356107CD0F325FE77A-4B00

1 Fault Found:
02011 - Right Entry Assistance Control Module (J573) 
            49-00 - No Communications

End-------------------------(Elapsed Time: 05:52)--------------------------
 
  • Like
Reactions: Uwe
   #9  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
S4 8H cab 2005 ABS 00301 return flow pump (V39) - Is the answer 42?

More observations: The isolated ABS pump motor draws from 11 amps at starting inrush to 5 amps after 20 seconds. It draws slightly less when the opposite polarity is applied. I re-checked pins pins 2, 6, and 23 for voltage, and good grounds at pin 1 and pin 5, plus the parking brake circuit pin 38 as well - all have the proper ground or voltage. tested cold as well as hot, with the ABS controller physically removed so that I could access the spring pins.

The system started off this morning, cold, by passing the VCDS ABS function test (Hurray!) which operated the pump for about 10 seconds. All codes cleared. It then failed on the road again as before, but at a higher MPH - this time 20 MPH. I threw the controller in the freezer for 2 hours and tried again - it didn't pass the functional test, but it ran for 5 seconds before stopping.

What causes the function test to turn on the ABS pump, and when does it stop the pump? What stops it - a pressure reading? Time?

When it fails (red BRAKE light begins flashing) on the road, I hear a click at the same time from near the a pillar below the dash. Sound like a relay. That click happens at 10 MPH regardless. What turns on at 10 MPH? Auto locking? Cabriolet top actuation denial? How does all this stuff work? What is the meaning of life? Is the answer really 42? Wait...must take break...family looking at me funny...

Cheers,
RichS
 
Last edited:
   #11  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
Good questions, Jack.

0 265 225 239, Esp 012 09A, 487289, Bosch part # 0 265 950 106, Bosch 5.7, did not correspond to any firmware updates that I could find (yet). But I will press the issue further. The ABS controller was remanufactured, but I do not know if they would have updated firmware. I'll do a little research on how to tell if the firmware is outdated and answer that question.

Yes, fuses checked (for resistance, not just visually): 50 amp fuse S123 (50A) in driver’s side dash panel, in relay carrier (4-pin) with threaded connection, S7 (10A) S13 (10A), S14 (10A) and S242 (25A), aka fuse 42 in block. I have not yet checked fuse S102 (15A) - the ECM fuse, within the plenum chamber. It is not likely to be the cause, as there is no ECM code. This appears to be every fuse in the wiring diagram that touches the ABS controller.

I checked the two grounds, pins 1 and 5, for resistance from the harness connector. They had no resistance, but I have not checked them under load. I have not visually or mechanically inspected the ground locations yet.

Any idea about anything external that makes the pump turn on and off? Or why I hear a clicking noise from the footwell at 10 mph (coinciding with a BRAKE warning light?)

I do have the Bentley wiring diagram if that is of interest.

Thanks,
RichS
 
Last edited:
   #12  

RichS

Verified VCDS User
Verified
Joined
Aug 12, 2016
Messages
38
Reaction score
26
Location
USA
VCDS Serial number
C?ID=222890
resolved: S4 8H cab 2005 ABS 00301 return flow pump (V39) - resolved for the moment

Resolved for the last week / 300 miles - but I don't know why.

I exercised the ABS pump repeatedly, in both directions, and measured current flow - 11 amps at startup inrush current, stabilizing at 4 amps after 10 seconds, running for 30 seconds at a time, in both directions. I think the pump would only pump in one direction regardless of rotation, but I don't know for sure. In one of the polarities, it drew about one amp less. My next step was going to be to insert monitoring wires on the spring contacts between pump and ABS controller to see when / if potential was not present.

As I carefully re-installed the ABS controller for the 11th time, battery disconnection and all, and it exhibited the same pattern of errors as before. I gave up and pondered my next move - the dealer, which in Des Moines is a pretty reasonable place to discuss technical problems. They read my Ross-tech printouts, by the way, plus they have good coffee. In return I buy parts and some service from them.

I made my wife aware of the shortcomings for her 2 mile commute on a beautiful fall top-down day. I got a text from her:

"The ABS fairy paid us a visit - no codes".

Sure enough, no amount of thrashing would make the codes return. The indicator lights are present, properly, on startup. The clicking footwell relay at 10 MPH is no longer present. With the refinished (straightened) wheels and new tires, the car drives nicely. New observation: I never noticed before, but there was never a cruise control dashboard indicator light before, and now there is. Maybe there was some sort of other system problem that affected the ABS controller.
cheers, RichS
 
Top