A4 B9 Avant MY16 OEM alarm retrofit faults

   #1  

Ciamardo

Verified VCDS User
Verified
Joined
Jun 14, 2015
Messages
26
Reaction score
12
Location
Italy
VCDS Serial number
C?ID=105004
Hi guys, I retrofitted the complete alarm system on my A4 B9 which consists on a front alarm horn + the interior monitoring system. After doing that, I coded what was necessary on module 46 and I got the horn working (also beep on closing/opening works) but the interior monitoring system doesn't. I did an autoscan ad this is the fault it gives me (I post only the involved unit, the others are ok and have no faults):

Code:
Address 46: Central Conv. (J393)       Labels:* None
   Part No SW: 8W0 907 064 BC    HW: 8W0 907 064 C
   Component: BCM2 MLBevo   018 0327  
   Coding: 013400004F0000E0E38980006E00080031004000104702502F0400000504803F001F0000000000
   Shop #: WSC 06335 790 00001
   ASAM Dataset: EV_BCM2HellaAU736 011012
   ROD: EV_BCM2HellaAU736_011_AU49.rod
   VCID: 7EB0337EE13986BFEB-802A

   Sensor For Anti Theft Alarm System: 
   Subsystem 1 - Part No SW: 5Q0 951 177     HW: 5Q0 951 172 
   Component: Sensor, DWA  005 0316 
   Serial number: 000000000ZY161022GHN

   Alarm horn: 
   Subsystem 2 - Part No SW: 5Q0 951 605 A    HW: 5Q0 951 605 A
   Component: Sirene, DWA  005 0314 
   Serial number: 00000000000099623377

   Sensor Controlled Power Rear Lid: 
   Subsystem 3 - Part No SW: 3AA 962 243 G    HW: 3AA 962 243 G
   Component: GEB.F.Heckoef  H16 0903 
   Serial number: 84390097            

1 Fault Found:
65598 - Sensor 2 for interior monitoring 
          B1332 29 [008] - Signal Implausible
          Intermittent - Confirmed - Tested Since Memory Clear
             Freeze Frame:
                    Fault Status: 00000001
                    Fault Priority: 5
                    Fault Frequency: 70
                    Reset counter: 39
                    Mileage: 130471 km
                    Date: 2019.08.11
                    Time: 20:06:21

                    Supply voltages-Supply voltage: Terminal 30: 12.392 V
                    Supply voltages-Supply voltage Terminal 30 - 2: 12.419 V
                    Supply voltages-Supply voltage Terminal 30 - 3: 12.419 V
                    general_additional_freeze_frame-Ambient_temperature_not_filtered: -50.0 °C
                    general_additional_freeze_frame-coprocessor_spi_status: 00000000 
                    general_additional_freeze_frame-dataflash_status: 00000000 
                    general_additional_freeze_frame-interior_temperature: -50.0 °C
                    general_additional_freeze_frame-Operating_Status: 00000000 00000000 
                    general_additional_freeze_frame-production_mode: not active
                    general_additional_freeze_frame-reset_cause: 00000000 
                    general_additional_freeze_frame-Reset_counter: 0
                    general_additional_freeze_frame-Stall_current_cutoff_level: Deactivation stage 0
                    general_additional_freeze_frame-Stall_Current_Measuring_Mode: not active
                    general_additional_freeze_frame-subnetwork_status: 00000000 00000000 
                    general_additional_freeze_frame-terminal_control_intern_status: 40 04 5A 12 04 38
                    general_additional_freeze_frame-Transport_Mode: not active
                    general_additional_freeze_frame-Vehicle speed: 0.00 km/h
                    can_lin_communication_freeze_frame: 00000000 00000000 00000000 00000000
I checked the button for activation/deactivation of the interior monitoring system and it is correctly wired, as all the other connections. Plus, if I try to disconnect the interior sensors VCDS gives me a different error, like "no communication" or something similar, so I think the fault I have means that the sensors don't work and need to be changed.

Thank you for your help in advance!

Thomas
 
   #2  

siLc

Verified VCDS User
Verified
Joined
Jul 9, 2014
Messages
637
Reaction score
528
Location
Tallinn, Estonia
VCDS Serial number
C?ID=330192
The alarm sensor module 5Q0 951 172 has three sensors. If one is implausible, perhaps check its installation - is it secured in it's proper place?
 
   #3  

Ciamardo

Verified VCDS User
Verified
Joined
Jun 14, 2015
Messages
26
Reaction score
12
Location
Italy
VCDS Serial number
C?ID=105004
Thanks for your reply siLc, yes in fact it has three sensors and the fault is on sensor 2, but the part has only one connection for all the three sensors, so I don't know what to check....it seems one of the sensors is faulty right?
 
   #4  

siLc

Verified VCDS User
Verified
Joined
Jul 9, 2014
Messages
637
Reaction score
528
Location
Tallinn, Estonia
VCDS Serial number
C?ID=330192
I meant the sensors see through a plastic trim piece (usually a grille) to monitor the car interior. Perhaps sensor 2 is out of place and is monitoring a plastic piece inside the headliner, instead of the car interior. Did you buy the sensor module new or used?
 
   #5  

Ciamardo

Verified VCDS User
Verified
Joined
Jun 14, 2015
Messages
26
Reaction score
12
Location
Italy
VCDS Serial number
C?ID=105004
Oh ok, I will check them! I bought it used so maybe during the transport or removing someone moved the sensor...but is it possible that the whole system don't work just for a fault like this?!
 
   #7  

Ciamardo

Verified VCDS User
Verified
Joined
Jun 14, 2015
Messages
26
Reaction score
12
Location
Italy
VCDS Serial number
C?ID=105004
Is it the wrong area for this thread? If yes, sorry it is the first time for me....
 
   #10  

Ciamardo

Verified VCDS User
Verified
Joined
Jun 14, 2015
Messages
26
Reaction score
12
Location
Italy
VCDS Serial number
C?ID=105004
Solved! I replaced the interior monitoring sensors and now it works! So maybe sensor 2 was faulty like I thought since the beginning...thanks anyway for your help!
 
  • Like
Reactions: Uwe
Top