Audi A6 4g, C7, Gateway and EPS bench test - EPS Unreacheable

   #1  

colonna

Verified VCDS User
Verified
Joined
Apr 15, 2019
Messages
5
Reaction score
3
Location
Romania
VCDS Serial number
C?ID=334153
Dear All,
I`m new to this forum and i`m trying to bech test the Audi A6 (4g, C7) EPS on bech. In the past i did the same with EPS for Vw Passat B6 and worked like charm, using a passat B6 gateway, the correct wiring and VCDS.

For now I`ve connected the (Audi A6, 4G - >2011)Gateway on bech and connected to it using CAN, but in gives me the following error :

0276 - FlexRay Databus
U1032 00 [009] - Initialization Failed
Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 1
Reset counter: 85
Mileage: 149511 km
Date: 2018.05.24
Time: 09:44:01

Voltage terminal 30: 11.9 V
Voltage terminal 15: 11.9 V
Control Module temperature: 20 °C
System status: Terminal 15 on
IN ESP_standstill flag: no standstill detected
Engine running: OFF
IN ZAS_Te_X: OFF
Terminal 15 status via CAN: OFF
Terminal 15 status: On
Datenfeld: 0

Of course the EPS is connected as well, but it is connected on FlexRay pins of Gateway (Pin 24 + Flexray and Pin 8 - Flexray) ... and it`s not reacheble.
Any advice ?
I`ve triple checked the wiring and it`s correct, Maybe this EPS can be bech tested using different pins or approach, i`ve noticed the data plug has 6 pins but only 3 of them are in use. Now i`m using: Pin 2 - +12V, Pin 3 - positive Flexray (pink), Pin 5 - negative Flexray (Green) on the EPS ecu. How can i connect to this EPS on bech? I`m tired of try outs :(( the EPS is 100% ok, i`ve tested it on a car not long time a go. The gateway is accesible on bech without any issues, but EPS is unreacheble. The Gateway also has optical data on it. Maybe i should loop that connection ?
 
   #2  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
31,053
Reaction score
22,125
Location
USA
VCDS Serial number
HC100001
FlexRay isn't as flexible as CAN, you can't just wire up modules arbitrarily.

At one point I saw a training video from VAG about this, but I don't think it was on Youtube, and I can't find it at the moment.

-Uwe-
 
   #3  

colonna

Verified VCDS User
Verified
Joined
Apr 15, 2019
Messages
5
Reaction score
3
Location
Romania
VCDS Serial number
C?ID=334153
Thank you Uwe, this is the first reply on this thread. I know what you`re saying about flexibility of Flex Ray but i still need a way to communicate wth this kind of equpiment. If it works on the car, it should work on the bench. But how? Should i connect all ecus of a car on bech in order for the flexy ray to be initialized. The Gateway sais: "0276 - FlexRay Databus U1032 00 [009] - Initialization Failed" There must be a reason for this.

Thank you all for the help!
 
   #4  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
31,053
Reaction score
22,125
Location
USA
VCDS Serial number
HC100001
Thank you Uwe, this is the first reply on this thread. I know what you`re saying about flexibility of Flex Ray but i still need a way to communicate wth this kind of equpiment. If it works on the car, it should work on the bench. But how? Should i connect all ecus of a car on bech in order for the flexy ray to be initialized. The Gateway sais: "0276 - FlexRay Databus U1032 00 [009] - Initialization Failed" There must be a reason for this.
I don't know. We've not tried to do this on a bench ourselves.

Here's a screen-shot from the AoA training video I found again:



You should check the wiring diagrams for the car to see if the EPS is on the end of the chain or in the middle. I suppose you could determine that by measuring resistance across the + and - pins.

Then there's the question: How many FlexRay branches exist in the car itself? It is not clear to me what (if any) interaction there is between those branches.

Lastly, you mentioned only three pins in use:
Now i`m using: Pin 2 - +12V, Pin 3 - positive Flexray (pink), Pin 5 - negative Flexray (Green) on the EPS ecu.
It seems to me that somehow, this module needs a ground connection too.

-Uwe-
 
   #5  

colonna

Verified VCDS User
Verified
Joined
Apr 15, 2019
Messages
5
Reaction score
3
Location
Romania
VCDS Serial number
C?ID=334153
Hi Uwe, It has four branches. and J500 stand`s alone on one of them. The Flexray cable go directly to the EPS. I will try to add resistor on each branch, based on your graph, to to see if it works. This module has a different 2 pins Connector with Permenent + and -, the "-" is shared with the ecu. There is data transmision between all of them ... but before everything, the FlexRay must be initialized by the Gatwway.

Big Thanks for the idea! I wil try it and provide feedback!
 
Last edited:
   #6  

colonna

Verified VCDS User
Verified
Joined
Apr 15, 2019
Messages
5
Reaction score
3
Location
Romania
VCDS Serial number
C?ID=334153
I`ve tried using resistor to terminate the Flexray but without succes :( And, i also realized that on my gateway one branch is missing. J428 was not on this car :) I, also have Optical bus open circuit. Shoud i try to close the Optical bus ?
 
   #7  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
31,053
Reaction score
22,125
Location
USA
VCDS Serial number
HC100001
I doubt the optical bus has anything to do with this.

-Uwe-
 
   #8  

colonna

Verified VCDS User
Verified
Joined
Apr 15, 2019
Messages
5
Reaction score
3
Location
Romania
VCDS Serial number
C?ID=334153
It`s frustrating allready! I`m thinking to get all ecu`s for one car and do trials until i find the answer. I don`t know what i can try next :(
 
  • Like
Reactions: Uwe
Top