Audi side assist canbus connection

   #21  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
The problem sounds like the wires are plugged the wrong way around in the mirror. Turn them around and see if the error goes away.
That is quite possible since I had to cut off the connecting plug/socket on the lights and loom as they didn't match and replaced them with bullet connectors.
I'm away now for a few days but will try swapping the wires over when I get back.
Did you get the Golf system calibrated at a dealer after it was fitted? Is it an expensive job?
Thanks again for your help.
Russ
 
   #22  

myounus

Verified VCDS User
Verified
Joined
Oct 17, 2017
Messages
845
Reaction score
401
Location
Northwest UK
VCDS Serial number
C?ID=321059
No I didn't need to - it worked straight off. I used the original connectors but it was a pain connecting the wires to the mirrors. It was a full dismantle of each mirror to get the wires through.
 
  • Like
Reactions: Uwe
   #23  

andyhud

Verified VCDS User
Verified
Joined
Mar 6, 2016
Messages
191
Reaction score
80
Location
UK
VCDS Serial number
C?ID=32695
Russ

Have you coded and enabled the Side Assist LEDS on the door controllers that you connected them too?

You shouldn't need calibration but its always good to get it done at some point if your car is in at the dealer.
 
   #25  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
Russ

Have you coded and enabled the Side Assist LEDS on the door controllers that you connected them too?

You shouldn't need calibration but its always good to get it done at some point if your car is in at the dealer.
I'm not sure why I might need to code/enable the door controllers. The only connection that is made by the LEDs is back to the radar modules and thats where the coding was done.
I'll see how well they work and then decide if I need calibration. My local dealer is reluctant to perform the wok on a retrofit.
 
   #26  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
Again, not sure why the face palm?
There was a mismatch between the loom connectors and the LED connectors so I had to find an alternative. Unfortunately the wiring colours didn't correspond to the official diagrams. I tested the LEDs by supplying 12v to one terminal and then dropping the other to earth which made the lights come on. I know (some?) LEDs are polarity sensitive so assumed I'd got it right...
Is there a better way?
 
   #27  

myounus

Verified VCDS User
Verified
Joined
Oct 17, 2017
Messages
845
Reaction score
401
Location
Northwest UK
VCDS Serial number
C?ID=321059
I'm not sure why I might need to code/enable the door controllers. The only connection that is made by the LEDs is back to the radar modules and thats where the coding was done.
I'll see how well they work and then decide if I need calibration. My local dealer is reluctant to perform the wok on a retrofit.
Unless I'm mistaken and I apologise in advance but usually all door connections travel through the door control module. This sometimes requires replacement to one that supports side assist, however I've not seen your kit so cannot comment on it. It might have a direct loom and wired separately. Do check though..
 
   #28  

morski

Verified VCDS User
Verified
Joined
Jan 28, 2018
Messages
127
Reaction score
88
Location
Cheshire UK
VCDS Serial number
C?ID=90186
Side assist doesn't connect through the door module. It has its own loom directly back to the car
 
   #29  

andyhud

Verified VCDS User
Verified
Joined
Mar 6, 2016
Messages
191
Reaction score
80
Location
UK
VCDS Serial number
C?ID=32695
Side assist doesn't connect through the door module. It has its own loom directly back to the car
Fair enough, I know they go into the door modules on the Q7 4M so just assumed the same. Thanks for the clarity
 
   #30  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
Home again now and back working on the SQ5...
First thing I tried was to determine if the LEDs in the warning lights were polarity sensitive - they are.
Next was to see if I'd connected them correctly - I had.
Fired up VCDS and still getting the "short to Positive/open circuit" fault code.
I then checked the LEDs again and realised that the near side one was only lighting two of the four LEDs in the cluster.
I'm wondering whether this is causing the open circuit error? When I disconnect the faulty light, VCDS only reports one open circuit fault, ie the "good" light doesn't seem to be generating a fault code, so it seems likely.
I can't get access to the LED cells to investigate further so will have to wait until Monday and speak to the Audi dealer about a replacement - very frustrating!
Russ
 
   #31  

downtime

Verified VCDS User
Verified
Joined
May 27, 2017
Messages
1,936
Reaction score
1,167
Location
Finland
VCDS Serial number
C?ID=280813
The system does a check when starting that the leds are okay. If there’s a too big difference to reference current a fault is generated and it disables the BSD.
That’s why you cannot use the mirror cap leds with the newer 5Q0 BSD modules and vice versa.

Could be that the faulty BSD warning led is causing the system error in your case.
 
   #32  

DarkyUK

Verified VCDS User
Verified
Joined
Mar 10, 2015
Messages
70
Reaction score
11
Location
UK
VCDS Serial number
C?ID=61560
I'm not sure why I might need to code/enable the door controllers. The only connection that is made by the LEDs is back to the radar modules and thats where the coding was done.
I'll see how well they work and then decide if I need calibration. My local dealer is reluctant to perform the wok on a retrofit.
If this is a newer SQ5 I believe it supports things like Exit Assist etc also which can be enabled in the door controllers and requires some extra LED's in the door trims. Basically if you open the door and the rear radar sees something it lights the door up red to warn you.

The side assist can also be used for the rear assist to warn you when reversing.

Cheers, Andy
 
   #33  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
If this is a newer SQ5 I believe it supports things like Exit Assist etc also which can be enabled in the door controllers and requires some extra LED's in the door trims. Basically if you open the door and the rear radar sees something it lights the door up red to warn you.

The side assist can also be used for the rear assist to warn you when reversing.

Cheers, Andy
Sadly no, mine is a 2015 model so I only get the blind spot warning unfortunately....
 
   #34  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
Finally got my replacement warning light from Audi, rushed home to fit it and....same error codes (short to positive/open circuit) plus a new one U004700.
The new code seems to relate to an intermittent CAN bus issue.
I’ll attach the scan below.
I checked both the warning lights to see if all four LEDs in both lights were working - they are.
I checked to see if the lights were connected the right way - they are.
I checked to see if constant 12v was being supplied to the light – it is.
I checked continuity from the other light terminal back to the module.
Voltage on the permanent live is 12v and on the other terminal is 5.72v.
I checked continuity both wires from the Gateway back to the bumper module – all OK.
I checked continuity both wires to another point on the same Canbus circuit - all OK.

I had to extend the loom canbus wiring owing to the change from LHD to RHD(see earlier post). I got some wire slightly thicker than the original, twisted together, soldered connections and heat shrink and checked continuity.

This evening my wife, the usual driver of the SQ5, caually mentioned that she had seen the warning lights illuminate from time to time! This despite dash message the side assist not available!

To be honest I’m completely stumped so any ideas of what to check next would be very welcome..

Code:
Friday,17,August,2018,20:23:17:63302
VCDS -- Windows Based VAG/VAS Emulator Running on Windows 10 x64
VCDS Version: 18.2.1.5 (x64)
Data version: 20180518 DS287.2
www.Ross-Tech.com


VIN: WAUZZZ8R8FA079650   License Plate: CJ55RDJ



--------------------------------------------------------------------------------
--------------------------------------------------------------------------------


                Address 3C: Lane Change       Labels: 5Q0-907-566.clb
Control Module Part Number: 8T0 907 566 B    HW: 8T0 907 566 B
  Component and/or Version: SWA Master    H05 0071
           Software Coding: 010312
            Work Shop Code: WSC 06334 123 12345
              ASAM Dataset: EV_LaneChangAssis 001020 (AU48)
                       ROD: EV_LaneChangAssis_AU21.rod
                      VCID: 3F8CC8ECA68AFABC1D-806A
3 Faults Found:

512260 - Extended CAN Bus (SAE Bus C) 
          U0047 00 [008] - Performance
          [New feature! Extended UDS fault detail is only supported by current gen. interfaces]
          Intermittent - Confirmed - Tested Since Memory Clear
             Freeze Frame:
                    Fault Status: 00000001
                    Fault Priority: 6
                    Fault Frequency: 2
                    Reset counter: 221
                    Mileage: 34319 km
                    Date: 2018.08.03
                    Time: 23:27:04

730378 - Warning Lamp for Lane Change Assistance in Driver-Side Ext. Mirror 
          C1116 15 [009] - Open or Short to Plus
          Confirmed - Tested Since Memory Clear
             Freeze Frame:
                    Fault Status: 00000001
                    Fault Priority: 6
                    Fault Frequency: 1
                    Reset counter: 181
                    Mileage: 34319 km
                    Date: 2018.08.03
                    Time: 23:26:57

730634 - Warning Lamp for Lane Change Assistance in Passenger-Side Ext. Mirror 
          C1117 15 [009] - Open or Short to Plus
          Confirmed - Tested Since Memory Clear
             Freeze Frame:
                    Fault Status: 00000001
                    Fault Priority: 6
                    Fault Frequency: 1
                    Reset counter: 181
                    Mileage: 34319 km
                    Date: 2018.08.03
                    Time: 23:26:57
 
   #35  

downtime

Verified VCDS User
Verified
Joined
May 27, 2017
Messages
1,936
Reaction score
1,167
Location
Finland
VCDS Serial number
C?ID=280813
If you go to assist menu in instruments, does it show side assist as active? does it have the tick mark?

Are the LEDs 8R1949145A (left) and 8R1949146A (right)?

The control module needs to have led modules that are exactly for that module type.

One interesting thing I found from ETKA is that it show separate control switch for lane change assist : 8K1927451. I thought Q5 also has assist menu where it is controlled is the system on or off.
 
   #36  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
The side assist option is present but greyed out. When selected it says "This system currently unavailable"
The LED part numbers are correct and are unique to early Q7s and the Q5.
The on/off switch is correct and fits in the door triangle near the tweeter.
My modules are: 8T0 907 566b and 568b which I believe are correct for the car.

My car also has Lane Change Assist which is different - vibrates the steering wheel if you drift out of lane etc. That is controlled via the menu system.

Would I be correct in thinking that the LEDs are supplied with a constant 12v on one wire and the module switches to ground on the other wire so completing the circuit, when it needs to flash the LEDs?
 
   #37  

m87a

Verified VCDS User
Verified
Joined
Jan 6, 2015
Messages
582
Reaction score
327
Location
Bosnia and Herzegovina
VCDS Serial number
C?ID=156900
  • Like
Reactions: Uwe
   #38  

downtime

Verified VCDS User
Verified
Joined
May 27, 2017
Messages
1,936
Reaction score
1,167
Location
Finland
VCDS Serial number
C?ID=280813
Ok. It disables the system if any part of it is non-functional.

Part numbers look to be correct and yes, the modules control the leds directly. I found one thread in german vrs forum. One person has the same open or short to plus error and proposal was to switch the wires other way around to the led modules. Switch polarity.
It never was said that it if it fixed the problem thou :)
 
   #39  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
512260 - Extended CAN Bus (SAE Bus C)
U0047 00 [008] - Performance

there's your problem, can bus wires are senstive, worth to read

https://www.my-gti.com/991/performing-repairs-on-can-bus-wiring
M87a,
Looks like the Canbus error was down to me. I no longer needed the loom extension after switching the entry point from driver to passenger side so I cut out my addition and re-connected the original canbus wires and the fault went. Many thanks for your suggestion.

Now I'll try reversing the LED connections...
 
   #40  

RussJ

Verified VCDS User
Verified
Joined
Nov 22, 2016
Messages
47
Reaction score
11
Location
UK
VCDS Serial number
C?ID=288662
Sadly, no difference swapping the connections over.
 
Top