2018 Audi S6. Messed with module 5F, and still can't get AudiConnect to read SIM card

   #1  

elp_jc

Verified VCDS User
Verified
Joined
Jan 25, 2018
Messages
55
Reaction score
6
Location
El Paso, TX USA
VCDS Serial number
C?ID=323850
Hi gang. My new car was acting up when first activated AudiConnect. Tried to resolve the problem by turning 'Data Module' to OFF on the AudiConnect menu. After restarting the car, couldn't even get into the menu. It kept saying 'Please insert SIM card'. The weird thing is that before I inserted the first SIM card, I was able to get into the menu, and even changed the WiFi passcode and name. Now can't even get into the menu. Anyway, messed with module 5F today, which has like a gazillion options, and could only find ONE option that specifically said 'SIM', and it was this option:

IDE 10668 - Internal SIM card: use

It was switched to 'OFF'. The options are off, automatic, or always on. I switched it to 'automatic'. Reset the MMI, and got thru several screens after choosing AudiConnect, so was hopeful that resolved the issue. But after warnings and such, went back to 'Please insert SIM card'. Didn't go back and change it to 'always on', because don't think it'd change anything, but please let me know if it makes sense to do so. And the challenge for Uwe is if there's any other channel that you might recommend trying co change:D. I'm almost sure that has to be able to be corrected with VCDS, but need somebody willing to find the solution. Many thanks.
 
   #2  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
34,475
Reaction score
24,557
Location
USA
VCDS Serial number
HC100001
For context, there's an Auto-Scan here.

-Uwe-
 
   #3  

elp_jc

Verified VCDS User
Verified
Joined
Jan 25, 2018
Messages
55
Reaction score
6
Location
El Paso, TX USA
VCDS Serial number
C?ID=323850
What do you suggest Uwe? Change that IDE setting to 'always on', and see if that changes anything? Hopefully you'll have a chance to go thru all menu options and suggest which other channel might do the trick. Saw a lot that could be it, but it wasn't very clear. Saw several about WiFi, but didn't have trouble with it when AudiConnect was working. There has to be a way to reset that thing, or at least find out what's wrong, right? The issue has to be with the DATA MODULE. Hopefully there's a way to either reset it, or test it, to see if it went bad or what. Just want to know what's wrong with it. Thanks.

By the way, since I don't have any DTCs after clearing them, I don't think that fault is throwing any codes, right?
 
   #4  

Uwe

Benevolent Dictator
Staff member
Joined
Jan 29, 2014
Messages
34,475
Reaction score
24,557
Location
USA
VCDS Serial number
HC100001
I have no idea.

I also have zero personal experience with the newer MMI (module 5F) used in the C7.5 cars, sorry.

-Uwe-
 
   #5  

elp_jc

Verified VCDS User
Verified
Joined
Jan 25, 2018
Messages
55
Reaction score
6
Location
El Paso, TX USA
VCDS Serial number
C?ID=323850
Oh well. This new module is way harder to interpret than before; probably on purpose. And without the security code, I probably don't have access to many functions anyway. That was the other reason I wanted the security code for, but titled my other thread (about VIM) the wrong way, and Uwe closed it (justified). If you read this Uwe, it'd be nice if you delete that thread so I can start another one just asking for the security code, but if not, that's fine. Will have to get help on the Audi forums since you don't know about my car. But seems like I was defeated by this issue. Oh well. If I have to take my car to a dealer before the SIM card expires in 6 months (hopefully not), then I'd ask them to investigate that. Otherwise it'll stay like that. Thanks anyway.
 
   #6  

MasterTommy

Verified VCDS User
Verified
Joined
Dec 28, 2016
Messages
597
Reaction score
419
Location
Amsterdam
VCDS Serial number
C?ID=295586
You can't enable VIM on the 5F units in VW models through coding and/or adaptation channels. You have to change the parameters of the unit which VCDS cannot do. I suspect the same goes for Audi 5F units.
 
   #7  

elp_jc

Verified VCDS User
Verified
Joined
Jan 25, 2018
Messages
55
Reaction score
6
Location
El Paso, TX USA
VCDS Serial number
C?ID=323850
You can't enable VIM on the 5F units in VW models through coding and/or adaptation channels. You have to change the parameters of the unit which VCDS cannot do. I suspect the same goes for Audi 5F units.
It only makes sense Tommy, especially in this litigious country. At least this car doesn't disable the freaking nav when driving, since in both cases, the PASSENGERS are the ones messing with nav or watching movies. Thanks a lot for your reply Tommy. Hey, do you know how to make MMI access the AudiConnect menu and read the SIM card? Something happened to mine that can't get into it, but started another thread about that. Hopefully no bad news on that too. Ha ha. Thanks again for your great help.
 
   #8  

elp_jc

Verified VCDS User
Verified
Joined
Jan 25, 2018
Messages
55
Reaction score
6
Location
El Paso, TX USA
VCDS Serial number
C?ID=323850
Folks, now that I think of it, the entire blue screen message I also got after changing the 'IDE 10668- Internal SIM card: use' channel to 'auto' (from 'never'), was this: 'Data service is not available. Please insert a SIM card'. So the issue might be turning the data module back on, which was exactly what I turned off before it acted up. But without having the stupid menu to turn it back on, I need to find the proper channel. By the way, after turning the data module off, the option to turn it back on appeared on the menu, but after restarting the car, couldn't access the AudiConnect menu anymore. The reason I turned it off was to see if the media sources volume came back on, because I had no sound from media sources (files were playing on the MMI like if there was), but I did have sound on all other sources. When I turned engine back on, radio was working fine, but couldn't access AudiConnect anymore. Weird, huh? Now that I cleared all the myriad codes that were thrown that day, maybe everything would be fine if I'm able to turn that module back on. Maybe with this new direction, one of you can help me find the channel for the data module. I'm absolutely positive the solution is in module 5F, but we just have to find the right channel. Thanks.
 
Last edited:
Top