Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: 2012 Audi A8 MMI visible only for a few seconds after screen comes up

  1. #11
    Verified VCDS User
    Join Date
    Dec 2016
    Location
    NL
    Posts
    88
    Post Thanks / Like
    Quote Originally Posted by Stew View Post
    Well now its not any better, after spending a better part of the evening pulling out the trim from the dash, I was able to pull the head unit (cd player/sd card reader). The screen is still in the car because of a two wire connection on a ten pin connector doesn't seem to come undone, a youtube video definitely showed that they cut this wire. Anyway in all of my moving around components and wiring now the screen doesn't come on at all. Back at it on Monday.
    Even more evidence that this could be ‘just’ a wiring issue.

  2. #12
    Verified VCDS User
    Join Date
    Jan 2018
    Location
    USA
    Posts
    6
    Post Thanks / Like
    First I had to cut what I believe is the power to the display. There are two micro switches. The fully raised switch is broken, the metal tab is missing and can not push the switch. Now that I have gotten this far, I still can't remove the unit because the switches don't have disconnects on them and I don't want to cut anymore wires. I am going to try and bypass the micro switch in a always on position (jump the wires together) and see if it will work this way. I can't really see replacing the micro switch as the unit is very hard to work on in the car. Hopefully I can get the unit working without having to reinstall it all the way so I can do some test runs.

  3. Likes jyoung8607 liked this post
  4. #13
    FoRT jyoung8607's Avatar
    Join Date
    Feb 2014
    Location
    Cincinnati, OH
    Posts
    1,692
    Post Thanks / Like
    Quote Originally Posted by jyoung8607 View Post
    $5 says it's deploying and turning on as per normal, but there's some little microswitch that's supposed to tell it the screen has fully come out, and that isn't happening. So the display turns back off as it's not supposed to be on when inside the dash.
    Quote Originally Posted by Stew View Post
    ... There are two micro switches. The fully raised switch is broken, the metal tab is missing and can not push the switch.
    I accept Paypal.

    (no not really. good luck though.)
    Silence gives consent.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •