Results 1 to 8 of 8

Thread: Infrastructure mode not connecting to shop network

  1. #1
    Verified VCDS User
    Join Date
    Apr 2017
    Location
    USA
    Posts
    4
    Post Thanks / Like

    Infrastructure mode not connecting to shop network

    Hey guys,

    I purchased a Premium ProKit a few months ago to run in my shop, and for the life of me, cant get the Hex+Net interface to work. I have been getting by just using the Hex+Can interface for the past months but have been wanting to get the Hex+Net going. I've spoke with technical support a couple months back but was told to watch the videos and/or post here. I've watched every video, tried reading everything I could search about the issue, and got nowhere, so it sat in my diagnostic cart for the time being.

    Today I had a friend come over to help troubleshoot the problem and here is what we found:

    > We can connect to the Hex+Net dongle in Access Point mode
    > We cannot connect the Hex+Net in infrastructure mode to my shops WiFi router
    > However, it will connect to my friends cell phone hot-spot in infrastructure mode

    the troubleshooting we have done so far and have tried are:

    > We locked the routers WiFi channel from "Auto" to channel "1"

    Yes, the software is updated to latest version and dongle is updated.
    Yes all firewalls are disabled. Both windows and McAfee as this is my reprogramming laptop as well.
    My hardware is a ThinkPad X260, running windows 10.
    My router is a Netgear R8500.

    pleas help. Thanks
    Last edited by tyson.c; 05-17-2017 at 12:32 AM. Reason: More info

  2. #2
    FoRT jyoung8607's Avatar
    Join Date
    Feb 2014
    Location
    Cincinnati, OH
    Posts
    1,601
    Post Thanks / Like
    Quote Originally Posted by tyson.c View Post
    We cannot connect the Hex+Net in infrastructure mode to my shops WiFi router
    However, it will connect to my friends cell phone hot-spot in infrastructure mode
    ...
    We locked the routers WiFi channel from "Auto" to channel "1"
    ...
    My router is a Netgear R8500.
    When you try to connect it to your shop WiFi, what do you see on the HEX-NET LEDs? And, what do you see in the HEX-NET config utility?

    Jason

  3. Likes Uwe liked this post
  4. #3
    Verified VCDS User
    Join Date
    Apr 2017
    Location
    USA
    Posts
    4
    Post Thanks / Like
    Quote Originally Posted by jyoung8607 View Post
    When you try to connect it to your shop WiFi, what do you see on the HEX-NET LEDs? And, what do you see in the HEX-NET config utility?

    Jason
    Hey Jason, Thank you for the help,

    When I connect the unit via USB to PC and open VCDS, info and LED indicators are as follows:

    > USB Port Test:
    Port Status: OK
    Interface: Found!
    Version: CB0.4336.4
    FW: 0253
    WiFi:310C
    Status: Questionable
    CPU LED blinks Green
    WiFi LED blinks Red
    SSID: (Indicated my shops WiFi name)
    IP: 0.0.0.0
    Mode: Infrastructure
    Security: WPA/WAP2
    Uit: Registered

    --------------------------------------------------

    If I switch the unit to AP mode, info/LEDs are:
    IP: 192168.0.1
    Mode: AP
    Security: None
    CPU LED: blink Green
    WiFi LED: steady Amber

  5. #4
    Ross-Tech Employee
    Join Date
    Jan 2014
    Posts
    498
    Post Thanks / Like
    That looks like a wifi 5Ghz ac router, make sure that it has 2.4 GHz enabled and backwords-compatibility with wifi b/g enabled, there may be options to disable those features which will prevent the hex-net from working.

    Are you sure you entered the password correctly? It may be case sensitive. Otherwise, check what encryption settings your router is using. There are multiple flavors of WPA, some of which are incompatible with the hex-net. Try setting it to something like WPA2 Personal if it is set on something different.

    --Shaun

  6. Likes jyoung8607, Uwe liked this post
  7. #5
    Verified VCDS User
    Join Date
    Apr 2017
    Location
    USA
    Posts
    4
    Post Thanks / Like
    Quote Originally Posted by Shaun View Post
    That looks like a wifi 5Ghz ac router, make sure that it has 2.4 GHz enabled and backwords-compatibility with wifi b/g enabled, there may be options to disable those features which will prevent the hex-net from working.

    Are you sure you entered the password correctly? It may be case sensitive. Otherwise, check what encryption settings your router is using. There are multiple flavors of WPA, some of which are incompatible with the hex-net. Try setting it to something like WPA2 Personal if it is set on something different.

    --Shaun
    Hey Shaun, Thanks man,

    I will give this info to my friend and see what he can do. I know we did connect to both of the 2.4ghz signals instead of the 5. and I know we entered the password correctly (we tried multiple times to "forget network" and reattempt - both with correct password and known incorrect passwords - no change in operation)

    will update in a few
    Thanks so much again.

    Tyson

  8. Likes Uwe liked this post
  9. #6
    Verified VCDS User PetrolDave's Avatar
    Join Date
    Dec 2014
    Location
    South Molton, UK
    Posts
    574
    Post Thanks / Like
    What channel is the 2.4GHz transmitting on? If the router is choosing a channel outside the normal range for WiFi channels in the US then the HEX-NET won't be able to connect - I had this problem when I first got my HEX-NET.

  10. #7
    Verified VCDS User
    Join Date
    Apr 2017
    Location
    USA
    Posts
    4
    Post Thanks / Like
    Quote Originally Posted by Shaun View Post
    That looks like a wifi 5Ghz ac router, make sure that it has 2.4 GHz enabled and backwords-compatibility with wifi b/g enabled, there may be options to disable those features which will prevent the hex-net from working.

    Are you sure you entered the password correctly? It may be case sensitive. Otherwise, check what encryption settings your router is using. There are multiple flavors of WPA, some of which are incompatible with the hex-net. Try setting it to something like WPA2 Personal if it is set on something different.

    --Shaun
    Shaun, Ive tried messing with all of the settings in the router. Tried locking the speed to 433mbps, and 54mbps with no change in operation. I am going to try switching the security options around to see if that makes a difference. The options listed are; WPA2-PSK [AES] (this is the default and does not connect) - WPA-PSK [TKIP] + WPA2-PSK [AES] (i will try this) - and WPA/WPA2 Enterprise (i will try this)

    Quote Originally Posted by PetrolDave View Post
    What channel is the 2.4GHz transmitting on? If the router is choosing a channel outside the normal range for WiFi channels in the US then the HEX-NET won't be able to connect - I had this problem when I first got my HEX-NET.
    Dave, the router is defaulted to "auto channel" but i have tried locking it down to multiple different channels, ie; 1,2,3,etc with no success in connection.

    thanks guys, I'm still trying to get this thing to work and will keep you updated with the results. I appreciate all the help.

    Tyson

  11. #8
    Ross-Tech Employee
    Join Date
    Jan 2014
    Posts
    498
    Post Thanks / Like
    Before you get bogged down with trying a bunch of different encryption settings, it might be a good idea to test temporarily turning encryption off on the router. Forget the network on the hex-net, and make a new profile for the now un-encrypted network, and test if that will connect. If this still does not connect, then encryption is not your problem. If this does connect, then you know to start playing around with encryption settings.

    Of course, remember to turn encryption back on.

    --Shaun

  12. Likes jyoung8607, Uwe, Eric liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •